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Part |. Using jEdit

This part of the user's guide coversjEdit's text editing commands, along with basic usage of macros
and plugins.

This part of the user's guide was written by Slava Pestov <sl ava@ edi t . or g>.




Chapter 1. Conventions

Several conventions are used throughout jEdit's user interface and this manual. They will be
described here. Macintosh users should note how their modifier keys map to the terms used in the

manual.

View>Scrolling>Scroll to Current Line

The Scroll to Current Line command contained
in the Scrolling submenu of the View menu.

Edit>GotoLine..

Menu items that end with ellipsis (...) display
dialog boxes.

C The primary modifier key in jEdit. On MacOS
X, thisis actually the key known as
“Command’. On most other keyboards, this key
islabelled “Control”.

A The secondary modifier key in jEdit. On MacOS
X, thisis actually the key labelled “Control”. On
most other keyboards, thiskey islabelled “Alt”.

S The standard “ Shift” key.

Ct+o Refersto pressing and holding the Cont r ol
key, pressing and releasing O, and finally
releasing the Cont r ol key.

Ct+e CHj Refersto holding down Cont r ol , pressing E,
pressing J, and releasing Cont r ol .

Default buttons In many dialog boxes, the default button (it hasa

heavy outline, or a special border, depending on
the current Swing look and feel) can be activated
by pressing Ent er . Similarly, pressing Escape
will usually close adialog box.

Al t -key mnemonics

Some user interface elements (menus, menu
items, buttons) have a certain letter in their l1abel
underlined. Pressing this letter in combination
with the Al t key activates the associated user
interface widget. Note that this functionality is
not available on MacOS X with the “MacOS
Adaptive’ ook and feel. See the section called
“The Appearance Pane’ for information on
changing the look and feel.

Right mouse button

Used in jEdit to show context-sensitive menus. If
you have a one button Macintosh mouse, a
Cont r ol -click has the same effect.

Middle mouse button

Used by the quick copy feature (see the section
called “Quick Copy”). True 3-button mice are
rare these days. If you have awheel mouse, press
down on the whedl without rolling it. On a
Macintosh with a one-button mouse,

Opt i on-click. On other platforms without a
three-button mouse, Al t -click.




Chapter 2. Starting JEdit

Exactly how jEdit is started depends on the operating system. For example, on Unix you can run
“jedit” at the command line, or select jEdit from a menu; on Windows, you can double-click on the
jEdit icon or select it from the Start menu.

If jEdit is started while another copy is aready running, control is transferred to the running copy,
and a second instance is not loaded. This saves time and memory if jEdit is started multiple times.
Communication between instances of jEdit isimplemented using TCP/IP sockets; the initial
instance is known as the server, and subsequent invocations are clients.

If you find yourself launching and exiting jEdit alot, the startup time can get a bit bothersome. If the
- backgr ound command line switch is specified, jEdit will continue running and waiting for client
requests even after all editor windows are closed. When run in background mode, you can open and
close jEdit any number of times, only having to wait for it to start the first time. The downside of
thisisincreased memory usage.

When running on MacOS X, the - backgr ound command-line switch is active by default, so that
jEdit conforms to the platform convention that programs should stay open until the Quit command
is explicitly invoked by the user, even if all windows are closed. To disable background mode on
MacOS X, use the - nobackgr ound switch.

For more information about command line switches that control the server feature, see the section
called “Command Line Usage”.

jEdit remembers open buffers, views and split window configurations between editing sessions, so
you can get back to work immediately after starting jEdit. This feature can be disabled in the
General pane of the Utilities>Global Options dialog box see the section called “The General
Pane”.

Theedit server and security

Since Java does not provide any interprocess communication facility other than TCP/IP, jEdit takes
extra precautions to prevent remote attacks.

Not only does the edit server pick arandom TCP port number on startup, it also requires that clients
provide an authorization key; a randomly-generated number only accessible to processes running on
the local machine. So not only will “bad guys’ have to guess a 64-bit integer, they will need to get it
right on the first try; the edit server shutsitself off upon receiving an invalid packet.

In environments that demand absol ute security, the edit server can be disabled by specifying the
- noser ver command line switch.

Command Line Usage

On operating systems that support acommand line, jEdit can be passed various arguments to control
its behavior.

When opening files from the command line, aline number or marker to position the caret on can be
specified like so:

$ jedit MyApplet.java +line:10
$ jedit thesis.tex +marker:c
Command-line switches begin with a"-". Some take a parameter. A file whose name begins with "-"

can be opened like so:

$jedit -- -nyfile
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Miscellaneous Options

Option Effect

-1 og=l evel Set the minimum log level to an integer between 1 and 9. Default is 7.
Has no effect when connecting to another instance via the edit server.

- usage Show a brief command line usage message without starting jEdit. This
message is also shown if an invalid switch was specified.

-version Show the version number without starting jEdit.

-- Specifies the end of command-line processing. Further parameters are
treated as file names, even if they begin with a dash.

Configuration Options

Option Effect

-pl ugi ns Enable loading of plugins. Has no effect when connecting to another
instance viathe edit server. See Chapter 9, Installing and Using Plugins.

- nopl ugi ns Disable loading of plugins. Has no effect when connecting to another
instance viathe edit server.

-restore Restore previously open files on startup. Thisis the default. This feature

can also be set permanently in the General pane of the Utilities>Global
Options dialog box; see the section called “ The General Pane”.

-norestore Do not restore previously open files on startup.

-run=scri pt Run the specified BeanShell script. There can only be one of these
parameters on the command line. See the section called “Running
Scripts from the Command Line”.

-settings=dir Store user-specific settingsin the directory named di r , instead of the
default user . home/ . j edi t . Thedirectory will be created
automatically if it does not exist. Has no effect when connecting to
another instance viathe edit server. See the section called “ The jEdit
Settings Directory”.

-nosettings Start jEdit without loading user-specific settings.

-startupscripts Run startup scripts. Thisisthe default. Has no effect when connecting to
another instance via the edit server. See the section called “ Startup
Scripts”.

-nostartupscri pts |Disable startup scripts. Has no effect when connecting to another
instance viathe edit server.

Edit Server Options

See Chapter 2, Sarting jEdit for a brief description of the edit server.

Option Effect

- background Run jEdit in background mode. In background mode, the edit server will
continue listening for client connections even after all views are closed.
Has no effect when connecting to another instance via the edit server.

- nobackgr ound Disable background mode. This is the default. Has no effect when
connecting to another instance via the edit server.

-gui Open aninitial view. Thisisthe default. Has no effect when connecting
to another instance via the edit server.

- hogui Do not open aninitial view, and instead only open one when the first

client connects. Can only be used in combination with the
- backgr ound switch. You can use this switch to “pre-load” jEdit
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Option

Effect

when you log in to your computer, for example. Has no effect when
connecting to another instance via the edit server.

- newpl ai nvi ew

Opens the specified filesin anew plain view. For more information
about views, see the section called “Multiple Views”.

-newi ew Opens the specified filesin anew view.

-reusevi ew Opens the specified filesin an existing view.

-quit Exits the currently running editor instance.

-server Store the server port info in the file named ser ver inside the settings

directory.

-server =nane

Store the server port info in the file named nane. File names for this
parameter are relative to the settings directory.

- noserver Do not attempt to connect to arunning edit server, and do not start one
either.
-wai t K eeps the client open until the user closes the specified buffer in the

server instance. Does nothing if passed to the initial jEdit instance. Use
this switch if jEdit is being invoked by another program as an external
editor; otherwise the client will exit immediately and the invoking
program will assume you have finished editing the given file.




Chapter 3. JEdit Basics

Interface Overview

A view isthe jEdit term for an editor window. It is possible to have multiple views open at once, and
each view can be split into multiple panes. jEdit remembers the state of open views between editing
sessions.

An open fileisreferred to as a buffer. Unlike some editors where each buffer getsits own view,
jEdit completely separates the two concepts. A buffer might be visible in several views, or none at
l.

The drop-down list at the top of the view shows all open buffers; selecting one will make it visible
in the view's text area. Different emblems are displayed next to buffer namesin the list, depending
the buffer's state; ared disk is shown for buffers with unsaved changes, alock is shown for
read-only buffers, and a spark is shown for new buffers which don't yet exist on disk.

Aswith most other graphical applications, there isatool bar at the top of the view which provides
quick access to frequently-used commands. Also, clicking the text area with the right mouse button
displays a popup menu which also facilitates quick access to various commands. Both the tool bar
and the right-click menu can be completely customized to suit your tastes in the Utilities>Global
Optionsdialog box; see the section called “ The Context Menu Pane” and the section called “The
Tool Bar Pane”.

Most of the view istaken up by the text area. If you've ever used a graphical user interface before,
the text areawill be instantly familiar. Text can be inserted simply by typing. More details on text
insertion and deletion can be found in the section called “ Inserting and Deleting Text”.

The strip on the |eft of the text areais called a gutter. The gutter displays marker and register
locations, as well asfolding arrows; it will also display line numbersif the View>Line Numbers
(shortcut: C+e C+t ) command isinvoked. Note this command only takes effect until the view is

closed. To have line numbers visible al the time, enable the appropriate setting in the Gutter pane
of the Utilities>Global Options dialog box.

Switching Buffers

In addition to using the drop-down list at the top of the view, as documented in the previous section,
the current buffer can also be switched using menu item commands and their keyboard shortcuts.

View>Go to Previous Buffer (keyboard shortcut: C+PAGE_UP) switches to the previous buffer in
thelist.

View>Go to Next Buffer (keyboard shortcut: C+PAGE_DOWN) switches to the next buffer in the
list.

View>Go to Recent Buffer (keyboard shortcut: C+BACK _QUOTE) flips between the two most
recently edited buffers.

View>Show Buffer Switcher (keyboard shortcut: A+BACK_QUOTE) has the same effect as
clicking on the buffer switcher combo box.

If you prefer an alternative graphical paradigm for switching buffers, take alook at one of these
plugins:

» BufferList

* BufferSelector

 BufferTabs
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If you decide to use one of these plugins, you can hide the popup menu buffer switcher in the View
pane of the Utilities>Global Options dialog box.

A number of plugins that implement fast keyboard-based buffer switching are available as well:

* FastOpen
e Openlt
» SwitchBuffer

Multiple Views

As documented at the beginning of this chapter, multiple views can be opened at once, and views
can be split into multiple panes.

View>New View creates anew view.

View>New Plain View creates a new view but without any tool bars or docked windows. This can
be used to open a small window for taking notes and so on.

View>Close View closes the current view. If only one view is open, closing it will exit jEdit, unless
background mode is on; see Chapter 2, Sarting jEdit for information about starting jEdit in
background mode.

View>Split Horizontally (shortcut: C+2) splitsthe view into two text areas, placed above each
other.

View>Split Vertically (shortcut: C+3) splits the view into two text areas, placed next to each other.
View>Unsplit Current (shortcut: C+0) removes the split containing the current text area only.
View>Unsplit All (shortcut: C+1) removes all splits from the view.

When aview is split, editing commands operate on the text area that has keyboard focus. To give a
text area keyboard focus, click in it with the mouse, or use the following commands.

View>Go to Previous Text Area (shortcut: A+PAGE_UP) shifts keyboard focus to the previous
text area.

View>Go to Next Text Area (shortcut: A+PAGE _DOWN) shifts keyboard focus to the next text
area.

Window Docking

Various jEdit and plugin windows can be docked into the view for convenience. Dockable windows
have a popup button in their top-left corner. Clicking this button displays a menu with commands
for docking the window in one of four sides of the view.

On each side of the text area where there are docked windows, a strip of buttonsis shown. Thereisa
button for activating each docked window, as well as a close box and a popup menu button, which
when clicked shows a menu for moving or undocking the currently selected window. The popup
menu also contains a command for opening a new floating instance of the current window.

The commands in the View>Docking menu move keyboard focus between docking areas.

Dockable windows can a so be configured in the Docking pane of the Utilities>Global Options
dialog box.
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For power users

Each dockabl e has three commands associated with it; oneis part of the menu bar and opens the
dockable. The other two commands are:

« Window Name (Toggle) - opens the dockable window if it is hidden, and hide it if its already
open.

* Window Name (New Floating I nstance) - opens a new instance of the dockable in afloating
window, regardless of the docking configuration. For example, this can be used to view two
different directories side-by-side in two file system browser windows.

A new floating instance can also be opened from the dockable window's popup menu.
These commands cannot be invoked from the menu bar. However, they can be added to the tool bar

or context menu, and given keyboard shortcuts; see the section called “ The Global Options Dialog
Box".

The Status Bar

The status bar at the bottom of the view consists of the following components, from left to right:

» Theline number containing the caret

* The column position of the caret, with the leftmost column being 1.
If the line contains tabs, the file position (where a hard tab is counted as one column) is shown
first, followed by the screen position (where each tab counts for the number of columns until the
next tab stop).

Double-clicking on the caret location indicator displays the Edit>Go to Line diaog box; see the
section called “Working With Lines’.

* A message area where various prompts and status messages are shown.

» The current buffer's edit mode, fold mode, and character encoding. Double-clicking one of these
displays the Utilities>Buffer Options dialog box. For more information about these settings,
see:

» thesection called “ The Buffer Options Dialog Box”
» thesection caled “Edit Modes”

» thesection called “ Folding”

» thesection called “ Character Encodings’

» A setof flags which indicate various editor features and settings. Clicking each flag will toggle
the feature in question; hovering the mouse over aflag will show atool tip with an explanation:
* Word wrap - see the section called “Wrapping Long Lines’.

* Multiple selection - see the section called “Multiple Selection”.

* Rectangular selection - see the section called “Rectangular Selection”.
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* Overwrite mode - see the section called “Inserting and Deleting Text”.
e Line separator - see the section called “Line Separators’.
* A Javaheap memory usage indicator, that shows used and total heap memory, in megabytes.

Double-clicking thisindicator opens the Utilities>Troubleshooting>Memory Status dialog
box.

The visibility of each of the above items can be controlled in the Status Bar pane of the
Utilities>Global Options dialog box; see the section called “ The Status Bar Pane”.

The Action Bar

The action bar allows almost any editor feature to be accessed from the keyboard.
Utilities>Action Bar (shortcut: C+ENTER) displays the action bar at the bottom of the view and
givesit keyboard focus. The action bar remembers previously entered strings; see Appendix C,
History Text Fields for details.

To use the action bar, input acommand and press Ent er . The following commands are supported:

Action invocations

Each menu item and tool bar button is bound to an action. To find out the name of an action, invoke
the menu item or click the tool bar button, and ook in the action bar's history.

If asubstring or an action name is entered, pressing Tab shows a popup listing matching actions.
An action can be selected using the Up and Down arrow keys, or by entering more characters of its
name.

Pressing Ent er with an incomplete substring invokes the action that would be first in the
completion popup's list.

For example, entering | - o will match gl obal - opt i ons, which has the same effect asinvoking
Utilities>Global Options.

Buffer-local properties

Entering buf f er . pr opert y=val ue setsthe vaue of the buffer-local property named
property toval ue. Buffer-local properties are documented in the section called “Buffer-Local
Properties”.

For example, entering buf f er . t abSi ze=4 changes the current buffer's tab size to 4.

See the section called “Buffer-Local Properties’ for information about buffer-local properties.
Global properties
Entering pr oper t y=val ue setsthe value of the global property named pr operty toval ue.

Thisfeature is primarily intended to help plugin developers, since the properties jEdit uses to store
its settings are not currently documented.

Command repetition

To repeat acommand multiple times, enter a number in the action bar, then invoke the command.
For example, “C+ENTER 1 4 C+d” will delete 14 lines; “C+ENTER 9 #” will insert “ tHtHHHHH#
in the buffer.
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If you specify arepeat count greater than 20, a confirmation dialog box will be displayed, asking if
you really want to perform the action. This prevents you from hanging jEdit by executing a
command too many times.
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Creating New Files

File>New (shortcut: C+n) opens a new, empty, buffer. Another way to create anew file isto specify
a non-existent file name when starting jEdit on the command line. A new file will be created on disk
when the buffer is saved for the first time.

Opening Files

File>Open (shortcut: C+o0) displays afile system browser dialog box and |oads the specified file
into a new buffer.

Multiple files can be opened at once by holding down Cont r ol while clicking on them in the file
system browser. The file system browser supports auto-completion; typing the first few characters
of alisted file name will select the file.

More advanced features of the file system browser are described in the section called “The File
System Browser”.

The File>Recent Files menu lists recently viewed files. When arecent fileis opened, the caret is
automatically moved to its previous location in that file. The number of recent files to remember can
be changed and caret position saving can be disabled in the General pane of the Utilities>Global
Options dialog box; see the section called “ The Genera Pane”.

The Utilities>Current Directory menu lists al files and directories in the current buffer's directory.
Selecting afile opensit in abuffer for editing; selecting a directory opensit in the file system
browser (see the section called “The File System Browser”).

Note

Files that you do not have write access to are opened in read-only mode, where editing is
not permitted.

Tip

jEdit supports transparent editing of GZipped files; if afile begins with the GZip “magic
number”, it is automatically decompressed before loading and compressed when saving. To
compress an existing file, you need to change a setting in the Utilities>Buffer Options
diaog box; see the section called “ The Buffer Options Dialog Box” for details.

Saving Files
Changed made in a buffer do not affect the file on disk until the buffer is saved.

File>Save (shortcut: C+s) saves the current buffer to disk.

File>Save As renames the buffer and savesit in a new location. Note that using this command to
save over another open buffer will close the other buffer, to stop two buffers from being able to
share the same path hame.

File>Save a Copy As saves the buffer to different location but does not rename it., but doesn't
rename the buffer, and doesn't clear the “maodified” flag. Note that using this command to save over
another open buffer will automatically reload the other buffer.

File>Save All (shortcut: C+e C+s) saves all open buffersto disk, asking for confirmation first. The
confirmation dialog can be disabled in the General pane of the Utilities>Global Optionsdialog
box.
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Two-Stage Save

To prevent dataloss in the unlikely case that jEdit should crash in the middle of saving afile, files
arefirst saved to atemporary file named #f i | enane#save#. If thisoperation is successful, the
origina fileis replaced with the temporary file.

However, in some situations, this behavior is undesirable. For example, on Unix this creates a new
i-node so while jEdit retains file permissions, the owner and group of thefilearereset, and if itisa
hard link the link is broken. The “two-stage save” feature can be disabled in the General pane of the
Utilities>Global Options dialog box; see the section called “The General Pane”.

Autosave and Crash Recovery

The autosave feature protects your work from computer crashes and such. Every 30 seconds, all
buffers with unsaved changes are written out to their respective file names, enclosed in hash (“#”)
characters. For example, pr ogr am c¢ will be autosaved to #pr ogr am c#.

Saving a buffer using one of the commands in the previous section automatically deletes the
autosave file, so they will only ever be visible in the unlikely event of a jEdit (or operating system)
crash.

If an autosave file is found while a buffer is being loaded, jEdit will offer to recover the autosaved
data.

The autosave interval can be changed in the Autosave and Backup pane of the Utilities>Global
Options dialog box; see the section called “ The Autosave and Backup Pane”.

Backups

The backup feature can be used to roll back to the previous version of afile after changes were
made. When a buffer is saved for the first time after being opened, its original contents are “backed
up” under adifferent file name.

The behavior of the backup feature is specified in the Autosave and Backup pane of the
Utilities>Global Options dialog box; see the section called “ The Autosave and Backup Pane”.”

The default behavior isto back up the original contents to the buffer's file name suffixed with atilde
(“~"). For example, afile named paper . t ex isbacked up to paper . t ex~.

e TheMax number of backups setting determines the number of backups to save. Setting thisto
zero disables the backup feature. Settings this to more than one adds nhumbered suffixesto file
names. By default only one backup is saved.

» If the Backup directory setting is non-empty, backups are saved in that location. Otherwise,
they are saved in the same directory asthe origina file. The latter is the default behavior.

* TheBackup filename prefix setting is the prefix that is added to the backed-up file name. This
is empty by default.

» TheBackup filename suffix setting is the suffix that is added to the backed-up file name. This
is“~" by default.

» Backups can optionally be saved in a specified backup directory, instead of the directory of the
origina file. This can reduce clutter.

» TheBackup on every save option is off by default, which results in a backup only being created
the first time a buffer is saved in an editing session. If switched on, backups are created every
time a buffer is saved.

12



Working With Files

Line Separators

Unix systems use newlines (\ n) to mark line endingsin text files. The MacOS uses carriage-returns
(\ r). Windows uses a carriage-return followed by anewline (\ r \ n). jEdit can read and write files
in al three formats.

Theline separator used by the in-memory representation of file contents is always the newline
character. When afileis being loaded, the line separator used in thefileon disk is stored in a
per-buffer property, and al line-endings are converted to newline characters for the in-memory
representation. When the buffer is consequently saved, the value of the property replaces newline
characters when the buffer is saved to disk.

There are several waysto change a buffer'sline separator:

* Inthe Utilities>Buffer Options dialog box. See the section called “ The Buffer Options Dialog
Box”.

» By clicking the line separator indicator in the status bar. See the section called “ The Status Bar”.

» From the keyboard, if a keyboard shortcut has been assigned to the Toggle L ine Separ ator
command in the Shortcuts pane of the Utilities>Global Options dialog box. By default, this
command does not have a keyboard shortcut.

By default, new files are saved with your operating system'’s native line separator. This can be
changed in the General pane of the Utilities>Global Options dialog box; see the section called
“The General Pane’. Note that changing this setting has no effect on existing files.

Character Encodings

A character encoding is a mapping from a set of charactersto their on-disk representation. jEdit can
use any encoding supported by the Java platform.

Buffersin memory are always stored in UTF- 16 encoding, which means each character is mapped
to an integer between 0 and 65535. UTF- 16 isthe native encoding supported by Java, and has a
large enough range of characters to support most human languages.

When abuffer isloaded, it is converted from its on-disk representation to UTF- 16 using a specified
encoding.

The default encoding, used to load files for which no other encoding is specified, can be set in the
General pane of the Utilities>Global Options dialog box; see the section called “ The General
Pane’. Unless you change this setting, it will be your operating system'’s native encoding, for
example Mac Roman on the MacOS, wi ndows- 1252 on Windows, and | SO- 8859- 1 on Unix.

An encoding can be explicitly set when opening afile in the file system browser's
Commands>Encoding menu.

Note that there is no general way to auto-detect the encoding used by afile, however in afew cases
itispossible:

» UTF- 16 and UTF- 8Y files are auto-detected, because they begin with a certain fixed character
sequence. Note that plain UTF-8 does not mandate a specific header, and thus cannot be
auto-detected, unless the filein question isan XML file.

* Encodings used in XML fileswith an XML Pl like the following are auto-detected:

<?xm version="1.0" encodi ng="UTF-8">
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The encoding that will be used to save the current buffer is shown in the status bar, and can be
changed in the Utilities>Buffer Options dialog box. Note that changing this setting has no effect on
the buffer's contents; if you opened afile with the wrong encoding and got garbage, you will need to
reload it.

If afileis opened without an explicit encoding specified and it appearsin the recent file list, jEdit
will use the encoding last used when working with that file; otherwise the default encoding will be
used.

Commonly Used Encodings

While the world is slowly converging on UTF-8 and UTF-16 encodings for storing text, awide
range of older encodings are still in widespread use and Java supports most of them.

The simplest character encoding still in useis ASCII, or “ American Standard Code for Information
Interchange”. ASCII encodes Latin letters used in English, in addition to numbers and a range of
punctuation characters. Each each ASCII character consists of 7 bits, thereisalimit of 128 distinct
characters, which makes it unsuitable for anything other than English text. jEdit will load and save
filesas ASCII if the US- ASCI | encoding is used.

Because ASCI| is unsuitable for international use, most operating systems use an 8-bit extension of
ASCII, with the first 128 values mapped to the ASCII characters, and the rest used to encode
accents, umlauts, and various more esoteric used typographical marks. The three major operating
systems all extend ASCII in adifferent way. Files written by Macintosh programs can be read using
the Mac Roman encoding; Windows text files are usually stored aswi ndows- 1252. In the Unix
world, the 8859 _1 character encoding has found widespread usage.

On Windows, various other encodings, referred to as code pages and identified by number, are used
to store non-English text. The corresponding Java encoding name iswi ndows- followed by the
code page number, for example wi ndows- 850.

Many common cross-platform international character sets are also supported; KO 8 R for Russian
text, Bi g5 and GBK for Chinese, and SJ| S for Japanese.

The File System Browser

Utilities>File System Browser displays the file system browser. By default, the file system browser
is shown in afloating window. This window can be docked using the commands in its top-left
corner popup menu; see the section called “Window Docking”.

Thefile system browser can be customized in the Utilities>Global Options dialog box; see the
section called “ The File System Browser Panes’.

Navigating the File System

The directory to browse is specified in the Path text field. Clicking the mouse in the text field
automatically selects its contents allowing a new path to be quickly typed in. If arelative pathis
entered, it will be resolved relative to the current path. This text field remembers previously entered
strings; see Appendix C, History Text Fields. The same list of previously browsed directoriesis also
listed in the Utilities>Recent Directories menu; selecting one opensit in the file system browser.

To browse alisted directory, double-click it (or if you have a three-button mouse, you can click the
middle mouse button as well). Alternatively, click the disclosure widget next to a directory to list its
contentsin place. To browse higher up in the directory hierarchy, double-click one of the parent
directoriesin the parent directory list.

Files and directoriesin the file list are shown in different colors depending on what glob patterns
their names match. The patterns and colors can be customized in the File System Browser>Colors
pane of the Utilities>Global Options dialog box.

To see a specific set of files only (for example, those whose names end with . j ava), enter aglob
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pattern in the Filter text field. Thistext fields remembers previously entered strings. See
Appendix D, Glab Patterns for information about glob patterns.

Unopened files can be opened by double-clicking (or by clicking the middle mouse button). Open
files have their names underlined, and can be selected by single-clicking. Holding down Shi f t
while opening afile will open it in anew view.

Clicking afile or directory with the right mouse button displays a popup menu containing various
commands.

Tip
Thefilelist sorting algorithm used in jEdit handles numbersin file namesin an intelligent
manner. For example, afile named sect i on10. xm will be placed after afile named

section5. xm . A conventional |etter-by-letter sort would have placed these two filesin
the wrong order.

The Tool Bar

The file system browser has atool bar containing a number of buttons. Each item in the Commands
menu (described below) except Show Hidden Files and Encoding has a corresponding tool bar
button.

The Commands Menu

Clicking the Commands button displays a menu containing the following items:

» Parent Directory - moves up in the directory hierarchy.
» Reload Directory - reloads thefile list from disk.

» Root Directory - on Unix, goesto theroot directory (/ ). On Windows and MacOS X, lists al
mounted drives and network shares.

 HomeDirectory - displays your home directory.
» Directory of Current Buffer - displays the directory containing the currently active buffer.

* New File- opens new, empty, buffer in the current directory. The file will not actually be
created on disk until the buffer is saved.

» New Directory - creates anew directory after prompting for the desired name.

e Searchin Directory - displays the search and replace dialog box set to search al filesin the
current directory. If afileis selected when this command isinvoked, its extension becomes the
file name filter for the search; otherwise, the file name filter entered in the browser is used. See
the section called “ Search and Replace” for details.

» Show Hidden Files- togglesif hidden files are to be shown in thefile list.

» Encoding - amenu for selecting the character encoding to use when opening files. See the
section called “ Character Encodings”.

The Plugins Menu

Clicking the Plugins button displays a menu containing plugin commands. For information about
plugins, see Chapter 9, Installing and Using Plugins.

The Favorites Menu
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Clicking the Favorites button displays a menu showing all files and directoriesin the favorites list.
The Add to Favoritesitem adds the currently selected file to the favorites list. If nothing is selected,
the current directory is added. To remove afile from the favorites, invoke Edit Favorites, which
will show the favoriteslist in the file system view, then select Delete from the right-click menu of
the entry you want to remove.

Keyboard Shortcuts

Completion behaves differently in file dialogs than in the stand-alone file system browser window.

In the file dialog, keyboard input goesin the file name field by default. Pressing Ent er opensthe
file or directory path that is either fully or partially entered in the file name field. Typing the first
few characters of afile's name selectsthat file. If the file name field is empty and nothing is
selected, / liststhe root directory on Unix and the list of drives on Windows. There are two handy
abbreviations that may be used in file paths: ~ expands to the home directory, and - expands to the
current buffer's directory.

For example, to open afile/ hone/ sl ava/ j Edi t / doc/ TODO. t xt , you might enter
~/j/ldlto.

In the stand-al one file system browser, keyboard input is handled sightly differently. Thereisno
file name field, instead shortcuts are active when the file tree has keyboard focus. Additionaly,
pressing/ , ~ or - alwaysimmediately goes to the root, home and current buffer's directory,
respectively.

Reloading From Disk

When aview is brought to the foreground, jEdit checks if any open buffers were modified on disk
by another application. All affected buffers are listed in adialog box. By default, buffers without
unsaved changes are automatically reloaded. This feature can be disabled, or changed to prompt if
files should be reloaded first, in the General pane of the Utilities>Global Options dialog box; see
the section called “ The Global Options Dialog Box”.

File>Reload can be used to reload the current buffer from disk at any other time; a confirmation
dialog box will be displayed first if the buffer has unsaved changes.

File>Reload All discards unsaved changesin all open buffers and reload them from disk, asking for
confirmation first.

Multi-Threaded I/O

To improve responsiveness and perceived performance, jEdit executes all buffer input/output
operations asynchronously. While 1/O isin progress, the status bar displays the number of remaining
1/O operations.

The Utilities>Troubleshooting>1/O Progress Monitor command displays a window with more
detailed status information and progress meters. By default, the 1/O Progress Monitor isshownin a
floating window. This window can be docked using the commands in its top-left corner popup

menu; see the section called “Window Docking”. I/O requests can also be aborted in this window,
however note that aborting a buffer save can result in dataloss.

Printing

File>Print (shortcut: C+p) prints the current buffer.

File>Page Setup displays adiaog box for changing your operating system's print settings, such as
margins, page size, print quality, and so on.

The print output can be customized in the Printing pane of the Utilities>Global Optionsdialog
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box; see the section called “ The Printing Pane”. The following settings can be changed:

* Thefont to use when printing.

» If aheader with the file name should be printed on each page.

» If afooter with the page number and current date should be printed on each page.
e If line numbers should be printed.

» If the output should be color or black and white.

e Thetab size to use when printing - thiswill usually be less than the text areatab size, to
conserve space in the printed output.

Closing Files and Exiting JEdit

File>Close (shortcut: C+w) closes the current buffer. If it has unsaved changes, jEdit will ask if they
should be saved first.

File>Close All (shortcut: C+e C+w) closes all buffers. If any buffers have unsaved changes, they
will be listed in adialog box where they can be saved or discarded. In the dialog box, multiple
buffers to operate on at once can be selected by clicking on them in the list while holding down
Cont r ol . After all buffers have been closed, a new untitled buffer is opened.

File>Exit (shortcut: C+q) will completely exit jEdit, prompting if unsaved buffers should be saved
first.
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Moving The Caret

The simplest way to move the caret is to click the mouse at the desired location in the text area. The
caret can also be moved using the keyboard.

The LEFT, Rl GHT, UP and DOMN keys move the caret in the respective direction, and the
PACGE_UP and PACGE_DOWN keys move the caret up and down one screenful, respectively.

When pressed once, the HOVE key moves the caret to the first non-whitespace character of the
current screen line. Pressing it a second time moves the caret to the beginning of the current buffer
line. Pressing it athird time moves the caret to the first visible line.

The END key behaves in asimilar manner, going to the last non-whitespace character of the current
screen ling, the end of the current buffer line, and finally to the last visibleline.

If soft wrap is disabled, a“screen line” isthe same as a* buffer line”. If soft wrap is enabled, a
screen lineis a section of a newline-delimited buffer line that fits within the wrap margin width. See
the section called “Wrapping Long Lines’.

C+HOVE and C+END move the caret to the beginning and end of the buffer, respectively.

More advanced caret movement is covered in the section called “Working With Words”, the section
called “Working With Lines” and the section called “Working With Paragraphs”.

The Home and End keys

If you prefer more traditional behavior for the HOVE and END keys, you can reassign the respective
keyboard shortcuts in the Shortcuts pane of the Utilities>Global Options; see the section called
“The Shortcuts Pane”.

By default, the shortcuts are assigned as follows:

 HQOVE isbound to Smart Home.

END is bound to Smart End.

e S+HOVE is bound to Select to Smart Home Position.

S+END is bound to Select to Smart End Position.

However you can rebind them to anything you want, for example, various combinations of the
following, or indeed any other command or macro:

» Goto Start/End of White Space.

+ Goto Start/End of Line.

* Goto Start/End of Buffer.

e Select to Start/End of White Space.

» Select to Start/End of Line.

» Select to Start/End of Buffer.
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Selecting Text

A selection isablock of text marked for further manipulation. Range selections are equivalent to
selections in most other text editors; they cover text between two pointsin a buffer. jEdit also allows
rectangular selections that cover arectangular area (some text editors refer to these as “ column
selections’). Furthermore, several chunks of text can be selected and operated on simultaneously.

Range Selection

Dragging the mouse creates a range sel ection from where the mouse was pressed to where it was
released. Holding down Shi f t while clicking alocation in the buffer will create a selection from
the caret position to the clicked location.

Holding down Shi f t in addition to a caret movement key (LEFT, UP, HOVE, etc) will extend a
selection in the specified direction.

Edit>Select All (shortcut: C+a) selects the entire buffer.

Edit>M or e Selection>Select None (shortcut: ESCAPE) deactivates the selection.

Rectangular Selection

Dragging with the Cont r ol key held down will create a rectangular selection. Holding down
Shi ft and Cont r ol while clicking alocation in the buffer will create a rectangular selection
from the caret position to the clicked location.

Alternatively, invoking Edit>M or e Selection>Rectangular Selection (shortcut: A+\ ) toggles
rectangular selection mode. In rectangular selection mode, dragging the mouse always creates a
rectangular selection, and keyboard commands that would normally create a range selection create a
rectangular selection instead. A status bar indicator is shown when this mode is enabled.

It is possible to select a rectangle with zero width but non-zero height. This can be used to insert a
new column between two existing columns, for example. Such zero-width selections are shown asa
thin vertical line.

Inserting text into a rectangular selection repeats the text going down as many times as necessary,
and shifts the selection to the right. This makesit behave like a“tall” caret.

Rectangles can be deleted, copied, pasted, and operated on using ordinary editing commands. If
necessary, rectangular selections are automatically filled in with whitespace to maintain alignment.

Rectangular selections can extend beyond the end of alineinto “virtual space’. Furthermore, if
keyboard rectangular selection modeison or if the Cont r ol key isbeing held down, clicking
beyond the end of aline will insert the appropriate amount of whitespace in order to position the
cursor at the clicked location.

Note

Rectangular selections are implemented using character offsets, not absol ute screen
positions, so they might not behave as you might expect if a proportional -width font is
being used or if soft wrap is enabled. The text area font can be changed in the Text Area
pane of the Utilities>Global Options dialog box. For information about soft wrap, see the
section called “Wrapping Long Lines’.

Multiple Selection

Edit>M or e Selection>M ultiple Selection (keyboard shortcut: C+\ ) turns multiple selection mode
on and off. In multiple selection mode, multiple fragments of text can be selected and operated on
simultaneously, and the caret can be moved independently of the selection. The status bar indicates
if multiple selection mode is active; see the section called “The Status Bar”.
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Various jEdit commands behave differently with multiple selections:

» Commands that copy text place the contents of each selection, separated by line breaks, in the
specified register.

» Commands that insert (or paste) text replace each selection with the entire text that is being
inserted.

e Commands that filter text (such as Spacesto Tabs, Range Comment, Replace in Selection,
and so on) behave asif each block was selected independently, and the command invoked on
eachinturn.

e Line-based commands (such as Shift Indent L eft, Shift Indent Right, and Line Comment)
operate on each line that contains at least one selection.

» Caret movement commands that would normally deactivate the selection (such asthe arrow
keys, while Shi f t isnot being held down), move the caret, leaving the selection as-is.

» Some older plugins may not support multiple selection at all.

Edit>M or e Selection>Select None (shortcut: ESCAPE) deactivates the selection containing the
caret, if thereisone. Otherwise it deactivates all active selections.

Edit>M ore Selection>I nvert Selection (shortcut: C+e C+i ) selects a set of text chunks such that
all text that was formerly part of a selection is now unselected, and all text that wasn't, is selected.

Note

Deactivating multiple selection mode while multiple blocks of text are selected will leave
the selectionsin place, but you will not be able to add new selections until multiple
selection mode is reactivated.

Inserting and Deleting Text

Text entered at the keyboard is inserted into the buffer. In overwrite mode, which can be toggled by
pressing | NSERT, one character is deleted from in front of the caret position for every character that
isinserted. The caret is drawn as horizontal line while overwrite mode is active. The status bar aso
indicatesif overwrite mode is active; see the section called “ The Status Bar” for details.

Inserting text while there is a selection will replace the selection with the inserted text.

When inserting text, the TAB and ENTER keys might not behave entirely like you expect because of
various indentation features; see the section called “ Tabbing and Indentation” for details.

The simplest way to delete text is with the BACKSPACE and DELETE keys. If nothing is selected,
they delete the character before or after the caret, respectively. If a selection exists, both delete the
selection.

More advanced deletion commands are described in the section called “Working With Words”, the
section called “Working With Lines’” and the section called “Working With Paragraphs’.

Undo and Redo

Edit>Undo (shortcut: C+z) reverses the most recent editing command. For example, this can be
used to restore unintentionally deleted text. More complicated operations, such as a search and
replace, can also be undone.

If you undo too many changes, Edit>Redo (shortcut: C+e C+2z) can restore the changes again. For
example, if some text was inserted, Undo will remove it from the buffer. Redo will insert it again.
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By default, the last 100 edits is retained; older edits cannot be undone. The maximum number of
undos can be changed in the Editing pane of the Utilities>Global Options dialog box; see the
section called “ The Editing Pane”.

Working With Words

C+LEFT and C+RI GHT move the caret aword at atime. Holding down Shi f t in addition to the
above extends the selection aword at atime.

A single word can be selected by double-clicking with the mouse, or using the Edit>More
Selection>Select Word command (shortcut: C+e  w). A selection that begins and ends on word
boundaries can be created by double-clicking and dragging.

C+BACKSPACE and C+DELETE delete the word before or after the caret, respectively.

Edit>Complete Word (shortcut: C+b) locates possible completions for the word at the caret, first
by looking in the current edit mode's syntax highlighting keyword list, and then in the current buffer
for words that begin with the word at the caret. This serves as avery basic code completion feature.

If there is only one completion, it will be inserted into the buffer immediately.

If multiple completions were found, the longest common prefix isinserted into the buffer, and a
popup is shown below the caret position listing the completions.

To insert acompletion from the list, either select it using the UP and DOWN keys and press ENTER,
press adigit to insert one of the first ten completions (1 isthe first completion; 9 isthe 9th; 0 isthe
10th), or click the desired completion with the mouse. To close the popup without inserting a
completion, press ESCAPE.

Typing while the popup is visible will automatically update the popup and narrow the set of
completions as necessary.

Edit>Word Count displays a dialog box with the number of characters, words and linesin the
current buffer.

What's a Word?

The default behavior of the C+LEFT, C+RI GHT, C+BACKSPACE and C+DELETE commandsisto
stop both at the beginning and the end of each word. However this can be changed by remapping
these keystrokes to alternative actions whose names end with (Eat Whitespace) in the Shortcuts
pane of the Utilities>Global Options dialog box; see the section called “ The Shortcuts Pane”.

Working With Lines

An entire line can be selected by triple-clicking with the mouse, or using the Edit>More
Selection>Select Line command (shortcut: C+e | ). A selection that begins and ends on line
boundaries can be created by triple-clicking and dragging.

Edit>Go to Line (shortcut: C+l ) prompts for aline number and moves the caret there.

Edit>M or e Selection>Select Line Range (shortcut: C+e C+l ) prompts for two line numbers and
selects al text between them.

Edit>Text>Delete Line (shortcut: C+d) deletes the current line.

Edit>Text>Deleteto Start Of Line (shortcut: CS+BACK SPACE) deletes all text from the start of
the current line to the caret.

Edit>Text>Deleteto End Of Line (shortcut: CS+DELETE) deletes all text from the caret to the
end of the current line.
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Edit>Text>Join Lines (shortcut; C+j ) removes any whitespace from the start of the next line and
joinsit with the current line. The caret is moved to the position where the two lines were joined. For
example, if you invoke Join Lineswith the caret on the first line of the following Java code:

new W dget ( Foo
. creat eDef aul t Foo());
It will be changed to:

new W dget ( Foo. cr eat eDef aul t Foo()) ;

Working With Paragraphs

Asfar asjEdit is concerned, “paragraphs’ are delimited by double newlines. Thisisaso how TeX
defines a paragraph. Note that jEdit doesn't parse HTML filesfor “<P>" tags, nor does it support
paragraphs delimited only by aleading indent.

C+UP and C+DOWN move the caret to the previous and next paragraph, respectively. Holding down
Shi f t inaddition to the above extends the selection a paragraph at atime.

Edit>M or e Selection>Select Par agraph (shortcut: C+e p) selects the paragraph containing the
caret.

Edit>Text>Format Paragraph (shortcut: C+e f) splitsand joinslinesin the current selection to
make it fit within the wrap column position. If nothing is selected, the paragraph containing the
caret isformatted instead. See the section called “Wrapping Long Lines’ for information and word
wrap and changing the wrap column.

Edit>Text>Delete Paragraph (shortcut: C+e d) deletes the paragraph containing the caret.

Wrapping Long Lines

The word wrap feature splits lines at word boundaries in order to fit text within a specified wrap
margin. The wrap margin position isindicated in the text are as afaint blue vertical line. There are
two “wrap modes’, “ soft” and “hard”; they are described below. The current wrap mode is shown in
the status bar; see the section called “ The Status Bar”. The wrap mode can be changed in one of the
following ways:

* Onaglobal or mode-specific basisin the Editing pane of the Utilities>Global Options dialog
box. See the section called “ The Editing Pane”.

» Inthe current buffer for the duration of the editing session,

» By clicking the status bar indicator.

* Inthe UtilitiessBuffer Optionsdialog box. See the section called “ The Buffer Options
Dialog Box”.

« From the keyboard, if akeyboard shortcut has been assigned to the Toggle Word Wrap
command in the Shortcuts pane of the Utilities>Global Options dialog box. By default, this
command does not have a keyboard shortcut.

* Inthe current buffer for future editing sessions by placing the following in one of the first or last
10 lines of the buffer, where node is either “none”, “soft” or “hard”, and col umm isthe desired
wrap margin;

:wr ap=node: maxLi neLen=col um:
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Soft Wrap

In soft wrap mode, lines are automatically wrapped when displayed on screen. Newlines are not
inserted at the wrap positions, and the wrapping is automatically updated when text is inserted or
removed.

If end of line markers are enabled in the Text Area pane of the Utilities>Global Options dialog
box, acolon (“:") is painted at the end of wrapped lines. See the section called “ The Text Area
Pane”.

Hard Wrap

In hard wrap mode, inserting text at the end of aline will automatically break the lineif it extends
beyond the wrap margin. Inserting or removing text in the middle of aline has no effect, however
text can be re-wrapped using the Edit>Text>For mat Paragraph command. See the section called
“Working With Paragraphs’.

Hard wrap isimplemented using character offsets, not screen positions, so it might not behave like
you expect if a proportional-width font is being used. The text areafont can be changed in the Text
Area pane of the Utilities>Global Options dialog box.

Scrolling

If you have a mouse with a scroll wheel and are running Java 2 version 1.4, you can use the wheel to
scroll up and down in the text area. Various modifier keys change the action of the whed!:

e Shift -scrollsan entire page at atime.

* Control -scrollsasinglelineat atime.

 Al't - movesthe caret up and down instead of scrolling.

* Alt-Shift -extendsthe selection up and down instead of scrolling.

Keyboard commands for scrolling the text area are also available.

View>Scrolling>Scroll to Current Line (shortcut: C+e C+j ) scrollsthetext areain order to
make the caret visible, if necessary. It does nothing if the caret is already visible.

View>Scrolling>Center Caret on Screen (shortcut: C+e  C+n) movesthe caret to theline in the
middle of the screen.

View>Scrolling>Line Scroll Up (shortcut: C+QUOTE) scrolls the text area up by oneline.
View>Scrolling>Line Scroll Down (shortcut: C+SLASH) scrolls the text area down by one line.
View>Scrolling>Page Scroll Up (shortcut: A+QUOTE) scrolls the text area up by one screenful.

View>Scrolling>Page Scroll Down (shortcut: A+SLASH) scrolls the text area down by one
screenful.

The above scrolling commands differ from the caret movement commands in that they don't actually
move the caret; they just change the scroll bar position.

Transferring Text

jEdit provides arich set of commands for moving and copying text. Commands are provided for
moving chunks of text from buffers to registers and vice-versa. A register isaholding areafor an
arbitrary length of text, with a single-character name. Most other programs can only transfer text to
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and from the system clipboard; in jEdit, the system clipboard is just another register, with the
special name $.

The Clipboard

jEdit offers the usual text transfer operations, that operate on the $ register.
Edit>Cut (shortcut: C+x) places the selected text in the clipboard and removes it from the buffer.
Edit>Copy (shortcut: C+c) places the selected text in the clipboard and leaves it in the buffer.

Edit>Paste (shortcut: C+v) inserts the clipboard contents in place of the selection (or at the caret
position, if there is no selection).

The Cut and Copy commands replace the old clipboard contents with the selected text. There are
two alternative commands which add the selection at the end of the existing clipboard contents,
instead of replacing it.

Edit>M ore Clipboard>Cut Append (shortcut: C+e C+u) appends the selected text to the
clipboard, then removes it from the buffer. After this command has been invoked, the clipboard will
consist of the former clipboard contents, followed by a newline, followed by the selected text.

Edit>M ore Clipboar d>Copy Append (shortcut: C+e C+a) isthe same as Cut Append except it
does not remove the selection from the buffer.

Quick Copy

The quick copy feature is usually found in Unix text editors. Quick copy is disabled by default, but
it can be enabled in the M ouse pane of the Utilities>Global Options dialog box.

The quick copy feature is accessed using the middle mouse button. If you do not have a three-button
mouse, then either Al t -click (on Windows and Unix) or Opt i on-click (on MacOS X). The quick
copy feature enables the following behavior:

» Clicking the middle mouse button in the text area inserts the most recently selected text at the
clicked location. If you only have atwo-button mouse, you can click the left mouse button while
holding down Al t instead of middle-clicking.

» Dragging with the middle mouse button creates a selection without moving the caret. As soon as
the mouse button is rel eased, the selected text isinserted at the caret position and the selection is
deactivated. A message is shown in the status bar while text is being selected to remind you that
thisis not an ordinary selection.

e Holding down Shi f t while clicking the middle mouse button will duplicate text between the
caret and the clicked location.

» Holding down Cont r ol while clicking the middle mouse button on a bracket will insert all text
in that bracket's scope at the caret position.

The most recently selected text is stored in the %oregister.

If jEdit is being run under Java 2 version 1.4 on Unix, you will be able to transfer text with other X

Windows applications using the quick copy feature. On other platforms and Java versions, the
contents of the quick copy register are only accessible from within jEdit.

General Register Commands

These commands require more keystrokes than the two methods shown above, but they can operate
on any register, allowing an arbitrary number of text chunksto be retained at atime.

Each command prompts for a single-character register name to be entered after being invoked.
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Pressing ESCAPE instead of specifying aregister name cancels the operation.

Note that the content of registers other than the clipboard and quick copy register are automatically
saved between jEdit sessions.

Edit>More Clipboard>Cut to Register (shortcut: C+r C+x key) stores the selected text in the
specified register, removing it from the buffer.

Edit>M ore Clipboar d>Copy to Register (shortcut: C+r C+c key) storesthe selected text in the
specified register, leaving it in the buffer.

Edit>M ore Clipboard>Cut Append to Register (shortcut: C+r C+u key) adds the selected text
to the existing contents of the specified register, and removes it from the buffer.

Edit>M ore Clipboar d>Copy Append to Register (shortcut: C+r C+a key) adds the selected
text to the existing contents of the specified register, without removing it from the buffer.

Edit>M ore Clipboar d>Paste from Register (shortcut: C+r C+v key) replaces the selection
with the contents of the specified register.

The following three commands display dialog boxesinstead of prompting for aregister name.

Edit>M or e Clipboar d>Paste Previous (shortcut: C+e C+v) displays adialog box listing the 20
most recently copied and pasted text strings.

Edit>M ore Clipboar d>Paste Deleted (shortcut: C+e C+y) isnot really aregister command; it
displays adialog box listing the 20 most recently deleted text strings.

Edit>M ore Clipboar d>View Registers displays adialog box for viewing register contents,
including the clipboard and the quick copy.

Markers

A marker is a pointer to a specific location within a buffer, which may or may not have a
single-character shortcut associated with it. Markers are persistent; they are saved to

.fil ename. mar ks, wheref i | enane isthe name of the buffer. (The dot prefix makesthe
markers file hidden on Unix systems.) Marker saving can be disabled in the General pane of the
Utilities>Global Options dialog box; see the section called “ The General Pane”.

Markers>Add/Remove Marker (shortcut: C+e C+m) adds a marker without a shortcut pointing to
the current line. If amarker is already set on the current line, the marker isremoved instead. If text
is selected, markers are added to the first and last line of each selection.

Markers are listed in the M arker s menu; selecting a marker from this menu will move the caret to
its location.

Markers>Go to Previous Marker (shortcut: C+e  C+COMVR) goes to the marker immediately
before the caret position.

Markers>Go to Next Marker (shortcut: C+e C+PERI OD) goes to the marker immediately after
the caret position.

Markers>Remove All Markersremoves all markers set in the current buffer.

Markers with shortcuts allow for quicker keyboard-based navigation. The following commands all
prompt for a single-character shortcut when invoked. Pressing ESCAPE instead of specifying a
shortcut will cancel the operation.

Markers>Add Marker With Shortcut (shortcut: G+t key) adds a marker with the specified
shortcut. If marker with that shortcut already exists, it will remain in the buffer but lose its shortcut.

Markers>Go to Marker (shortcut: C+y key) moves the caret to the location of the marker with
the specified shortcut.
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Markers>Select to Marker (shortcut: C+u key) creates a selection from the caret location to the
marker with the specified shortcut.

Markers>Swap Caret and Marker (shortcut: C+k key) moves the caret to the location of the
marker with the specified shortcut, and moves the marker to the former caret position. Invoke this
command multiple times to flip between two locations in the buffer.

Lines which contain markers are indicated in the gutter with a highlight. Moving the mouse over the
highlight displays atool tip showing the marker's shortcut, if it has one. See the section called
“Interface Overview” for information about the gutter.

Search and Replace

Searching For Text

Search>Find (shortcut: C+f ) displays the search and replace dialog box.

The search string can be entered in the Sear ch for text field. This text field remembers previously
entered strings; see Appendix C, History Text Fields for details.

If text was selected in the text area and the selection does not span aline break, the selected text
becomes the default search string.

If the selection spans aline break, the Search in Selection and Hyper Sear ch buttons will be
pre-selected, and the search string field will be initially blank. (See the section called “HyperSearch”
for information about the HyperSearch feature.)

Selecting the I gnor e case check box makes the search case insensitive - for example, searching for
“Hello” will match “hello”, “HELLO” and “HeLl1O".

Selecting the Regular expressions check box allows aregular expression to be used in the search
string. Regular expressions can match inexact sequences of text that optionally span more than one
line. Regular expression syntax is described in Appendix E, Regular Expressions.

The Backward and Forward buttons specify the search direction. Note that regular expressions can
only be used when searching in aforward direction.

Clicking Find will locate the next occurrence of the search string (or previous occurrence, if
searching backwards). If the K eep dialog check box is selected, the dialog box will remain open
after the search string has been located; otherwise, it will close.

If no occurrences could be found and the Auto wrap check box is selected, the search will
automatically restart from the beginning of the buffer (or the end, if searching backwards). If Auto
wrap is not selected, a confirmation dialog box is shown before restarting the search.

Search>Find Next (shortcut: C+g) locates the next occurrence of the most recent search string
without displaying the search and replace dialog box.

Sear ch>Find Previous (shortcut: C+h) locates the previous occurrence of the most recent search
string without displaying the search and replace dialog box.

Replacing Text

The replace string text field of the search dialog remembers previously entered strings; see
Appendix C, History Text Fields for details.

Clicking Replace & Find will perform areplacement in the current selection and locate the next
occurrence of the search string. Clicking Replace All will replace all occurrences of the search
string with the replacement string in the current search scope (which is either the selection, the
current buffer, or aset of buffers, as specified in the search and replace dialog box).
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Occurrences of the search string can be replaced with either areplacement string, or the return value
of aBeanShell script snippet. Two radio buttons in the search and replace dialog box select between
the two replacement modes, which are described in detail below.

Text Replace
If the Text button is selected, the search string is simply replaced with the replacement string.
If regular expressions are enabled, positiona parameters ($0, $1, $2, and so on) can be used to
insert the contents of matched subexpressions in the replacement string; see Appendix E, Regular
Expressions for more information.
If the search is case-insensitive, jEdit attempts to modify the case of the replacement string to match
that of the particular instance of the search string being replaced. For example, searching for “label”
and replacing it with “text”, will perform the following replacements:
e “String label” would become “ String text”
» “setlLabel” would become “ setText”

+ “DEFAULT_LABEL” would become“DEFAULT_TEXT"

BeanShell Replace
In BeanShell replacement mode, the search string is replaced with the return value of a BeanShell
snippet. The following predefined variables can be referenced in the snippet:
e 0 --thetext to be replaced
o _1-_9--if regular expressions are enabled, these contain the values of matched

subexpressions.

BeanShell syntax and features are covered in great detail in Part 111, “Writing Macros’, but here are
some examples:

To replace each occurrence of “Windows” with “Linux”, and each occurrence of “Linux” with
“Windows’, search for the following regular expression:

(W ndows| Li nux)

Replacing it with the following BeanShell snippet:

_1.equal s("Wndows") ? "Linux" : "Wndows"

To convert all HTML tagsto lower case, search for the following regular expression:

<\ S+

Replacing it with the following BeanShell snippet:

_0.tolLower Case()

To replace arithmetic expressions contained in curly braces with the result of evaluating the
expression, search for the following regular expression:

V(. +2)\}
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Replacing it with the following BeanShell snippet:
eval (_1)

These examples only scratch the surface; the possibilities are endless.

HyperSearch

If the Hyper Sear ch check box in the search and replace dialog box is selected, clicking Find lists
all occurrences of the search string, instead of locating the next match.

By default, HyperSearch results are shown in a floating window. This window can be docked using
the commands in its top-left corner popup menu; see the section called “Window Docking”.

If the Multipleresults check box is selected in the results window, past search results are retained.

Running searches can be stopped in the Utilities>Tr oubleshooting>1/O Progress M onitor dialog
box.

Multiple File Search

Search and replace commands can be performed over an arbitrary set of filesin one step. The set of
filesto search is selected with a set of buttonsin the search dialog box.

If the Current buffer button is selected, only the current buffer is searched. Thisis the default
behavior.

If the All buffers button is selected, all open buffers whose names match the glob pattern entered in
the Filter text field will be searched. See Appendix D, Glob Patterns for more information about
glob patterns.

If the Directory radio button is selected, all files contained in the specified directory whose names
match the glob will be searched. The directory to search in can either be entered in the Directory
text field, or chosen in afile selector dialog box by clicking the Choose button next to the field. If
the Sear ch subdirectories check box is selected, all subdirectories of the specified directory will
also be searched. Keep in mind that searching through directories containing many files can take a
long time.

The Directory and Filter text fields remember previously entered strings; see Appendix C, History
Text Fields for details.

When the search and replace dialog box is opened, the directory and file namefilter fields are set to
their previous values. They can be set to match the current buffer's directory and file name extension
by clicking Synchronize.

Note that clicking the All Buffersor Directory radio buttons also selects the Hyper Sear ch check
box since that is what you would want, most of the time. However, the Hyper Sear ch check box can
be unchecked, for stepping through search results in multiple files one at atime.

Two convenience commands are provided for performing multiple file searches.

Search>Sear ch in Open Buffers (shortcut: C+e C+b) displays the search dialog box and selects
the All buffer s button.

Search>Sear ch in Directory (shortcut: C+e C+d) displays the search dialog box and selects the
Directory button.

The Search Bar

The search bar feature provides a convenient way to search in the current buffer without opening the
search dialog box. The search bar does not support replacement or multiple file search. Previously
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entered strings can be recalled in the search bar with the Up and Down arrow keys, see Appendix C,
History Text Fields.

By default, the search bar remains hidden until one of the quick search commands (described below)
isinvoked; however you can choose to have it always visible in the View pane of the
Utilities>Global Options dialog box; see the section called “The View Pane”.

Search>Incremental Search Bar (shortcut: C+COVVA) displays the search bar if necessary, and
givesit keyboard focus. If this command isinvoked while there is a selection, the selection is placed
in the search string field.

Search>Incremental Search for Word (shortcut: A+COMVA) behaves like the above command
except it places the word at the caret in the search string field.

Unless the Hyper Sear ch check box is selected, the search bar will perform an incremental search.
Inincremental search mode, the first occurrence of the search string is located in the current buffer
asitisbeing typed. Pressing ENTER and S+ENTER searches for the next and previous occurrence,
respectively. Once the desired occurrence has been located, pressing ESCAPE returns keyboard
focus to the text area. Unless the search bar is set to be always visible (see above), pressing ESCAPE
will also hide the search bar.

Note

Incremental searches cannot be not recorded in macros. If your macro needs to perform a
search, use the search and replace dialog box instead. See Chapter 8, Using Macros for
information about macros.

Search>Hyper Sear ch Bar (shortcut: C+PERI OD) displays the search bar if necessary, givesit
keyboard focus, and selects the Hyper Sear ch check box. If this command isinvoked while there is
a selection, the selected text will be searched for immediately and the search bar will not be shown.

If the Hyper Sear ch check box is selected, pressing Ent er in the search string field will perform a
HyperSearch in the current buffer.

Sear ch>Hyper Sear ch for Word (shortcut: A+PERI OD) performs a HyperSearch for the word at
the caret. This command does not show the search bar or give it keyboard focus.
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Chapter 6. Editing Source Code
Edit Modes

An edit mode specifies syntax highlighting rules, auto indent behavior, and various other
customizations for editing a certain file type. This section only covers using existing edit modes;
information about writing your own can be found in Part 11, “Writing Edit Modes”.

When afileis opened, jEdit first checks the file name against alist of known patterns. For example,
fileswhose names end with . ¢ are opened with C mode, and files named Makef i | e are opened
with Makefile mode. If a suitable match based on file name cannot be found, jEdit checks the first
line of the file. For example, fileswhose first lineis#! / bi n/ sh are opened with shell script
mode.

Mode Selection

File name and first line matching is done using glob patterns similar to those used in Unix shells.
Glob patterns associated with edit modes can be changed in the Editing pane of the
Utilities>Global Options dialog box. Note that the glob patterns must match the file name or first
line exactly; so to match fileswhosefirst line contains begi n, you must use afirst line glob of
*pbegi n*. See Appendix D, Glob Patterns for a description of glob pattern syntax.

The default edit mode for files which do not match any pattern can be set in the Editing pane as
well.

The edit mode can be specified manually as well. The current buffer's edit mode can be set on a
one-time basisin the Utilities>Buffer Options dialog box; see the section called “The Buffer
Options Dialog Box”. To set a buffer's edit mode for future editing sessions, place the following in
one of thefirst or last 10 lines of the buffer, whereedi t node isthe name of the desired edit
mode:

:nmode=edi t node:

Syntax Highlighting

Syntax highlighting is the display of programming language tokens using different fonts and colors.
This makes code easier to follow and errors such as misplaced quotes easier to spot. All edit modes
except for the plain text mode perform some kind of syntax highlighting.

The colors and styles used to highlight syntax tokens can be changed in the Syntax Highlighting

pane of the Utilities>Global Options dialog box; see the section called “ The Syntax Highlighting
Pane”.

Tabbing and Indentation

jEdit makes a distinction between the tab width, which isis used when displaying hard tab
characters, and the indent width, which is used when alevel of indent isto be added or removed, for
example by mode-specific auto indent routines. Both can be changed in one of several ways:

e Onaglobal or mode-specific basisin the Editing pane of the the Utilities>Global Options
dialog box. See the section called “The Editing Pane”.

* Inthe current buffer for the duration of the editing session in the Utilities>Buffer Options
dialog box. See the section called “The Buffer Options Dialog Box”.

» Inthe current buffer for future editing sessions by placing the following in one of the first or last
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10 lines of the buffer, where n is the desired tab width, and mis the desired indent width:

:tabSi ze=n:i ndent Si ze=m

Edit>Indent>Shift I ndent L eft (shortcut: S+TAB or A+LEFT) adds one level of indent to each
selected line, or the current line if there is no selection.

Edit>Indent>Shift Indent Right (shortcut: A+RI GHT) removes one level of indent from each
selected line, or the current line if there is no selection. Pressing Tab while amulti-line selectionis
active has the same effect.

Edit>Indent>Remove Trailing Whitespace (shortcut: C+e r ) removes all whitespace from the
end of each selected line, or the current lineif there is no selection.

Soft Tabs

Files containing hard tab characters may look less than ideal if the default tab size is changed, so
some people prefer using multiple space charactersinstead of hard tabs to indent code.

This feature is known as soft tabs. Soft tabs can be enabled or disabled in one of severa ways:
» Onaglobal or mode-specific basisin the Editing pane of the Utilities>Global Options dialog
box. See the section called “ The Editing Pane”.

e Inthe current buffer for the duration of the editing session in the Utilities>Buffer Options
dialog box. See the section called “The Buffer Options Dialog Box”.

* Inthe current buffer for future editing sessions by placing the following in one of the first or last
10 lines of the buffer, wheref | ag iseither “true” or “false”:

:noTabs=fI ag:

Changing the soft tabs setting has no effect on existing tab characters; it only affects
subsequently-inserted tabs.

Edit>I ndent>Spacesto Tabs converts soft tabs to hard tabs in the current selection, or the entire
buffer if nothing is selected.

Edit>Indent>Tabsto Spaces converts hard tabs to soft tabs in the current selection, or the entire
buffer if nothing is selected.

Automatic Indent

The auto indent feature inserts the appropriate number of tabs or spaces at the beginning of aline by
looking at program structure.

In the default configuration, pressing ENTER will create a new line with the appropriate amount of
indent automatically, and pressing TAB at the beginning of, or inside the leading whitespace of a
line will insert the appropriate amount of indentation. Pressing it again will insert atab character.

The behavior of the ENTER and TAB keys can be configured in the Shortcuts pane of the
Utilities>Global Optionsdialog. box, just as with any other key. The ENTER key can be bound to
one of the following, or indeed any other command or macro:

e |nsert Newline.

* |nsert Newline and I ndent, which isthe default.
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The TAB can be bound to one of the following, or again, any other command or macro:

e |nsert Tab.
e |nsert Tab or Indent, which is the default.

* |ndent Selected Lines.

See the section called “ The Shortcuts Pane” for details.

Auto indent behavior is mode-specific. In most edit modes, the indent of the previous lineis simply
copied over. However, in C-like languages (C, C++, Java, JavaScript), curly brackets and language
statements are taken into account and indent is added and removed as necessary.

Edit>Sour ce>I ndent Selected Lines (shortcut: C+i ) indents all selected lines, or the current line if
thereis no selection.

Toinsert aliteral tab or newline without performing indentation, prefix the tab or newline with Ct+e
v. For example, to create a new line without any indentation, type C+te v ENTER.

Commenting Out Code

Most programming and markup languages support the notion of “comments’, or regions of code
which are ignored by the compiler/interpreter. jEdit has commands which make inserting comments
more convenient.

Comment strings are mode-specific, and some in some modes such as HTML different parts of a
buffer can have different comment strings. For example, in HTML files, different comment strings
are used for HTML text and inline JavaScript.

Edit>Sour ce Code>Range Comment (shortcut: C+e C+c) encloses the selection with comment
start and end strings, for example/ * and */ in Java mode.

Edit>Sour ce Code>L ine Comment (shortcut: C+e C+k) inserts the line comment string, for
example/ / inJavamode, at the start of each selected line.

Bracket Matching

Misplaced and unmatched brackets are one of the most common syntax errors encountered when
writing code. jEdit has several featuresto make brackets easier to deal with.

Positioning the caret immediately after a bracket will highlight the corresponding closing or opening
bracket (assuming it is visible), and draw a scope indicator in the gutter. If the highlighted bracket is
not visible, the text of the matching line will be shown in the status bar. If the matching line consists
of only whitespace and the bracket itself, the previous line is shown instead. Thisfeatureis very
useful when your code is indented as follows, with braces on their own lines:

public void someMethod()
i f(isOK)
doSonet hi ng() ;

Invoking Edit>Sour ce>Go to M atching Bracket (shortcut: C+] ) or clicking the scope indicator in
the gutter moves the caret to the matching bracket.

Edit>Sour ce>Select Code Block (shortcut: C+[ ) selects all text between the closest two brackets

32



Editing Source Code

surrounding the caret.

Holding down Cont r ol while clicking the scope indicator in the gutter or a bracket in the text area
will select al text between the two matching brackets.

Edit>Source>Go to Previous Bracket (shortcut: C+e C+[ ) moves the caret to the previous
opening bracket.

Edit>Source>Go to Next Bracket (shortcut: C+e C+] ) moves the caret to the next closing
bracket.

Bracket highlighting in the text area and bracket scope display in the gutter can be customized in the
Text Area and Gutter panes of the Utilities>Global Options dialog box; see the section called
“The Global Options Dialog Box”.

Tip

jEdit's bracket matching algorithm only checks syntax tokens with the same type asthe
original bracket, so for example unmatched brackets inside string literals and comments
will be skipped when matching brackets that are part of program syntax.

Abbreviations

Using abbreviations reduces the time spent typing long but commonly used strings. For example, in
Java mode, the abbreviation “sout” is defined to expand to “ System.out.printin()”, so to insert
“System.out.printin()” in a Java buffer, you only need to type “sout” followed by C+; . An
abbreviation can either be global, in which case it can be used in all edit modes, or specific to a
single mode.

Abbreviations can be edited in the Abbreviations pane of the Utilities>Global Options dialog box;
see the section called “The Abbreviations Pane”. The Java, VHDL. XML and XSL edit modes
include some pre-defined abbreviations you might find useful. Other modes do not have any
abbreviations defined by default.

Edit>Expand Abbreviation (keyboard shortcut: C+; ) attempts to expand the abbreviation named
by the word before the caret. If no expansion could be found, it will offer to define one.

Automatic abbreviation expansion can be enabled in the Abbreviations pane of the
Utilities>Global Options dialog box. If enabled, pressing the space bar after entering an
abbreviation will automatically expand it.

If automatic expansion is enabled, a space can be inserted without expanding the word before the
caret by pressing Cont r ol -EV Space.

Positional Parameters

Positional parameters are an advanced feature that make abbreviations much more useful. The best
way to describe them is with an example.

Java mode defines an abbreviation “F” that is set to expand to the following:
for(int $1 = 0; $1 < $2; $1++)

Expanding F#j #ar r ay. | engt h# will insert the following text into the buffer:

for(int j = 0; j < array.length; j++)

Expansions can contain up to nine positional parameters. Note that atrailing hash character (“#")
must be entered when expanding an abbreviation with parameters.

If you do not specify the correct number of positional parameters when expanding an abbreviation,
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any missing parameters will be blank in the expansion, and extra parameters will be ignored. A
status bar message will be shown stating the required number of parameters.

Folding

Program source code and other structured text files can be thought of as containing a hierarchy of
sections, which themselves might contain sub-sections. The folding feature lets you selectively hide
and show these sections, replacing hidden ones with a single line that serves as an “overview” of
that section. Folding is disabled by default. To enableit, you must choose one of the available
folding modes.

“Indent” mode creates folds based on aline's |eading whitespace; the more leading whitespace a
block of text has, the further down it isin the hierarchy. For example:

This is a section
This is a sub-section
This i s anot her sub-section
This is a sub-sub-section
Anot her top-level section

“Explicit” mode folds away blocks of text surrounded with “{{{” and “}}}”. For example:

{{{ The first line of a fold.

When this fold is collapsed, only the above line will be visible.
{{{ A sub-section.

Wth text inside it.

11}

{{{ Another sub-section.

P}

11}

Both modes have distinct advantages and disadvantages; indent folding requires no changes to be
made to a buffer's text and does a decent job with most program source. Explicit folding requires
“fold markers’ to be inserted into the text, but is more flexible in exactly what to fold away.

Some plugins might add additional folding modes; see Chapter 9, Installing and Using Plugins for
information about plugins.

Folding can be enabled in one of severa ways:
» Onaglobal or mode-specific basisin the Editing pane of the Utilities>Global Options dialog
box. See the section called “ The Editing Pane”.

« Inthe current buffer for the duration of the editing session in the Utilities>Buffer Options
dialog box. See the section called “The Buffer Options Dialog Box”.

» Inthe current buffer for future editing sessions by placing the following in the first or last 10
lines of abuffer, where node is either “indent”, “explicit”, or the name of a plugin folding
mode;

: f ol di ng=node:

Warning

When using indent folding, portions of the buffer may become inaccessible if you change
the leading indent of thefirst line of a collapsed fold. If you experience this, you can use
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the Expand All Folds command to make the text visible again.

Collapsing and Expanding Folds

Thefirst line of each fold has atriangle drawn next to it in the gutter (see the section called
“Interface Overview” for more information about the gutter). The triangle points toward the line
when the fold is collapsed, and downward when the fold is expanded. Clicking the triangle collapses
and expands the fold. To expand all sub-folds as well, hold down the Shi f t while clicking.

Thefirst line of acollapsed fold is drawn with a background color that depends on the fold level,
and the number of linesin the fold is shown to the right of the line'stext.

Folds can also be collapsed and expanded using menu item commands and keyboard shortcuts.
Folding>Collapse Fold (shortcut: A+BACK SPACE) collapses the fold containing the caret.

Folding>Expand Fold One L evel (shortcut: A+ENTER) expands the fold containing the caret.
Nested folds will remain collapsed, and the caret will be positioned on the first nested fold (if any).

Folding>Expand Fold Fully (shortcut: AS+ENTER) expands the fold containing the caret, also
expanding any nested folds.

Folding>Collapse All Folds (shortcut: C+e c¢) collapses al foldsin the buffer.

Folding>Expand All Folds (shortcut: C+e x) expandsall foldsin the buffer.

Navigating Around With Folds

Folding>Go to Parent Fold (shortcut: C+e u) moves the caret to the fold containing the one at the
caret position.

Folding>Go to Previous Fold (shortcut: A+UP) movesthe caret to the fold immediately before the
caret position.

Folding>Go to Next Fold (shortcut: A+DOWN) moves the caret to the fold immediately after the
caret position.

Miscellaneous Folding Commands

Folding>Add Explicit Fold (shortcut: C+e a) surrounds the selection with “{{{” and “}}}”. If the
current buffer's edit mode defines comment strings (see the section called “ Commenting Out Code”)
the explicit fold markers will automatically be commented out as well.

Folding>Select Fold (shortcut: C+e s) selectsall lines within the fold containing the caret.
Cont r ol -clicking afold expansion triangle in the gutter has the same effect.

Folding>Expand Folds With Level (shortcut: C+e ENTER key) reads the next character entered
at the keyboard, and expands folds in the buffer with afold level less than that specified, while
collapsing al others.

Sometimesit is desirable to have files open with folds initially collapsed. This can be configured as

follows:

* Onaglobal or mode-specific basisin the Editing pane of the Utilities>Global Options dialog
box. See the section called “ The Editing Pane”.

» Inthe current buffer for future editing sessions by placing the following in the first or last 10
lines of abuffer, wherel evel isthedesired fold level:

. col | apseFol ds=l evel :
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Narrowing

The narrowing feature temporarily “narrows’ the display of a buffer to a specified region. Text
outside the region is not shown, but is still present in the buffer.

Holding down Al t while clicking afold expansion triangle in the gutter will hide al lines the buffer
except those contained in the clicked fold.

Folding>Narrow Buffer to Fold (shortcut: C+e n n) hides all lines the buffer except those in the
fold containing the caret.

Folding>Narrow Buffer to Selection (shortcut: C+e n s) hidesall lines the buffer except those
in the selection.

Folding>Expand All Folds (shortcut: C+e x) shows linesthat were hidden as a result of
narrowing.
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The Buffer Options Dialog Box

Utilities>Buffer Options displays adialog box for changing editor settings on a per-buffer basis.
Changes made in this dialog box are not retained after the buffer is closed.

The following settings can be changed here:

» Theline separator (see the section called “Line Separators’)

» The character encoding (see the section called “ Character Encodings’)

» If thefile should be GZipped on disk (see the section called “ Opening Files")
» The edit mode (see the section called “Edit Modes”)

» Thefold mode (see the section called “Folding”)

» Thewrap mode and margin (see the section called “Wrapping Long Lines")
* Thetab width (see the section called “ Tabbing and Indentation”)

* Theindent width

» If soft tabs should be used (see the section called “ Tabbing and Indentation™)

Buffer-Local Properties

Buffer-local properties provide an alternate way to change editor settings on a per-buffer basis.
While changes made in the Buffer Options dialog box are lost after the buffer is closed,

buffer-local properties take effect each time the file is opened, because they are embedded in the file
itself.

When jEdit loads afile, it checksthe first and last 10 lines for colon-enclosed name/value pairs. For
example, placing the following in a buffer changes the indent width to 4 characters, enables soft
tabs, and activates the Perl edit mode:

i ndent Si ze=4: noTabs=t r ue: node=per| :

Adding buffer-local properties to a buffer takes effect after the next time the buffer is saved.

The following table describes each buffer-local property in detail.

Property name Description

col | apseFol ds Folds with alevel of this or higher will be collapsed when the buffer is
opened. If set to zero, all foldswill be expanded initially. See the section
called “Folding”.

deepl ndent When set to “true”, multiple-line expressions delimited by parentheses

are adligned like so:
retVal.x = (int)(horizontal O fset
+ Chunk. of f set ToX(i nfo. chunks,
of fset));

With this setting disabled, the text would look like so:
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Property name Description

retval.x = (int)(horizontal Ofset
+ Chunk. of f set ToX(i nfo. chunks,

of fset));
fol di ng The fold mode; one of “none”, “indent”, “explicit”, or the name of a
plugin folding mode. See the section called “Folding”.
i ndent Si ze Thewidth, in characters, of one indent. Must be an integer greater than
0. See the section called “ Tabbing and Indentation”.
maxLi neLen The maximum line length and wrap column position. Inserting text

beyond this column will automatically insert aline break at the
appropriate position. See the section called “Inserting and Deleting

Text".

node The default edit mode for the buffer. See the section called “Edit
Modes”".

noTabs If set to “true”, soft tabs (multiple space characters) will be used instead
of “real” tabs. See the section called “ Tabbing and Indentation”.

noWbr dSep A list of non-alphanumeric characters that are not to be treated as word
separators. Global defaultis“_”.

tabSi ze The tab width. Must be an integer greater than 0. See the section called

“Tabbing and Indentation”.

wor dBr eakChar s Characters, in addition to spaces and tabs, at which lines may be split
when word wrapping. See the section called “Inserting and Deleting
Text”.

wr ap The word wrap mode; one of “none”, “soft”, or “hard”. See the section
called “Wrapping Long Lines”.

The Global Options Dialog Box

Utilities>Global Options displays the global options dialog box. The dialog box is divided into
several panes, each pane containing a set of related options. Use the list on the left of the dialog box
to switch between panes. Only panes created by jEdit are described here; some plugins add their
own option panes, and information about them can be found in the documentation for the pluginsin
guestion.

The Abbreviations Pane

The Abbreviations option pane can be used to enable or disable automatic abbreviation expansion,
and to edit currently defined abbreviations.

The combo box labelled “Abbrev set” selects the abbreviation set to edit. The first entry, “global”,
contains abbreviations available in al edit modes. The subsequent entries correspond to each mode's
local set of abbreviations.

To change an abbreviation or its expansion, either double-click the appropriate table entry, or click a
table entry and then click the Edit button. Thiswill display a dialog box for modifying the
abbreviation.

The Add button displays a dialog box where you can define a new abbreviation. The Remove
button removes the currently selected abbreviation from the list.

See the section called “ Positional Parameters” for information about positional parametersin
abbreviations.
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The Appearance Pane

The Appear ance pane can be used to change the appearance of user interface controls such as
buttons, labels and menus. The number of items retained in history text fields can also be set here;
see Appendix C, History Text Fields.

Note that changes to certain settings such as the Swing look and feel require arestart of jEdit to take
effect.

The Autosave and Backup Pane

The Autosave option pane contains settings for the autosave and backup features. See the section
called “Autosave and Crash Recovery” and the section called “Backups’.

The Context Menu Pane

The Context M enu option pane edits the text area's right-click context menu. See the section called
“Multiple Views'.

The Docking Pane

The Docking option pane specifies docking location for various dockable windows. Another way to
specify docking locations is to use the popup menus associated with each dockable window; see the
section called “Window Docking”.

The Editing Pane

The Editing option pane contains settings such as the tab size, syntax highlighting and soft tabs on a
global or mode-specific basis.

When changing mode-specific settings, the File name glob and Fir st line glob text fields et you
specify aglob pattern that names and first lines of buffers will be matched against to determine the
edit mode. See Appendix D, Glob Patterns for information about glob patterns.

This option pane does not change XML mode definition files on disk; it merely writes values to the

user properties file which override those set in mode files. To find out how to edit mode files
directly, see Part 11, “Writing Edit Modes”.

The General Pane

The General pane contains various miscellaneous settings, such as the default line separator and file
encoding, the number of recent files to remember, if the buffer list should be sorted, and so on.

The Gutter Pane

The Gutter option pane contains settings to customize the appearance of the gutter. See the section
called “Interface Overview”.

The Mouse Pane

The M ouse option pane contains settings for toggling drag and drop of text, aswell as gutter mouse
click behavior.

The Printing Pane

The Printing option pane contains settings to control the appearance of printed output.
Workarounds that might be needed for your Java version to print correctly can also be enabled here.
See the section called “ Printing”.
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The Plugin Manager Pane

The Plugin Manager pane contains a chooser for the desired download mirror, as well as various
settings such as the directory where plugins are to be installed. See Chapter 9, Installing and Using
Plugins.

The Proxy Servers Pane

The Proxy Servers option pane lets you specify HTTP and SOCKS proxy serversto use when jEdit
makes network connections, for example when downloading plugins.

The Shortcuts Pane

The Shortcuts option pane associates keyboard shortcuts with commands. Each command can have
up to two shortcuts associated with it.

The combo box at the top of the option pane selects the command set to edit. Command sets include
the set of all built-in commands, the commands of each plugin, and the set of macros.

To change a shortcut, click the appropriate table entry and press the keys you want associated with
that command in the resulting dialog box. The dialog box will warn you if the shortcut is already
assigned.

The Status Bar Pane

The Status Bar option pane contains settings to customize the status bar, or disable it completely.
See the section called “ The Status Bar”.

The Syntax Highlighting Pane

The Syntax Highlighting pane can be used to customize the fonts and colors for syntax
highlighting. See the section called “ Syntax Highlighting”.

The Text Area Pane

The Text Area pane contains settings to customize the appearance of the text area. See the section
called “Interface Overview”.

The Tool Bar Pane

The Tool Bar option pane lets you edit the tool bar, or disable it completely. See the section called
“Multiple Views'.

The View Pane

The View option pane lets you change various settings related to the editor window's appearance,
including the arrangement of dockable windows, and if the search bar and buffer switcher should be
visible. See the section called “Multiple Views”.

The File System Browser Panes

The File System Browser group contains two option panes, General and Colors. The former
contains various file system browser settings. The latter configures glob patterns used for coloring
thefilelist. See the section called “ The File System Browser” for more information.

The jEdit Settings Directory
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jEdit stores settings, macros, and plugins as files inside the settings directory. In most cases, editing
these files by hand is not necessary, since graphical tools and editor commands can do the job.
However, being familiar with the structure of the settings directory still comesin handy in certain
situations, for example when you want to copy jEdit settings between computers.

The location of the settings directory is system-specific; it is printed to the activity log
(Utilities>Troubleshooting>Activity L og). For example:

[message] jEdit: Settings directory is /home/slaval.jedit

Specifying the - set t i ngs switch on the command line instructs jEdit to store settingsin a

directory other than the default. For example, the following command will instruct jEdit to store all

settingsinthej edi t subdirectory of the C. drive:

C\ljedit> jedit -settings=C\jedit

The- noset ti ngs switch will force jEdit to not look for or create a settings directory; default

settings will be used instead.

jEdit creates the following files and directories inside the settings directory; plugins may add more:

« abbrevs - aplaintext file which stores all defined abbreviations. See the section called
“Abbreviations’.

 activity.| og-aplaintextfilewhich contains the full activity log. See Appendix B, The
Activity Log.

» history -aplaintext file which stores history lists, used by history text fields and the
Edit>Paste Previous command. See the section called “ Transferring Text” and Appendix C,
History Text Fields.

» ] ars -thisdirectory contains plugins. See Chapter 9, Installing and Using Plugins.

» jars-cache - thisdirectory contains plugin cache files which decrease the time to start jEdit.
They are automatically updated when plugins are installed or updated.

 killring.xm - storesrecently deleted text. See the section called “ Transferring Text”.
e macr os - thisdirectory contains macros. See Chapter 8, Using Macros.
» nodes - thisdirectory contains custom edit modes. See Part |1, “Writing Edit Modes’.

e perspective. xm -an XML filethat storesthe list of open buffers and views used to
maintain editor state between sessions.

* Pl ugi nManager . downl oad - thisdirectory is usually empty. It only contains files while the
plugin manager is downloading a plugin. For information about the plugin manager, see
Chapter 9, Installing and Using Plugins.

* printspec - abinary file that stores printing settings when running under Java 2 version 1.4.

e properties -aplaintext filethat storesthe maority of jEdit's settings.

 recent.xm -an XML filewhich storesthelist of recently opened files. jEdit remembers the
caret position and character encoding of each recent file, and automatically restores those values
when one of thefilesis opened.

* registers.xm -anXML filethat storesregister contents. See the section called “ General
Register Commands’ for more information about registers.

e server -aplaintextfilethat only exists while jEdit is running. The edit server's port number
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and authorization key is stored here. See Chapter 2, Sarting jEdit.

» settings-backup - thisdirectory contains numbered backups of all automatically-written
settingsfiles.
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Macrosin jEdit are short scripts written in a scripting language called BeanShell. They provide an
easy way to automate repetitive keyboard and menu procedures, as well as access to the objects and
methods created by jEdit. Macros also provide a powerful facility for customizing jEdit and
automating complex text processing and programming tasks. This section describes how to record
and run macros. A detailed guide on writing macros appears later; see Part 111, “Writing Macros’.

Other scripting languages

A number of jEdit plugins provide support for writing scripts in aternative programming languages,
like Python and Prolog. Consult the documentation for the appropriate plugins for more information.

Recording Macros

The simplest use of macrosisto record a series of key strokes and menu commands as a BeanShell
script, and play them back later. While this doesn't let you take advantage of the full power of
BeanShell, it is still agreat time saver and can even be used to “prototype” more complicated
macros.

M acros>Record Macro (shortcut: C+m C+r ) prompts for a macro name and begins recording.
While recording isin progress, the string “Macro recording” is displayed in the status bar. jEdit
records the following:

» Key strokes

*  Menuitem commands

Tool bar clicks

» All search and replace operations, except incremental search

Mouse clicksin the text area are not recorded; use text selection commands or arrow keys instead.

Macros>Stop Recording (shortcut: C+m C+s) stops recording. It also switches to the buffer
containing the recorded macro, giving you a chance to check over the recorded commands and make
any necessary changes. When you are happy with the macro, save the buffer and it will appear in the
M acr os menu. To discard the macro, close the buffer without saving it.

Thefile name extension . bsh isautomatically appended to the macro name, and all spaces are
converted to underscore characters, in order to make the macro name avalid file name. These two
operations are reversed when macros are displayed in the M acr os menu; see the section called
“How jEdit Organizes Macros’ for details.

If acomplicated operation only needsto be repeated a few times, using the temporary macro feature
is quicker than saving a new macro file.

Macros>Record Temporary Macro (shortcut: C+m C+m begins recording to a buffer named
Tenpor ary_Macr 0. bsh. Once recording of atemporary macro is complete, jEdit does not
display the buffer containing the recorded commands, but the name Tenpor ary_Macr 0. bsh
will be visible on any list of open buffers. By switching to that buffer, you can view the commands,
edit them, and save them if you wish to a permanent macro file. Whether or not you look at or save
the temporary macro contents, it isimmediately available for playback.

Macros>Run Temporary Macro (shortcut: C+m C+p) plays the macro recorded to the
Tenpor ary_Macr 0. bsh buffer.
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Only one temporary macro is available at atime. If you begin recording a second temporary macro,
thefirst is erased and cannot be recovered unless you have saved the contents to a file with aname
other than Tenpor ary_Macr o. bsh. If you do not save the temporary macro, you must keep the
buffer containing the macro script open during your jEdit session. To have the macro available for
your next jEdit session, save the buffer Tenpor ary_Macr 0. bsh as an ordinary macro with a
descriptive name of your choice. The new name will then be displayed in the M acr os menu.

Running Macros

Macros supplied with jEdit, as well as macros that you record or write, are displayed under the
Macros menu in a hierarchical structure. The jEdit installation includes about 30 macros divided
into several major categories. Each category corresponds to a nested submenu under the M acr os
menu. An index of these macros containing short descriptions and usage notesisfound in
Appendix F, Macros Included With jEdit.

To run amacro, choose the M acr os menu, navigate through the hierarchy of submenus, and select
the name of the macro to execute. Y ou can also assign execution of a particular macro to a keyboard
shortcut, toolbar button or context menu using the M acro Shortcuts, Tool Bar or Context Menu
panes of the Utilities>Global Options dialog; see the section called “ The Global Options Dialog
Box”.

How jEdit Organizes Macros

Every macro, whether or not you originally recorded it, is stored on disk and can be edited as a text
file. The file name of amacro must have a. bsh extension in order for jEdit to be aware of it. By
default, jEdit associatesa. bsh file with the BeanShell edit mode for purposes of syntax
highlighting, indentation and other formatting. However, BeanShell syntax does not impose any
indentation or line break requirements.

The Macros menu lists all macros stored in two places: the macr os subdirectory of the jEdit home
directory, and the macr os subdirectory of the user-specific settings directory (see the section called
“The jEdit Settings Directory” for information about the settings directory). Any macros you record

will be stored in the user-specific directory.

Macros stored elsewhere can be run using the M acr os>Run Other Macro command, which
displays afile chooser dialog box, and runs the specified file.

Thelisting of individual macrosin the M acros menu can be organized in a hierarchy using
subdirectoriesin the general or user-specific macro directories; each subdirectory appears as a
submenu. Y ou will find such a hierarchy in the default macro set included with jEdit.

When jEdit first loads, it scans the designated macro directories and assembles alisting of

individual macros in the M acr os menu. When scanning the names, jEdit will delete underscore
charactersand the . bsh extension for menu labels, so that Li st _Usef ul _I nf or mati on. bsh,
for example, will be displayed in the Macros menu as List Useful Information.

Y ou can browse the user and system macro directories by opening the macr os directory from the
Utilities>jEdit Home Directory and Utilities>Settings Directory menus.

Macros can be opened and edited much like ordinary files from the file system browser. Editing
macros from within jEdit will automatically update the macros menu; however, if you modify
macros from another program or add macro files to the macro directories, you should run the
Macr os>Rescan M acr os command to update the macro list.




Chapter 9. Installing and Using
Plugins
A plugin is an application which is loaded and runs as part of another, host application. Plugins
respond to user commands and perform tasks that supplement the host application's features.
This chapter coversinstalling, updating and removing plugins. Documentation for the plugins

themselves can be found in Help>jEdit Help, and information about writing plugins can be found
in Part IV, “Writing Plugins’.

The Plugin Manager

Plugins>Plugin Manager displays the plugin manager window. The plugin manager lists all
installed plugins; clicking on aplugin in the list will display information about it.

To remove plugins, select them (multiple plugins can be selected by holding down Cont r ol ) and
click Remove. Thiswill display a confirmation dialog box first.

To view plugin documentation, select a plugin and click Help. Note that plugin documentation can
also be accessed by invoking Help>jEdit Help.

Plugins>Plugin Options displays a dialog box for changing plugin settings.

Installing and Updating Plugins

Plugins can be installed in two ways; manually, and from the plugin manager. In most cases, plugins
should be installed from the plugin manager. It is easier and more convenient.

Toinstall plugins manually, go to http://plugins.jedit.org in aweb browser and follow the directions
on that page.

Toinstall plugins from the plugin manager, make sure you are connected to the Internet and click
the Install tab in the plugin manager window. The plugin manager will then download information
about available plugins from the jEdit web site, and present alist of plugins compatible with your
jEdit release.

Click on aplugininthelist to see some information about it. To select plugins for installation, click
the check box next to their namesin thelist.

The Total sizefield shows the total size of all plugins chosen for installation, along with any
plugins that will be automatically downloaded in order to fulfill dependencies.

Once you have specified pluginsto install, click I nstall to begin the download process.

By default, the plugin manager does not download plugin source code, and installs the downloaded
pluginsinthej ar s subdirectory of the user-specific settings directory. These settings can be
changed in Plugin Manager pane of the Utilities>Global Options dialog box; see the section
called “The Plugin Manager Pane”.

The Update tab of the plugin manager is very similar to the Install tab. It lists plugins for which
updated versions are available. It will also offer to delete any obsolete plugins.

Proxy Serversand Firewalls

If you are connected to the Internet through an HT TP proxy or SOCK S firewall, you will need to
specify the relevant detailsin the Proxy Server s pane of the Utilities>Global Options dialog box;
see the section called “ The Proxy Servers Pane”.
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Appendix A. Keyboard Shortcuts

This appendix documents the default set of keyboard shortcuts. They can be customized to suit your
taste in the Shortcuts pane of the Utilities>Global Options dialog box; see the section called “ The

Global Options Dialog Box”.

Files

For details, see the section called “ Switching Buffers’, the section called “Multiple Views’ and

Chapter 4, Working With Files.

C+n New file.

Ct+o Openfile.

C+w Close buffer.

C+te Ctw Close all buffers.

C+s Save buffer.

C+e Cts Save al buffers.

C+p Print buffer.

C+PAGE_UP Go to previous buffer.

C+PAGE_DOVWN Go to next buffer.

C+ Go to recent buffer.

A+ Show buffer switcher.

C+q Exit jEdit.

Views

For details, see the section called “Multiple Views’.

Cte C+t Turn gutter (line numbering) on and off.
C+0 Remove split containing current text areaonly.
C+l Remove al splits.

C+2 Split view horizontally.

C+3 Split view vertically.

A+PAGE_UP Send keyboard focus to previous text area.
A+PAGE DO Send keyboard focus to next text area.
C+e UP; LEFT; DOMWN; Rl GHT Send keyboard focus to top; bottom; left; right docking

area.

C+e C+ Close currently focused docking area.
Action Bar

For details, see the section called “The Action Bar”.

C+ENTER

‘ Display the action bar and give it keyboard focus.

C+SPACE

| Repest last editor action.
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Moving the Caret

For details, see the section called “Moving The Caret”, the section called “Working With Words’,
the section called “Working With Lines’, the section called “Working With Paragraphs’ and the

section called “Bracket Matching”.

Arrow Move caret one character or line.

C+Arr ow Move caret one word or paragraph.

PAGE_UP; PAGE_DOWN Move caret one screenful.

HOVE First non-whitespace character of line, beginning of line,
first visible line (repeated presses).

END Last non-whitespace character of line, end of line, last
visible line (repeated presses).

C+HOVE Beginning of buffer.

C+END End of buffer.

Ct] Go to matching bracket.

Cre [;] Go to previous; next bracket.

CHl Gotoline.

Selecting Text

For details, see the section called “ Selecting Text”, the section called “Working With Words’, the
section called “Working With Lines’, the section called “Working With Paragraphs’ and the section

called “Bracket Matching”.

S+Arrow

Extend selection by one character or line.

CS+Arr ow

Extend selection by one word or paragraph.

S+PAGE_UP; S+PAGE_DOMN

Extend selection by one screenful.

S+HOVE

Extend selection to first non-whitespace character of line,
beginning of line, first visible line (repeated presses).

S+END Extend selection to last non-whitespace character of line,
end of ling, last visible line (repeated presses).

CS+HOVE Extend selection to beginning of buffer.

CS+END Extend selection to end of buffer.

C+[ Select code block.

Cte w ! ;p Select word; line; paragraph.

Cte CHl Select linerange.

C+a Select all.

ESCAPE Select none.

A+\ Switch between range and rectangular selection mode.

C+\ Switch between single and multiple selection mode.

Cte i Invert selection.

Scrolling

For details, see the section called “Multiple Views'.

Cre CHj

Ensure current line isvisible, and send focus to the text
area.
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Keyboard Shortcuts

Cte C#n Center caret on screen.
C+' ; CH Scroll up; down oneline.
A+ A+ Scroll up; down one page.

Text Editing

For details, see the section called “Undo and Redo”, the section called “Inserting and Deleting
Text”, the section called “Working With Words’, the section called “Working With Lines’ and the
section called “Working With Paragraphs”.

C+z

Undo.

Ct+te C+z

Redo.

BACK_SPACE; DELETE

Delete character before; after caret.

C+BACK_SPACE; C+DELETE

Delete word before; after caret.

C+d;C+re d

Delete line; paragraph.

CS+BACK_SPACE; CS+DELETE

Delete from caret to beginning; end of line.

Cte r

Remove trailing whitespace from the current line (or all
selected lines).

C+j Join lines.
C+b Complete word.
C+e f Format paragraph (or selection).

Clipboard and Registers

For details, see the section called “Transferring Text”.

C+x or S+DELETE

Cut selected text to clipboard.

C+c or C+l NSERT

Copy selected text to clipboard.

C+te Ctu Append selected text to clipboard, removing it from the
buffer.

C+e Cta Append selected text to clipboard, leaving it in the buffer.

C+v or S+1 NSERT Paste clipboard contents.

C+e Ctp Vertically paste clipboard contents.

C+tr C+x key Cut selected text to register key.

C+r C+c key Copy selected text to register key.

C+r Ct+u key Append selected text to register key, removing it from the
buffer.

C+r Cta key Append selected text to register key, leaving it in the
buffer.

C+r Ct+v key Paste contents of register key.

C+r C+p key Vertically paste contents of register key.

C+te Ctv Paste previous.

C+e Cty Paste deleted.

Markers
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Keyboard Shortcuts

For details, see the section called “Markers’.

C+e Ctm If current line doesn't contain a marker, one will be added.
Otherwise, the existing marker will be removed. Use the
M ar kers menu to return to markers added in this manner.

C+t key Add marker with shortcut key .

C+y key Go to marker with shortcut key.

C+tu key Select to marker with shortcut key.

C+k key Go to marker with shortcut key, and move the marker to
the previous caret position.

C+e C+,; Cte C+. Move caret to previous,; next marker.

Search and Replace

For details, see the section called “ Search and Replace”.

C+f Open search and replace dialog box.
C+g Find next.

C+h Find previous.

C+e C+b Search in open buffers.

Ct+e C+d Search in directory.

C+e C+r Replace in selection.

C+e Ctg Replace in selection and find next.
C+, Incremental search bar.

At, HyperSearch bar.

C+. Incremental search for word under the caret.
A+, HyperSearch for word under the caret.
C+te CHi Toggle ignore case.

C+e Ctx Toggle regular expressions.

Source Code Editing

For details, see the section called “ Abbreviations”, the section called “ Tabbing and Indentation” and
the section called “Commenting Out Code”.

C+; Expand abbreviation.

A+LEFT; A+RI GAT Shift current line (or all selected lines) left; right.

S+TAB; TAB Shift selected lines left; right. Note that pressing TAB with
no selection active will insert atab character at the caret
position.

CHi Indent current line (or all selected lines).

C+e Ctc Range comment selection.

C+te C+k Line comment selection.

Folding and Narrowing

For details, see the section called “Folding” and the section called “Narrowing”.
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Keyboard Shortcuts

A+BACK_SPACE Collapse fold containing caret.

A+ENTER Expand fold containing caret one level only.

AS+ENTER Expand fold containing caret fully.

C+e X Expand al folds.

Cte a Add explicit fold.

Cte s Select fold.

C+e ENTER key Expand folds with level lessthan key, collapse al others.

Cte n n Narrow to fold.

Cte n s Narrow to selection.

A+UP; A+DOVN Moves caret to previous; next fold.

C+te u Moves caret to the parent fold of the one containing the
caret.

Macros

For details, see Chapter 8, Using Macros.

C+tm C+r Record macro.

C+m C+m Record temporary macro.
C+m C+s Stop recording.

C+m C+p Run temporary macro.

Alternative Shortcuts

A few frequently-used commands have alternative shortcuts intended to help you keep your hands
from moving all over the keyboard.

Atj ; A+l Move caret to previous, next character.

At+i; Atk Move caret up, down oneline.

A+q; A+a Move caret up, down one screenful.

A+z First non-whitespace character of line, beginning of line,

first visible line (repeated presses).

A+X Last non-whitespace character of line, end of line, last
visible line (repeated presses).
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Appendix B. The Activity Log

The activity log is very useful for troubleshooting problems, and helps when developing plugins.
Utilities>Troubleshooting>Activity L og displays the last 500 lines of the activity log. By defaullt,
the activity log is shown in afloating window. Thiswindow can be docked using the commandsin
its top-left corner popup menu; see the section called “Window Docking”.

The complete log can befound intheact i vi ty. | og fileinside the jEdit settings directory, the
path of which is shown inside the activity log window.

jEdit writes the following information to the activity log:

» Information about your Javaimplementation (version, operating system, architecture, etc).

« All error messages and runtime exceptions (most errors are shown in dialog boxes as well, but
the activity log usually contains more detailed and technical information).

» All sorts of debugging information that can be helpful when tracking down bugs.

» Information about loaded plugins.

While jEdit is running, the log file on disk may not always accurately reflect what has been logged,
due to buffering being done for performance reasons. To ensure the file on disk is up to date, invoke

the Utilities>Troubleshooting>Update Activity Log on Disk command. The log fileisaso
automatically updated on disk when jEdit exits.
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Appendix C. History Text Fields

The text fields in the search and replace dialog box and the file system browser remember the last 20
entered strings by default. The number of strings to remember can be changed in the Appear ance
pane of the Utilities>Global Options dialog box; see the section called “ The Appearance Pane”.

Pressing UP recalls previous strings. Pressing DOWN after recalling previous strings recalls later
strings.

Pressing S+UP or S+DOWN will search backwards or forwards, respectively, for strings beginning
with the text already entered in the text field.

Clicking the triangle to the right of the text field, or clicking with the right-mouse button anywhere
else will display a pop-up menu of all previously entered strings; selecting one will input it into the
text field. Holding down Shi f t while clicking will display a menu of all previously entered strings
that begin with the text already entered.
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Appendix D. Glob Patterns

jEdit uses glob patterns similar to those in the various Unix shellsto implement file namefiltersin

the file system browser. Glob patterns resemble regular expressions somewhat, but have a much

simpler syntax. The following character sequences have special meaning within a glob pattern:

* ? matches any one character

* * matches any number of characters

» {!gl ob} Matchesanything that does not match gl ob

 {a, b, c} matchesany oneof a, b orc

» [abc] matchesany characterintheseta, b orc

e [”~abc] matchesany character notintheseta, b orc

» [ a-z] matchesany character intherangea to z, inclusive. A leading or trailing dash will be
interpreted literally

In addition to the above, a number of “character class expressions’ may be used as well:

* [[:al num]] matchesany alphanumeric character

 [[:al pha:]] matchesany aphabetical character

* [[:blank:]] matchesaspace or horizontal tab

e [[:cntrl:]] matchesacontrol character

o [[:digit:]] matchesadecimal digit

e [[:graph:]] matchesanon-space, non-control character

o [[:1ower:]] matchesalowercase letter

e [[:print:]] sameas|[[:graph:]], butasospaceandtab
* [[:punct:]] matchesapunctuation character
 [[:space:]] matchesany whitespace character, including newlines
* [[:upper:]] matchesan uppercase letter

e [[:xdigit:]] matchesavalid hexadecimal digit
Here are some examples of glob patterns:

o * -dlfiles

o *_ java -adl fileswhose namesend with “ java’.

* . [ ch] -al fileswhose names end with either “.c” or “.h".

[~#] * - dl fileswhose names do not start with “#”.
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Appendix E. Regular Expressions

jEdit uses regular expressions to implement inexact search and replace. A regular expression
consists of a string where some characters are given special meaning with regard to pattern
matching.

Within aregular expression, the following characters have special meaning:

Positional Operators

e matches at the beginning of aline
* $ matches at the end of aline

* \ b matches at aword break

* \ B matches at anon-word break

* \ < matches at the start of aword

e \ > matches at the end of aword

One-Character Operators

* . matches any single character

* \ d matches any decimal digit

* \ Dmatches any non-digit

* \ n matches the newline character

* \ s matches any whitespace character

» \ S matches any non-whitespace character

* \'t matchesahorizontal tab character

» \ wmatches any word (alphanumeric) character

* \ Wmatches any non-word (al phanumeric) character

e \\ matchesthe backdash (“\") character

Character Class Operator

e [abc] matchesany characterintheseta, b orc
e [”™abc] matchesany character notintheseta, b orc

e [a-z] matchesany character intherangea to z, inclusive. A leading or trailing dash will be
interpreted literally

 [[:al num]] matchesany alphanumeric character

* [[:al pha:]] matchesany aphabetical character




Regular Expressions

e [[:blank:]] matchesaspace or horizontal tab

e [[:cntrl:]] matchesacontrol character

e [[:digit:]] matchesadecimal digit

* [[:graph:]] matchesanon-space, non-control character

e [[:1ower:]] matchesalowercase letter

o [[:print:]] sameas[[:graph:]], butalso spaceand tab

e [[:punct:]] matchesapunctuation character

* [[:space:]] matchesany whitespace character, including newlines
e [[:upper:]] matchesan uppercase letter

* [[:xdigit:]] matchesavalid hexadecimal digit

Subexpressions and Backreferences

» (abc) matches whatever the expression abc would match, and saves it as a subexpression.
Also used for grouping

e (?:...) puregrouping operator, does not save contents

e (?#...) embedded comment, ignored by engine

e (?=...) positive lookahead; the regular expression will match if the text in the brackets
matches, but that text will not be considered part of the match

* (?'...) negativelookahead; the regular expression will match if the text in the brackets does
not match, and that text will not be considered part of the match

* \ nwhere0 < n < 10, matches the same thing the nth subexpression matched. Can only be used
in the search string

e $n where 0 < n < 10, substituted with the text matched by the nth subexpression. Can only be
used in the replacement string

Branching (Alternation) Operator

» a| b matches whatever the expression a would match, or whatever the expression b would
match.

Repeating Operators

These symbols operate on the previous atomic expression.

e ? matches the preceding expression or the null string
» * matches the null string or any number of repetitions of the preceding expression
e+ matches one or more repetitions of the preceding expression

* {n} matches exactly mrepetitions of the one-character expression
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Regular Expressions

* {m n} matches between mand n repetitions of the preceding expression, inclusive

* {m } matches mor more repetitions of the preceding expression

Stingy (Minimal) Matching

If arepeating operator (above) isimmediately followed by a?, the repeating operator will stop at
the smallest number of repetitions that can complete the rest of the match.
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Appendix F. Macros Included With

iEdit

jEdit comes with alarge number of sample macros that perform avariety of tasks. The following
index provides short descriptions of each macro, in some cases accompanied by usage notes.

In addition to the macrosincluded with jEdit, a very large collection of user-contributed macrosis
available in the “Downloads’ section of the community.jedit.org web site. There are detailed
descriptions for each macro as well as a search facility.

Clipboard Macros

These macros copy or cut text to the clipboard.

Copy_Li nes_Cont ai ni ng. bsh

Copies all lines from the current buffer, containing a user-supplied string, to the clipboard.

Cut _Li nes_Cont ai ni ng. bsh

Cuts all lines from the current buffer, containing a user-supplied string, to the clipboard.
Copy_Sel ection_or_Line. bsh

If no text is selected, the current line is copied to the clipboard, otherwise the selected text is
copied to the clipboard. Some editors have this has the default copy behavior. To achieve the
same effect in jEdit, bind this macro to C+c in the Shortcuts pane of the Utilities>Global
Options dialog box.

Cut _Sel ection_or _Line. bsh

If no text is selected, the current lineis cut to the clipboard, otherwise the selected text is cut to
the clipboard. Some editors have this has the default cut behavior. To achieve the same effect in
jEdit, bind this macro to C+x in the Shortcuts pane of the Utilities>Global Options dialog box.
Copy_Vi si bl e_Li nes. bsh

Copiesthe visible lines from the current buffer to the Clipboard. Linesthat are not visible
becuase they are folded are not copied.

Editing Macros

These macros automate various text editing tasks.

Emacs_Next Li ne. bsh

Moves the cursor to the next line, centering the current line in the middle of the text areaif the
cursor is at the bottom of the text area.

Emacs_Previ ous_Li ne. bsh

Moves the cursor to the previous line, centering the current line in the middle of the text areaif
the cursor is at the top of the text area.

Go_to_Col unn. bsh
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Macros Included With jEdit

Prompts the user for a column position on the current line, then moves the caret there.
* G eedy_Backspace. bsh

If buffer is using soft tabs, this macro will backspace to the previous tab stop, if all characters
between the caret and the tab stop are spaces. In all other cases a single character is removed.

e Greedy Del ete. bsh

If abuffer isusing soft tabs, this macro will delete tabSize number of spaces, if al the characters
between the caret and the next tab stop are spaces. In all other cases a single character is deleted.

e Greedy Left.bsh
If abuffer is using soft tabs, this macro will move the caret tabSize spacesto the left, if al the
characters between the caret and the previous tab stop are all spaces. In al other cases, the caret
ismoved a single character to the | eft.

* Greedy_Right.bsh
If abuffer is using soft tabs, this macro will move the caret tabSize spaces to the right, if all the
characters between the caret and the next tab stop are all spaces. In al other cases, the caret is
moved a single character to theright.

 Keywords_to_Upper_Case. bsh
Converts all keywords in the current buffer to upper case.

« Mde_Switcher. bsh

Displays amodal dialog with the current buffer's mode in atext field, allowing one to change
the mode by typing in its name.

ENTER selects the current mode; if the text is not avalid mode, the dialog still dismisses, but a
warning islogged to the activity log. ESACPE closes the dialog with no further action. TAB
attempts to auto-compl ete the mode name. Pressing TAB repeatedly cycles through the possible
completions. SHI FT- TAB cyclesthrough the completionsin reverse.

e Move_Li ne_Down. bsh
Moves the current line down one, with automatic indentation.

e Move_Line_Up. bsh

Moves the current line up one, with automatic indentation.

File Management Macros

These macros automate the opening and closing of files.

e Browse Directory. bsh
Opens a directory supplied by the user in the file system browser.
« Buffer_Switcher. bsh
Displays amodal dialog listing al open buffers, allowing one to switch to and/or close buffers.

ENTER switches to a buffer and closes the dialog, DELETE closes a buffer, SPACE switchesto a
buffer but does not close the dialog.
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Macros Included With jEdit

e Close All _Except Active. bsh

Closes all files except the current buffer.

Prompts the user to save any buffer containing unsaved changes.
e Copy_Path_to_dipboad. bsh

Copies the current buffer's path to the clipboard.
» Copy_Nane_to_d i pboad. bsh

Copies the current buffer's filename to the clipboard.
» Delete Current.bsh

Deletes the current buffer's file on disk, but doesn't close the buffer.
* G ob_Cose. bsh

Closes all open buffers matching a given glob pattern.
* Insert_Sel ection. bsh

Assumes the current selection isfile path and tries replaces the selection with the contents of the
file. Does nothing if no text is selected or the selection spans multiple lines.

* Next_Dirty_Buffer.bsh
Switches to the next dirty buffer, if thereis one.
* Open_Pat h. bsh
Opens the file supplied by the user in an input dialog.
* Open_Sel ection. bsh
Opens the file named by the current buffer's selected text.
 Toggl e_ReadOnly. bsh

Toggles alocal file's read-only flag. Uses platform-specific commands, so it only works on
Windows, Unix and MacOS X.

User Interface Macros

Description.

e« Decrease_Font _Size. bsh
Decreases the font size in the gutter and text area by 1 point.
e Increase_Font _Size. bsh
Increases the font size in the gutter and text area by 1 point.
e (Open_Cont ext _Menu. bsh
Opens the text area context menu just below and to the right of the caret.

e Toggl e Bottom Docki ng_Area. bsh
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Macros Included With jEdit

Expands or collapses the bottom docking area, depending on it's current state.
 Toggl e_Left_Docki ng_Area. bsh

Expands or collapses the left docking area, depending on it's current state.
» Toggl e_Ri ght _Docki ng_Area. bsh

Expands or collapses the right docking area, depending on it's current state.
» Toggl e_Top_Docki ng_Area. bsh

Expands or collapses the top docking area, depending on it's current state.

Java Code Macros

These macros handle text formatting and generation tasks that are particularly useful in writing Java
code.

e Create_Constructor. bsh
Inserts constructor for the class at the current caret position.

e Get_C ass_Nane. bsh
Inserts a Java class name based upon the buffer's file name.

 Get _Package_Nane. bsh
Inserts a plausible Java package name for the current buffer.
The macro compares the buffer's path name with the elements of the classpath being used by the
jEdit session. An error message will be displayed if no suitable package nameis found. This
macro will not work if jEdit is being run as a JAR file without specifying a classpath; in that
case the classpath seen by the macro consists solely of the JAR file.

e Java_File_Save. bsh

Abstract

Acts as awrapper script to the Save As action. If the buffer isanew file, it scansthe first 250
lines for a Java class or interface declaration. On finding one, it extracts the appropriate filename
to be used in the Save As dialog.

» Make_Get _and_Set Met hods. bsh
Creates get XXX() or set XXX() methods that can be pasted into the buffer text.

This macro presents adialog that will “grab” the names of instance variables from the caret line
of the current buffer and paste a corresponding get XXX() or set XXX() method to one of two
text areasin the dialog. The text can be edited in the dialog and then pasted into the current
buffer using the Insert... buttons. If the caret is set to aline containing something other than an
instance variable, the text grabbing routineis likely to generate nonsense.

As explained in the notes accompanying the source code, the macro uses a global variable which
can be set to configure the macro to work with either Java or C++ code. When set for use with
C++ code, the macro will also write (in commented text) definitions of get XXX() or

set XXX() suitablefor inclusion in a header file.
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Macros Included With jEdit

e Preview Javadoc_of Buffer.bsh
Create and display APl documentation for the current buffer.

The macro includes various configuration variables you can change; see the comment at the
beginning of the macro source for details.

Miscellaneous Macros

While these macros do not fit easily into the other categories, they all provide interesting and useful
functions.
e Display_Abbreviations. bsh
Displays the abbreviations registered for each of jEdit's editing modes.
The macro provides aread-only view of the abbreviations contained in the “ Abbreviations’
option pane. Pressing a letter key will scroll the table to the first entry beginning with that |etter.
A further option is provided to write a selected mode's abbreviations or all abbreviationsin a
text buffer for printing as a reference. Notes in the source code listing point out some display
options that are configured by modifying global variables.
« Display_Actions. bsh
Displaysalist of all the actions known to jEdit categorised by their action set.
This macro can be a useful referenceif you want to use the jEdit 4.2 action bar.
 Display_Character_Code. bsh
Display int and hex values for the character at the caret, in the status bar.
 Display_Shortcuts. bsh
Displays a sorted list of the keyboard shortcuts currently in effect.
The macro provides a combined read-only view of command, macro and plugin shortcuts.
Pressing aletter key will scroll the table to the first entry beginning with that letter. A further
option is provided to write the shortcut assignments in atext buffer for printing as a reference.
Notes in the source code listing point out some display options that are configured by modifying
global variables.

e Evaluate_Buffer_in_BeanShell.bsh

Evaluates contents of current buffer as a BeanShell script, and opens a new buffer to receive any
text output.

Thisisaquick way to test amacro script even beforeitstext is saved to afile. Opening a new
buffer for output is a precaution to prevent the macro from inadvertently erasing or overwriting
itself. BeanShell scripts that operate on the contents of the current buffer will not work
meaningfully when tested using this macro.

e Hex_Convert. bsh
Converts byte characters to their hex eguivalent, and vice versa.

e Hyper Search Results to Buffer.bsh
Writes HyperSeach results to a new buffer.

 Include_Quard. bsh
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Macros Included With jEdit

Intended for C/C++ header files, this macro inserts a preprocessor directive in the current buffer
to ensure that the header isincluded only once per compilation unit.

To use the macro, first place the caret at the beginning of the header file before any
uncommented text. The macro will return to this position upon completion. The defined term
that triggers the “include guard” istaken from the buffer's name.

Make_Bug_Report. bsh
Creates anew buffer with installation and error information extracted from the activity log.

The macro extractsinitial messages written to the activity log describing the user's operating
system, JDK, jEdit version and installed plugins. It then appends the last set of error messages
written to the activity log. The new text buffer can be saved and attached to an email message or
abug report made on SourceForge.

Run_Scri pt. bsh

Runs script using interpreter based upon buffer's editing mode (by default, determined using file
extension). Y ou must have the appropriate interpreter (such as Perl, Python, or Windows Script
Host) installed on your system.

Show_Thr eads. bsh

Displaysin atree format all running Javathreads of the current Java Virtual Machine.

Property Macros

Text

These macros produce lists or tables containing properties used by the Java platform or jEdit itself.

Insert_Buffer_Properties. bsh
Inserts buffer-local propertiesinto the current buffer.

If the buffer's mode has a line comment defined, or comment start and end defined, the inserted
properties will be commented out.

j Edit _Properties. bsh

Writes an unsorted list of jEdit properties in a new buffer.

Look_and_Feel Properties. bsh

Writes an unsorted list of the names of Java L ook and Feel propertiesin anew buffer.
System Properties. bsh

Writes an unsorted list of al Java system propertiesin a new buffer.

Macros

These macros generate various forms of formatted text.

Add_Prefix_and_Suf fix. bsh

Adds user-supplied “ prefix” and “suffix” text to each line in agroup of selected lines.
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Macros Included With jEdit

Text is added after leading whitespace and before trailing whitespace. A dialog window receives
input and “remembers’ past entries.

Col or _Pi cker. bsh
Displays a color picker and inserts the selected color in hexadecimal format, prefixed with a“#".
Dupl i cate_Li ne. bsh

Duplicates the line on which the caret liesimmediately beneath it and moves the caret to the new
line.

I nsert _Date. bsh

Inserts the current date and time in the current buffer.

Theinserted text includes a representation of the time in the “Internet Time” format.
I nsert_Tag. bsh

Inserts abalanced pair of HTML/SGML/XML markup tags as supplied in an input dialog. The
tags will surround any selected text.

Next Char. bsh

Finds next occurrence of character on current line.

The macro takes the next character typed after macro execution as the character being searched.
That character is not displayed. If the character does not appear in the balance of the current line,

Nno action occurs.

This macro illustrates the use of | nput Handl er . r eadNext Char () asameans of
obtaining user input. See the section called “Using a Single Keypress as Input”.

Rever se_Li nes. bsh

Reverses the selected lines or the entire buffer if no lines are selected. Does not support
Rectangular Selections.

Si ngl e_Space_Buf fer. bsh

Removes every second line, if they are all blank.
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Part II. Writing Edit Modes

This part of the user's guide covers writing edit modes for jEdit.

Edit modes specify syntax highlighting rules, auto indent behavior, and various other customizations

for editing different file types. For general information about edit modes, see the section called “Edit
Modes’.

This part of the user's guide was written by Slava Pestov <sl ava@ edi t . or g>.




Chapter 10. Mode Definition Syntax

Edit modes are defined using XML, the extensible markup language; mode files have the extension
. xm . XML isavery simple language, and as a result edit modes are easy to create and modify.
This section will start with ashort XML primer, followed by detailed information about each
supported tag and highlighting rule.

Editing a mode or a mode catalog file within jEdit will cause the changes to take effect immediately.
If you edit modes using another application, the changes will take effect after the Utilities>Reload
Edit M odes command isinvoked.

An XML Primer

A very simple XML file (which also happens to be an edit mode) 1ooks like so:
<?xm version="1.0"?>
<! DOCTYPE MCDE SYSTEM " xnode. dt d" >
<MODE>
<PROPS>
<PROPERTY NAME="comment Start" VALUE="/*" [>
<PROPERTY NAME="conmment End" VALUE="*/" [>
</ PROPS>
<RULES>
<SPAN TYPE=" COVMENT1" >
<BEQ N>/ *</ BEG N>
<END>*/ </ END>
</ SPAN>

</ RULES>
</ MODE>

Note that each opening tag must have a corresponding closing tag. If there is nothing between the
opening and closing tags, for example <TAG></ TAG>, the shorthand notation <TAG / > may be
used. An example of this shorthand can be seen in the <PROPERTY> tags above.

XML is case sensitive. Span or span is not the same as SPAN.

Toinsert aspecia character such as < or > literally in XML (for example, inside an attribute value),
you must write it as an entity. An entity consists of the character's symbolic name enclosed with “&”
and “;”. The most frequently used entities are:

* &l t; -Thelessthan (<) character

» &gt ; - Thegreater-than (>) character

* &anp; - Theampersand (&) character

For example, the following will cause a syntax error:

<SEQ TYPE=" OPERATOR" >&</ SEQ>

Instead, you must write:
<SEQ TYPE=" OPERATCR' >&anp; </ SEQ>

Now that the basics of XML have been covered, the rest of this section will cover each construct in
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detail.

The Preamble and MODE tag

Each mode definition must begin with the following:

<?xm version="1.0"?7>
<! DOCTYPE MODE SYSTEM " xnode. dtd" >

Each mode definition must also contain exactly one MODE tag. All other tags (PROPS, RULES)
must be placed inside the MODE tag. The MODE tag does not have any defined attributes. Hereis an
example:

<MODE>

... node definition goes here ...
</ MCDE>

The PROPS Tag

The PROPS tag and the PROPERTY tagsinside it are used to define mode-specific properties. Each
PROPERTY tag must have a NAME attribute set to the property's name, and a VAL UE attribute with
the property's value.

All buffer-local propertieslisted in the section called “Buffer-Loca Properties’ may be given values
in edit modes.

The following mode properties specify commenting strings:

» conment End - the comment end string, used by the Range Comment command.
e« comment St art - the comment start string, used by the Range Comment command.

* |ineComent - theline comment string, used by the Line Comment command.
When performing auto indent, a number of mode properties determine the resulting indent level:

« Thelineand the one before it are scanned for bracketslisted inthei ndent Cl oseBr acket s
and i ndent OpenBr acket s properties. Opening brackets in the previous line increase indent.

If 1i neUpd osi ngBr acket issettot r ue, then closing brackets on the current line will
line up with the line containing the matching opening bracket. For example, in Java mode
| i neUpd osi ngBr acket issettotr ue, resulting in brackets being indented like so:

/1 Code

{
/'l More code

If 1i neUpd osi ngBracket issettof al se, theline after aclosing bracket will be lined up
with the line containing the matching opening bracket. For example, in Lisp mode
| i neUpd osi ngBracket issettof al se, resulting in brackets being indented like so:

(foo '"a-paraneter
(crazy-p)
(bar baz ()))
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(print "hello world")

» If the previous line contains no opening brackets, or if thedoubl eBr acket | ndent property
issettot r ue, the previouslineis checked against the regular expressionsin the
i ndent Next Li ne andi ndent Next Li nes properties. If the previous line matches the
former, the indent of the current line isincreased and the subsequent line is shifted back again. If
the previous line matches the latter, the indent of the current and subsequent linesis increased.

In Javamode, for example, thei ndent Next Li ne property is set to match control structures
such as“if”, “else”, “while”, and so on.

Thedoubl eBr acket | ndent property, if set to the default of f al se, resultsin code
indented like so:

\{Nhi | e(obj ects. hasNext ())

bj ect next = objects. hasNext();
i f(next instanceof Paintable)
next . paint(Qg);

On the other hand, settings this property to “true” will give the following result:
whi | e(obj ects. hasNext ())
{

bj ect next = objects. hasNext();
i f(next instanceof Paintable)
next . pai nt (g);

Hereis the complete <PROPS> tag for Java mode:

<PROPS>
<PROPERTY NAME="comment Start" VALUE="/*" [>
<PROPERTY NAME="comment End" VALUE="*/" [>
<PROPERTY NAME="|ineComment" VALUE="//" [>
<PROPERTY NAME="wor dBr eakChars" VALUE=", +- =&l t; &gt ; / ?"&amp; *" />

<l-- Auto indent -->
<PROPERTY NAME="i ndent OpenBr ackets" VALUE="{" />
<PROPERTY NAME="i ndent Cl oseBrackets" VALUE="}" />
<PROPERTY NAME="i ndent Next Li ne"
VALUE="\s*(((if|while)\s*\(|else\s*|else\s+if\s*\(|for\s*\(.*\))["{
<l-- set this to "true' if you want to use GNU coding style -->
<PROPERTY NAME="doubl eBracket | ndent" VALUE="fal se" />
<PROPERTY NAME="1i neUpd osi ngBracket" VALUE="true" />
</ PROPS>

The RULES Tag

RULES tags must be placed inside the MODE tag. Each RULES tag defines aruleset. A ruleset
consists of anumber of parser rules, with each parser rule specifying how to highlight a specific
syntax token. There must be at |east one ruleset in each edit mode. There can also be more than one,
with different rulesets being used to highlight different parts of a buffer (for example, in HTML
mode, one rule set highlights HTML tags, and another highlights inline JavaScript). For information
about using more than one ruleset, see the section called “ The SPAN Tag”.

The RULES tag supports the following attributes, al of which are optional:
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* SET - the name of this ruleset. All rulesets other than the first must have aname.

* | GNORE_CASE - if set to FALSE, matches will be case sensitive. Otherwise, case will not
matter. Default is TRUE.

e« NO WORD_SEP - any non-al phanumeric character not in thislist is treated as a word separator
for the purposes of syntax highlighting.

o DEFAULT - the token type for text which doesn't match any specific rule. Default iSNULL. See
the section called “Token Types’ for alist of token types.

« HGHLIGHT DIG TS

e DI A T_RE - see below for information about these two attributes.

Here is an example RULES tag:

<RULES | GNORE_CASE="FALSE" H GHLI GHT_DI G TS="TRUE" >
... parser rules go here ...
</ RULES>

Highlighting Numbers

If the Hl GHLI GHT_DI @ TS attribute is set to TRUE, jEdit will attempt to highlight numbersin
thisruleset.

Any word consisting entirely of digits (0-9) will be highlighted with the DI G T token type. A word
that contains other letters in addition to digits will be highlighted with the DI G T token type only if
it matches the regular expression specified inthe DI G T_RE attribute. If this attribute is not
specified, it will not be highlighted.

Hereisan example DI G T_RE regular expression that highlights Java-style numeric literals
(normal numbers, hexadecimals prefixed with Ox, numbers suffixed with various type indicators,
and floating point literals containing an exponent):

DIG T _RE="(OX[[:xdigit:]]+ [[:digit:]]+(e[[:digit:]]*)?)[ILdDf F]?"

Regular expression syntax is described in Appendix E, Regular Expressions.

Rule Ordering Requirements

Y ou might encounter this very common pitfall when writing your own modes.

Since jEdit checks buffer text against parser rulesin the order they appear in the ruleset, more
specific rules must be placed before generalized ones, otherwise the generalized rules will catch
everything.

Thisis best demonstrated with an example. The following isincorrect rule ordering:

<SPAN TYPE=" MARKUP" >
<BEGQ N>[ </ BEG N>
<END>] </ END>

</ SPAN>

<SPAN TYPE=" KEYWORD1" >
<BEG N>[ ! </ BEG N>
<END>] </ END>

</ SPAN>

If you write the above in arule set, any occurrence of “[” (even things like “[!DEFINE”, etc) will be
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highlighted using the first rule, because it will be the first to match. Thisis most likely not the
intended behavior.

The problem can be solved by placing the more specific rule before the general one;

<SPAN TYPE=" KEYWORDL" >
<BEG N>[ ! </ BEG N>
<END>] </ END>

</ SPAN>

<SPAN TYPE=" MARKUP" >
<BEG N>[ </ BEG N>

<END>] </ END>
</ SPAN>

Now, if the buffer contains the text “[!SPECIAL]", the rules will be checked in order, and the first
rule will be the first to match. However, if you write “[FOQ]”, it will be highlighted using the
second rule, which is exactly what you would expect.

Per-Ruleset Properties

The PROPS tag (described in the section called “The PROPS Tag") can also be placed inside the
RULES tag to define ruleset-specific properties. The following properties can be set on a per-rul eset
basis:

» conment End - the comment end string.

e conmment St art - the comment start string.

e |ineConment - theline comment string.

This allows different parts of afileto have different comment strings (in the case of HTML, for
example, in HTML text and inline JavaScript). For information about the commenting commands,
see the section called “Commenting Out Code”.

The TERMINATE Tag

The TERM NATE rule, which must be placed inside a RULES tag, specifies that parsing should stop
after the specified number of characters have been read from aline. The number of charactersto
terminate after should be specified with the AT _CHAR attribute. Here is an example:

<TERM NATE AT_CHAR="1" />

Thisruleisused in Patch mode, for example, because only the first character of each line affects
highlighting.

The SPAN Tag

The SPAN rule, which must be placed inside a RULES tag, highlights text between a start and end
string. The start and end strings are specified inside child elements of the SPAN tag. The following
attributes are supported:

» TYPE - The token type to highlight the span with. See the section called “ Token Types’ for alist
of token types.

e AT_LI NE_START - If set to TRUE, the span will only be highlighted if the start sequence
occurs at the beginning of aline.
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e AT _VH TESPACE_END- If set to TRUE, the span will only be highlighted if the start sequence
isthe first non-whitespace text in the line.

* AT_WORD_START - If set to TRUE, the span will only be highlighted if the start sequence
occurs at the beginning of aword.

» DELEGATE - text inside the span will be highlighted with the specified ruleset. To delegate to a
ruleset defined in the current mode, just specify its name. To delegate to aruleset defined in
another mode, specify aname of the form node: : r ul eset . Note that the first (unnamed)
ruleset inamodeis called “MAIN”.

o EXCLUDE_MATCH - If set to TRUE, the start and end sequences will not be highlighted, only the
text between them will.

* NO_ESCAPE - If set to TRUE, the ruleset's escape character will have no effect before the span's
end string. Otherwise, the presence of the escape character will cause that occurrence of the end
string to be ignored.

* NO_LI NE_BREAK - If set to TRUE, the span will not cross line breaks.

«  NO WORD BREAK - If set to TRUE, the span will not cross word breaks.

Note that the AT_LI NE_START, AT_WH TESPACE_END and AT_WORD_START attributes can
also be used on the BEA N and END elements. Setting these attributes to the same value on both
elements has the same effect as setting them on the SPAN element.

Here isa SPAN that highlights Java string literals, which cannot include line breaks:

<SPAN TYPE="LI TERAL1" NO_LI NE_BREAK="TRUE" >
<BEG N>" </ BEG N>
<END>" </ END>

</ SPAN>

Here isa SPAN that highlights Java documentation comments by delegating to the “JAVADOC”
ruleset defined elsewhere in the current mode:

<SPAN TYPE="COMVENT2" DELEGATE="JAVADCC' >
<BEG N>/ ** </ BEA N>
<END>*/ </ END>

</ SPAN>

Hereisa SPAN that highlights HTML cascading stylesheets inside <STYLE> tags by delegating to
the main ruleset in the CSS edit mode:

<SPAN TYPE="MARKUP' DELEGATE="css:: MAI N'>
<BEG N>&l t ; styl e&gt ; </ BEG N>
<END>&l t ; / st yl e&gt ; </ END>

</ SPAN>

The SPAN_REGEXP Tag

The SPAN_REGEXP ruleis similar to the SPAN rule except the start sequenceistakento be a
regular expression. In addition to the attributes supported by the SPAN tag, the HASH CHAR
attribute must be specified. It must be set to the first character that the regular expression matches.
This rules out using regular expressions which can match more than one character at the start
position. The regular expression match cannot span more than one line, either.

Any text matched by groupsin the BEG N regular expression is substituted in the END string. See
below for an example of where thisis useful.
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Regular expression syntax is described in Appendix E, Regular Expressions.
Hereisa SPAN_REGEXP rule that highlights “read-ins’ in shell scripts:

<SPAN_REGEXP HASH CHAR="<" TYPE="L| TERAL1" DELEGATE="LI TERAL" >
<BEGQ N><! [ CDATA[ <<[[:space:]""]1*([[:alnum]_]+)[[:space:]"'"]*]]></BEG N>
<END>$1</ END>

</ SPAN_REGEXP>

Hereisa SPAN_REGEXP rule that highlights constructs placed between <#f t | and >, aslong as
the<#f t | isfollowed by aword bresk:

<SPAN REGEXP TYPE="KEYWORD1" HASH CHAR="&lt;" DELEGATE="EXPRESSI ON'>
<BEG N>&l t; #ft 1\ &gt ; </ BEG N>
<END>&gt ; </ END>

</ SPAN_REGEXP>

The EOL_SPAN Tag

An EOL_SPANissimilar to a SPAN except that highlighting stops at the end of the line, and no end
sequence needs to be specified. The text to match is specified between the opening and closing
ECL_SPAN tags. The following attributes are supported:

» TYPE - The token type to highlight the span with. See the section called “ Token Types’ for alist
of token types.

e AT_LI NE_START - If set to TRUE, the span will only be highlighted if the start sequence
occurs at the beginning of aline.

e AT _VH TESPACE_END - If set to TRUE, the span will only be highlighted if the sequenceis
the first non-whitespace text in the line.

* AT_WORD_START - If set to TRUE, the span will only be highlighted if the start sequence
occurs at the beginning of aword.

» DELEGATE - text inside the span will be highlighted with the specified ruleset. To delegate to a
ruleset defined in the current mode, just specify its name. To delegate to aruleset defined in
another mode, specify aname of the form node: : r ul eset . Note that the first (unnamed)
ruleset inamodeis called “MAIN”.

» EXCLUDE_MATCH - If set to TRUE, the start and end sequences will not be highlighted, only the
text between them will.

Hereisan EQL_ SPAN that highlights C++ comments:

<EQOL_SPAN TYPE="COMMENT1" >/ / </ EOL_SPAN>

The EOL_SPAN_REGEXP Tag

The EOL_SPAN_REGEXP ruleissimilar to the EOL_ SPAN rule except the match sequence is taken
to be aregular expression. In addition to the attributes supported by the ECL_ SPAN tag, the
HASH_CHAR attribute must be specified. It must be set to the first character that the regular
expression matches. This rules out using regular expressions which can match more than one
character at the start position. The regular expression match cannot span more than one ling, either.

Regular expression syntax is described in Appendix E, Regular Expressions.

Hereisan EQL_SPAN REGEXP that highlights MS-DOS batch file comments, which start with
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REM followed by any whitespace character, and extend until the end of the line;

<EOL_SPAN_REGEXP AT_WH TESPACE_END="TRUE" HASH CHAR="R' TYPE="COMMENT1" >REM s</

The MARK_PREVIOUS Tag

The MARK _PREVI QUS rule, which must be placed inside a RULES tag, highlights from the end of
the previous syntax token to the matched text. The text to match is specified between opening and
closing MARK _PREVI OUS tags. The following attributes are supported:

e TYPE - Thetoken type to highlight the text with. See the section called “Token Types’ for alist
of token types.

* AT_LI NE_START - If set to TRUE, the sequence will only be highlighted if it occurs at the
beginning of aline.

* AT_VH TESPACE_END- If set to TRUE, the sequence will only be highlighted if it isthe first
non-whitespace text in the line.

e« AT _WORD START - If set to TRUE, the sequence will only be highlighted if it occurs at the
beginning of aword.

» EXCLUDE_MATCH - If set to TRUE, the match will not be highlighted, only the text before it
will.
Hereisarule that highlights labels in Java mode (for example, “XXX:"):

<MARK_PREVI QUS AT_WH TESPACE_END=" TRUE"
EXCLUDE_MATCH="TRUE" >: </ MARK PREVI QUS>

The MARK_FOLLOWING Tag

The MARK_FOLLOW NGrule, which must be placed inside a RULES tag, highlights from the start
of the match to the next syntax token. The text to match is specified between opening and closing
MARK FOLLOW NGtags. The following attributes are supported:

e TYPE - The token type to highlight the text with. See the section called “Token Types’ for alist
of token types.

o AT_LI NE_START - If set to TRUE, the sequence will only be highlighted if it occurs at the
beginning of aline.

o AT_VH TESPACE_END- If set to TRUE, the sequence will only be highlighted if it isthe first
non-whitespace text in the line.

e AT _WORD START - If set to TRUE, the sequence will only be highlighted if it occurs at the
beginning of aword.

* EXCLUDE_MATCH - If set to TRUE, the match will not be highlighted, only the text after it will.

Hereisarulethat highlights variablesin Unix shell scripts (“$SCLASSPATH”, “$IFS’, etc):
<MARK_FOLLOW NG TYPE=" KEYWORD2" >$</ MARK_FOLLOW NG>

The SEQ Tag
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The SEQrule, which must be placed inside a RULES tag, highlights fixed sequences of text. The
text to highlight is specified between opening and closing SEQtags. The following attributes are
supported:

» TYPE - the token type to highlight the sequence with. See the section called “Token Types’ for
alist of token types.

e AT_LI NE_START - If set to TRUE, the sequence will only be highlighted if it occurs at the
beginning of aline.

o AT_VH TESPACE_END- If set to TRUE, the sequence will only be highlighted if it is the first
non-whitespace text in the line.

e AT _WORD START - If set to TRUE, the sequence will only be highlighted if it occurs at the
beginning of aword.

» DELEGATE - if this attribute is specified, all text after the sequence will be highlighted using
thisruleset. To delegate to aruleset defined in the current mode, just specify its name. To
delegate to aruleset defined in another mode, specify aname of the form node: : r ul eset.
Note that the first (unnamed) ruleset in amodeis called “MAIN”.

The following rules highlight a few Java operators:

<SEQ TYPE=" OPERATCR'" >+</ SEQ>
<SEQ TYPE=" OPERATCR' >- </ SEQ>
<SEQ TYPE=" OPERATCR" >* </ SEQ>
<SEQ TYPE=" OPERATOR' >/ </ SEQ>

The SEQ REGEXP Tag

The SEQ REGEXP ruleis similar to the SEQrule except the match sequence is taken to be aregular
expression. In addition to the attributes supported by the SEQtag, the HASH CHAR attribute must
be specified. It must be set to the first character that the regular expression matches. This rules out
using regular expressions which can match more than one character at the start position. The regular
expression match cannot span more than one line, either.

Here is an example of a SEQ REGEXP rule that highlights Perl's matcher constructions such as
m(.+):(\d+): (. +)/:

<SEQ REGEXP TYPE=" MARKUP"
HASH _CHAR="n{
AT_WORD_START="TRUE"
>n([[:punct:]])(?:.*?[M\])*?\ 1] sgi exom *</ SEQ REGEXP>

Regular expression syntax is described in Appendix E, Regular Expressions.

The IMPORT Tag

The | MPORT tag, which must be placed inside a RULES tag, loads all rules defined in agiven
ruleset into the current ruleset; in other words, it has the same effect as copying and pasting the
imported ruleset.

The only required attribute DEL EGATE must be set to the name of aruleset. To import aruleset
defined in the current mode, just specify its name. To import a ruleset defined in another mode,
specify aname of theform node: : r ul eset . Note that the first (unnamed) ruleset inamodeis
caled “MAIN".

One quirk is that the definition of the imported ruleset is not copied to the location of the | MPORT

73



Mode Definition Syntax

tag, but rather to the end of the containing ruleset. This has implications with rule-ordering; see the
section called “Rule Ordering Requirements’.

Hereis an example from the PHP mode, which extends the inline JavaScript highlighting to support
embedded PHP:

<RULES SET="JAVASCRI PT+PHP" >

<SPAN TYPE="MARKUP" DELEGATE="php: : PHP" >
<BEG N>&l t ; ?php</ BEG N>
<END>?&gt ; </ END>

</ SPAN>

<SPAN TYPE="MARKUP" DELEGATE="php: : PHP" >
<BEG N>&l t ; ?</ BEG N>
<END>?&gt ; </ END>

</ SPAN>

<SPAN TYPE="MARKUP" DELEGATE="php: : PHP" >
<BEG N>& t ; %</ BEG N>
<END>%&gt : </ END>

</ SPAN>

<I MPORT DELEGATE="j avascript:: MAIN'/>
</ RULES>

The KEYWORDS Tag

The KEYWORDS tag, which must be placed inside a RULES tag and can only appear once, specifies
alist of keywordsto highlight. Keywords are similar to SEQs, except that SEQs match anywherein
the text, whereas keywords only match whole words. Words are considered to be runs of text
separated by non-alphanumeric characters.

The KEYWORDS tag does not define any attributes.
Each child element of the KEYWORDS tag is an element whose name is atoken type, and whose
content is the keyword to highlight. For example, the following rule highlights the most common
Java keywords:
<KEYWORDS>

<KEYWORD1>i f </ KEYWORD1>

<KEYWORD1>el se</ KEYWORD1>

<KEYWORD3>i nt </ KEYWORD3>

<KEYWORD3>Vvoi d</ KEYWORD3>
</ KEYWORDS>

Token Types

Parser rules can highlight tokens using any of the following token types:

* NULL - no specia highlighting is performed on tokens of type NULL
+ COMMVENT1
+ COMMVENT2
+ COMMVENT3
+ COMMVENT4
*  FUNCTI ON
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I NVALI D
KEYWORD1
KEYWORD2
KEYWORD3
KEYWORD4
LABEL

LI TERAL1
LI TERAL2
LI TERAL3
LI TERAL4
MARKUP
OPERATOR
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jEdit looks for edit modesin two locations; the nodes subdirectory of the jEdit settings directory,
and the nodes subdirectory of the jEdit install directory. The location of the settings directory is
system-specific; see the section called “ The jEdit Settings Directory”.

Each mode directory containsacat al og file. All edit modes contained in that directory must be
listed in the catalog, otherwise they will not be available to jEdit.

Catalogs, like modes themselves, are written in XML. They consist of a single MODES tag, with a
number of MODE tags inside. Each mode tag associates a mode name with an XML file, and
specifies the file name and first line pattern for the mode. A sample mode catal og 1ooks as follows:

<?xm version="1.0"?>
<! DOCTYPE CATALOG SYSTEM "cat al og. dtd" >

<MODES>
<MODE NAME="shel | script" FILE="shellscript.xm"
FI LE_NAME_G.OB="*.sh"
FI RST_LI NE_G.OB="#!/*sh*" [>
</ MODES>

In the above example, a mode named “shellscript” is defined, and is used for files whose names end

with . sh, or whosefirst line starts with “#!/” and contains “sh”.

The MODE tag supports the following attributes:

» NAME - the name of the edit mode, asit will appear in the Buffer Options dialog box, the status
bar, and so on.

e Fl LE - the name of the XML file containing the mode definition.

* FI LE_NAME_GLOB - files whose names match this glob pattern will be opened in this edit
mode.

 FIRST_LI NE_GLOB - fileswhosefirst line matches this glob pattern will be opened in this
edit mode.

Glob pattern syntax is described in Appendix D, Glob Patterns.
Tip

If an edit mode in the user-specific catalog has the same name as an edit mode in the
system catalog, the version in the user-specific catalog will override the system default.
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Chapter 12. Updating Edit Modes for
JEdit 4.1/4.2

InjEdit 4.1, the mode file grammar has been cleaned up somewhat. As aresult, some edit modes
written for jEdit 4.0 and earlier need to be updated:

e Defining <WH TESPACE> rulesis no longer necessary and doing so will print warnings to the
activity logs.

» The <KEYWORDS> tag no longer accepts an | GNORE_CASE attribute. Set the | GNORE_CASE
attribute of the <RULES> tag instead.

» The <END> tag of the <SPAN> rule used to be optional, in which case any occurrence of the
start string would cause the remainder of the buffer to be highlighted with the span. In jEdit 4.1,
the <END> tag can no longer be omitted, however a <SEQ> tag with a DELEGATE attribute can
be used to achieve the same effect as endless span.

» Defining <SEQ TYPE="NULL" > rulesfor word separatorsis no longer necessary. Now, any
non-al phanumeric character not appearing in a keyword definition or the ruleset's
NO_WORD_SEP attribute is considered a word separator.
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Part IIl. Writing Macros

This part of the user's guide covers writing macros for jEdit.

First, we will tell you alittle about BeanShell, jEdit's macro scripting language. Next, we will walk
through a few simple macros. We then present and analyze a dial og-based macro to illustrate
additional macro writing techniques. Finally, we discuss several tips and techniques for writing and
debugging macros.

This part of the user's guide was written by John Gellene <j gel | ene@yc. rr. conp.




Chapter 13. Macro Basics

Introducing BeanShell

Here is how BeanShell's author, Pat Niemeyer, describes his creation:

“Beanshell isasmall, free, embeddable, Java source interpreter with object
scripting language features, written in Java. BeanShell executes standard Java
statements and expressions, in addition to obvious scripting commands and
syntax. BeanShell supports scripted objects as simple method closures like those
in Perl and JavaScript.”

Y ou do not have to know anything about Java to begin writing your own jEdit macros. But if you
know how to program in Java, you already know how to write BeanShell scripts. The major strength
of using BeanShell with a program written in Javaisthat it allows the user to customize the
program's behavior using the same interfaces designed and used by the program itself. BeanShell
can turn awell-designed application into a powerful, extensible toolkit.

This guide focuses on using BeanShell in macros. If you are interested in learning more about
BeanShell generally, consult the BeanShell web site. Information on how to run and organize
macros, whether included with the jEdit installation or written by you, can be found in Chapter 8,
Using Macros.

Single Execution Macros

As noted in the section called “How jEdit Organizes Macros’, you can save a BeanShell script of
any length as atext filewith the . bsh extension and run it from the M acr os menu. There are three
other ways jEdit lets you use BeanShell quickly, without saving a script to storage, on a“onetime
only” basis. You will find them in the Utilities menu.

Utilities>BeanShell>Evaluate BeanShell Expression displays atext input dialog that asks you to
type asingle line of BeanShell commands. Y ou can type more than one BeanShell statement so long
as each of them ends with a semicolon. If BeanShell successfully interprets your input, a message
box will appear with the return value of the last statement.

Utilities>BeanShell>Evaluate For Selected Lines displays atext input dialog that asks you to type
asingle line of BeanShell commands. The commands are evaluated for each line of the selection. In
addition to the standard set of variables described in the section called “ Predefined Variablesin
BeanShell”, this command defines the following:

* |i ne - theline number, from the start of the buffer. The first lineis numbered 0.

* i ndex -theline number, from the start of the selection. Thefirst lineis numbered 0.

* text -thetextof theline

Try typing an expression like(line + 1) + ": " + text intheEvaluate For Selected
Linesdialog box. Thiswill add aline number to each selected line beginning with the number 1.
The BeanShell expression you enter will be evaluated and substituted in place of the entire text of a
selected line. If you want to leave the lin€'s current text as an element of the modified line, you must

include the defined variable t ext as part of the BeanShell expression that you enter.

Utilities>BeanShell>Evaluate Selection evaluates the selected text as a BeanShell script and
replaces it with the return value of the statement.

Using Evaluate Selection is an easy way to do arithmetic calculations inline while editing.
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BeanShell uses numbers and arithmetic operations in an ordinary, intuitive way.

Try typing an expression like ( 3745* 856) +74 in the buffer, select it, and choose
Utilities>BeanShell>Evaluate Selection. The selected text will be replaced by the answer,
3205794.

Console plugin

Y ou can aso do the same thing using the BeanShell interpreter option of the Console plugin.

The Mandatory First Example

Macr os. nessage(view, "Hello world!");

Running this one line script causes jEdit to display a message box (more precisely, a
JOpt i onPane object) with the traditional beginner's message and an OK button. Let's see what is
happening here.

This statement calls a static method (or function) named message in jEdit's Macros class. If you
don't know anything about classes or static methods or Java (or C++, which employs the same
concept), you will need to gain some understanding of afew terms. Obviously thisis not the place
for academic precision, but if you are entirely new to object-oriented programming, here are afew
skeleton ideas to help you with BeanShell.

* Anobjectisacollection of datathat can beinitialized, accessed and manipulated in certain
defined ways.

» A classisaspecification of what data an object contains and what methods can be used to work
with the data. A Java application consists of one or more classes (in the case of jEdit ,over 600
classes) written by the programmer that defines the application's behavior. A BeanShell macro
uses these classes, along with built-in classes that are supplied with the Java platform, to define
its own behavior.

» A subclass (or child class) isaclass which uses (or “inherits’) the data and methods of its parent
class along with additions or modifications that alter the subclass's behavior. Classes are
typically organized in hierarchies of parent and child classes to organize program code, to define
common behavior in shared parent class code, and to specify the types of similar behavior that
child classes will perform in their own specific ways.

* A method (or function) is a procedure that works with datain a particular object, other data
(including other objects) supplied as parameters, or both. Methods typically are applied to a
particular object which is an instance of the class to which the method belongs.

» A dtatic method differs from other methods in that it does not deal with the datain a particular
object but isincluded within a class for the sake of convenience.

Java has arich set of classes defined as part of the Java platform. Like all Java applications, jEdit is
organized as a set of classes that are themselves derived from the Java platform's classes. We will
refer to Java classes and jEdit classes to make this distinction. Some of jEdit's classes (such as those
dealing with regular expressions and XML) are derived from or make use of classesin other
open-source Java packages. Except for BeanShell itself, we won't be discussing them in this guide.

In our one line script, the static method Macr os. nessage() hastwo parameters because that is
the way the method is defined in the Macros class. Y ou must specify both parameters when you call
the function. The first parameter, vi ew, is a variable naming the current, active View object.
Information about pre-defined variables can be found in the section called “Predefined Variablesin
BeanShell”.
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The second parameter, which appears to be quoted text, isastring literal - a sequence of characters
of fixed length and content. Behind the scenes, BeanShell and Javatake this string literal and use it
to createa St r i ng object. Normally, if you want to create an object in Java or BeanShell, you must
construct the object using the new keyword and a constructor method that is part of the object's
class. Well show an example of that later. However, both Java and BeanShell let you use a string
literal anytime a method's parameter callsfor aSt r i ng.

If you are a Java programmer, you might wonder about a few things missing from this one line
program. Thereis no class definition, for example. Y ou can think of a BeanShell script as an
implicit definition of armai n() method in an anonymous class. That isin fact how BeanShell is
implemented; the class is derived from a BeanShell class called XThis. If you don't find that helpful,
just think of a script as one or more blocks of procedural statements conforming to Java syntax

rules. You will also get along fine (for the most part) with C or C++ syntax if you leave out anything
to do with pointers or memory management - Java and BeanShell do not have pointers and deal with
memory management automatically.

Another missing item from a Java perspectiveisapackage statement. In Java, such a statement is
used to bundle together a number of files so that their classes become visible to one another.
Packages are not part of BeanShell, and you don't need to know anything about them to write
BeanShell macros.

Finally, therearenoi nport statementsinthisscript. In Java, ani nport statement makes public
classes from other packages visible within the file in which the statement occurs without having to
specify afully qualified class name. Without an import statement or afully qualified name, Java
cannot identify most classes using a single name as an identifier.

jEdit automatically imports a number of commonly-used packages into the namespace of every
BeanShell script. Because of this, the script output of arecorded macro does not containi npor t
statements. For the same reason, most BeanShell scripts you write will not requirei npor t
Statements.

Javarequiresi nport statement to be located at the beginning of a source file. BeanShell alows
you to placei nport statements anywhere in ascript, including inside a block of statements. The
i mport statement will cover al names used following the statement in the enclosing block.

If you try to use a class that is not imported without its fully-qualified name, the BeanShell
interpreter will complain with an error message relating to the offending line of code.

Hereisthe full list of packages automatically imported by jEdit:

j ava. awmt

j ava. awm . event

] ava. net

java. util

java.io

] ava. | ang

J avax. swi ng

j avax. swi ng. event
org.gjt.sp.jedit
org.gjt.sp.jedit.browser
org.gjt.sp.jedit. buffer
org.gjt.sp.jedit. gui
org.gjt.sp.jedit.help
.io

org.gjt.sp.jedit
org.gjt.sp.jedit.nsg
org.gjt.sp.jedit.options
org.gjt.sp.jedit.plugi nngr
org.gjt.sp.jedit.print
org.gjt.sp.jedit.search
org.gjt.sp.jedit.syntax
org.gjt.sp.jedit.textarea
org.gjt.sp.util
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Predefined Variables in BeanShell

The following variables are always available for use in BeanShell scripts:

» buffer - aBuffer object represents the contents of the currently visible open text file.

e vi ew- A View represents the current top-level editor window, extending Java's JFr ane class,
that contains the various visible components of the program, including the text area, menu bar,
toolbar, and any docked windows.

This variable has the same value as the return value of:
jEdit.getActiveView)

e edi t Pane - an EditPane object contains atext area and buffer switcher. A view can be split to
display edit panes. Among other things, the EditPane class contains methods for selecting the
buffer to edit.

Most of the time your macros will manipulate the buf f er or thet ext Ar ea. Sometimes you
will need to usevi ew as a parameter in amethod call. Y ou will probably only need to use
edi t Pane if your macros work with split views.

This variable has the same value as the return value of:

vi ew. get Edi t Pane()

* textArea-aJEditTextAreaisthe visible component that displays the current buffer.
This variable has the same value as the return value of:
edi t Pane. get Text Area()

» wm- a DockableWindowManager is the visible component that manages dockable windows in
the current view. This classis discussed in detail in Part 1V, “Writing Plugins’. This object is
useful for writing macros that interface with, open, or close plugin windows.

This variable has the same value the return value of

vi ew. get Dockabl eW ndowManager ()

e scriptPat h - set to the full path of the script currently being executed.
* scriptPat h - set to the full path of the script currently being executed.
Note that these variables are set at the beginning of macro execution. If the macro switches views,

buffers or edit panes, the variable values will be out of date. In that case, you can use the equivalent
method calls.

Helpful Methods in the Macros Class

Including message( ) , there arefive static methods in the Macros class that alow you to converse
easily with your macros. They all encapsulate calls to methods of the Java platform's
JOpt i onPane class.

e public static void nessage(Conponent conp, String nessage);

e public static void error(Conponent conp, String nessage);
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e public static String input(Conponent conp, String pronpt);

e public static String input(Conponent conp, String pronpt, String
def aul t Val ue) ;

e public static int confirn{Conponent conp, String pronpt, int
buttons);

The format of these four declarations provides a concise reference to the way in which the methods
may be used. The keyword publ i ¢ means that the method can be used outside the Macros class.
Thealternativesarepr i vat e and pr ot ect ed. For purposes of BeanShell, you just have to know
that BeanShell can only use public methods of other Java classes. The keyword st at i ¢ we have
already discussed. It means that the method does not operate on a particular object. You call astatic
function using the name of the class (like Macros) rather than the name of a particular object (like
vi ew). The third word is the type of the value returned by the method. The keyword voi d is Javas
way of saying the the method does not have areturn value.

Theer ror () method worksjust likemessage() but displays an error icon in the message box.
Thei nput () method furnishes atext field for input, an OK button and a Cancel button. If Cancel
is pressed, the method returns nul | . If OK ispressed, aSt ri ng containing the contents of the
text field isreturned. Note that there are two forms of thei nput () method; the first form with two
parameters displays an empty input field, the other forms lets you specify an initial, default input
value.

For those without Java experience, it isimportant to know that nul | is not the same as an empty,
“zero-length” St ri ng. ItisJava's way of saying that there is no object associated with this
variable. Whenever you seek to use areturn value fromi nput () inyour macro, you should test it
toseeif itisnul | . In most cases, you will want to exit gracefully from the script withar et urn
statement, because the presence of a null value for an input variable usually means that the user
intended to cancel macro execution. BeanShell will complain if you call any methodsonanul |
object.

Theconfirn() method in the Macros classis alittle more complex. The but t ons parameter
hasani nt type, and the usua way to supply avalueisto use one of the predefined values taken
from Java's JOpt i onPane class. You can choose among JOpt i onPane. YES_NO_OPTI ON,
JOpti onPane. YES _NO_CANCEL_OPTI ON, or JOpt i onPane. OK_CANCEL_OPTI ON. The
return value of the method isalso ani nt , and should be tested against the value of other predefined
constants: JOpt i onPane. YES_OPTI ON, JOpt i onPane. NO_OPTI ON,

JOpt i onPane. OK_OPTI ONor JOpt i onPane. CANCEL_CPTI ON.

We've looked at using Macr os. message( ) . To use the other methods, you would write
something like the following:

Macr os. error(vi ew, "Goodbye, cruel world!");
String result = Macros.input(view, "Type sonething here.");

String result = Macros.input(view, "Wen were you born?",
"I don't renmenber, | was very young at the time");

int result = Macros.confirn("Do you really want to |l earn"
+ " about BeanShel | ?", JOpti onPane. YES NO OPTI ON);

In the last three examples, placing theword St ri ng or i nt before the variable namer esul t

tells BeanShell that the variable refersto an integer or aSt r i ng object, even before a particular
value is assigned to the variable. In BeanShell, this declaration of the type of r esul t isnot
necessary; BeanShell can figure it out when the macro runs. This can be helpful if you are not
comfortable with specifying types and classes; just use your variables and let BeanShell worry about
it.

Note that macros are not limited to using these methods for presenting a user interface. In fact,
full-blown user interfaces using the Java Swing APIs are also possible, and will be covered later on
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in Chapter 14, A Dialog-Based Macro.

BeanShell Dynamic Typing

Without an explicit type declaration like St ri ng r esul t , BeanShell variables can change their
type at runtime depending on the object or data assigned to it. This dynamic typing allows you to
write code like this (if you really wanted to):

/1 note: no type declaration
result = Macros.input(view, “Type sonething here.”);

/1 this is our predefined, current View
result = view,

/1l this is an “int” (for integer);

/1 in Java and BeanShell, int is one of a small nunber
/1 of “primtive” data types which are not classes
result = 14;

However, if you first declared r esul t to betype St ri ng and and then tried these reassignments,
BeanShell would complain. While avoiding explicit type declaration makes writing macro code
simpler, using them can act as a check to make sure you are not using the wrong variabl e type of
object at alater point in your script. It also makesit easier (if you are so inclined) to take a
BeanShell “prototype” and incorporate it in a Java program.

One last thing before we bury our first macro. The double slashes in the examples just above signify
that everything following them on that line should be ignored by BeanShell as acomment. Asin
Java and C/C++, you can also embed comments in your BeanShell code by setting them off with
pairsof / * */, asinthefollowing example:

/* This is a long comment that covers several lines
and will be totally ignored by BeanShell regardless of how
many lines it covers */

Now For Something Useful

Here isamacro that inserts the path of the current buffer in the text:

String newlext = buffer.getPath();
t ext Ar ea. set Sel ect edText ( newText) ;

Unlikein our first macro example, here we are calling class methods on particular objects. First, we
call get Pat h() onthe current Buffer object to get the full path of the text file currently being
edited. Next, we call set Sel ect edText () onthe current text display component, specifying the
text to be inserted as a parameter.

In preciseterms, the set Sel ect edText () method substitutes the contents of the St ri ng
parameter for arange of selected text that includes the current caret position. If no text is selected at
the caret position, the effect of this operation is simply to insert the new text at that position.

Here'safew alternativesto the full file path that you could use to insert various useful things:

/1 the file name (w thout full path)
String newText = buffer.getNanme();

/1 today's date
i mport | ava.text. Dat eFor mat;

String newlext = DateFormat. get Dat el nst ance()
.format (new Date());
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// a line count for the current buffer

String newlext = "This file contains
+ text Area.getLineCount() + " lines.";

Here are brief comments on each:

* Inthefirst, the call toget Nane() invokes another method of the Buffer class.

» The syntax of the second example chains the results of several methods. Y ou could write it this
way:

i mport j ava.text. Dat eFor nmat;
Date d = new Date();

Dat eFor mat df
String result

Dat eFor mat . get Dat el nst ance() ;
df . format (d);

Taking the pieces in order:

A Java Dat e object is created using the new keyword. The empty parenthesis after Dat e
signify acall on the constructor method of Dat e having no parameters; here, aDat e is
created representing the current date and time.

Dat eFor mat . get Dat el nst ance() isastatic method that creates and returns a

Dat eFor mat object. Asthe nameimplies, Dat eFor nat isa Javaclassthat takes Dat e
objects and produces readable text. The method get Dat el nst ance() returnsa

Dat eFor mat object that parses and formats dates. It will use the default locale or text
format specified in the user's Javainstallation.

Finally, Dat eFor mat . f or mat () iscaled onthe new Dat eFor mat object using the
Dat e object as a parameter. Theresultisa St r i ng containing the date in the default
locale.

Note that the Dat e classis contained inthej ava. ut i | package, so an explicit import
statement is not required. However, Dat eFor mat ispart of thej ava. t ext package,
which is not automatically imported, so an expliciti nmport statement must be used.

* Thethird example shows three items of note:

get Li neCount () isamethod in jEdit's JEditTextAreaclass. It returnsani nt
representing the number of linesin the current text buffer. We call it ont ext Ar ea, the
pre-defined, current JEditTextArea object.

The use of the + operator (which can be chained, as here) appends objects and string literals
to return asingle, concatenated St r i ng.
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Chapter 14. A Dialog-Based Macro

Now we will look at a more complicated macro which will demonstrate some useful techniques and
BeanShell features.

Use of the Macro

Our new example adds prefix and suffix text to a series of selected lines. This macro can be used to
reduce typing for a series of text items that must be preceded and following by identical text. In
Java, for example, if we are interested in making a series of callsto St ri ngBuf f er . append()
to construct alengthy, formatted string, we could type the parameter for each call on successive
linesasfollows:

profileString_1

secret Thing.toString()
name

addr ess

addr essSupp

city

“stat e/ provi nce”
country

Our macro would ask for input for the common “ prefix” and “suffix” to be applied to each ling; in
this case, the prefix isour St ri ngBuf f er . append( and the suffix is) ; . After selecting these
lines and running the macro, the resulting text would look like this:

our Stri ngBuf fer. append(profileString_1);

our St ri ngBuf f er. append(secret Thing.toString());
our St ri ngBuf f er. append( nane) ;

our Stri ngBuf f er. append( addr ess) ;

our St ri ngBuf f er. append( addr essSupp) ;

our Stri ngBuffer.append(city);

our Stri ngBuf f er. append(“st at e/ provi nce”);

our Stri ngBuf fer.append(country);

Listing of the Macro

The macro script follows. You can find it in the jEdit distribution in the Text subdirectory of the
macr os directory. You can also try it out by invoking M acros>Text>Add Prefix and Suffix.

/1 beginning of Add_Prefix_and_Suffix. bsh

/1 inmport statement (see the section called “Inport Statenents”)
i mport javax.sw ng. border. *;

// main routine
voi d prefixSuffixDial og()
{
/1 create dialog object (see the section called “Create the Dial 0g”)
title = “Add prefix and suffix to selected |ines”;
di al og = new JDi al og(view, title, false);
content = new JPanel (new Border Layout());
cont ent. set Border (new EnptyBorder (12, 12, 12, 12));
content.set PreferredSi ze(new Di mensi on(320, 160));
di al og. set Cont ent Pane(content);

/1 add the text fields (see the section called “
Create the Text Fields”)

fiel dPanel = new JPanel (new GridLayout(4, 1, 0, 6));

prefixField new Hi storyTextFi el d(“macro. add- prefix”);

prefi xLabel new JLabel (“Prefix to add:”);
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suffixField = new Hi storyTextFi el d(“macro. add-suffix”);
suf fi xLabel = new JLabel (“Suffix to add:”);

fi el dPanel . add( prefi xLabel);

fi el dPanel . add( prefi xFi el d);

fi el dPanel . add(suffi xLabel);

fiel dPanel . add(suffi xFi el d);

content.add(fi el dPanel, “Center”);

/1 add a panel containing the buttons (see the section called “
Create the Buttons”)

butt onPanel = new JPanel ();

but t onPanel . set Layout (new BoxLayout ( butt onPanel
BoxLayout . X AXI S));

but t onPanel . set Bor der (new Enpt yBorder (12, 50, 0, 50));

but t onPanel . add( Box. creat ed ue());

ok = new JButton(“OK");

cancel = new JButton("Cancel”);

ok. set Pref erredSi ze(cancel . get PreferredSi ze());

di al og. get Root Pane() . set Def aul t But t on( ok) ;

but t onPanel . add( ok) ;

but t onPanel . add( Box. cr eat eHori zontal Strut(6));

but t onPanel . add(cancel ) ;

but t onPanel . add( Box. creat ed ue());

content. add( buttonPanel, “South”);

/1 register this method as an ActionLi stener for

/1 the buttons and text fields (see the section called “Register the Action
ok. addAct i onLi st ener (this);
cancel . addActi onLi st ener (thi s);
prefi xFi el d. addActi onLi stener(this);

suf fi xFi el d. addActi onLi stener(this);

/1l locate the dialog in the center of the

/1 editing pane and make it visible (see the section called “Make the Dialo
di al og. pack();

di al og. set Locati onRel ativeTo(vi ew);

di al og. set Def aul t G oseOper ati on(JDi al og. DI SPOSE_ON_CLOSE)

di al og. set Vi si bl e(true);

/1 this nmethod will be called when a button is clicked
/1 or when ENTER is pressed (see the section called “The Action Listener”)
voi d actionPerformed(e)

i f(e.getSource() != cancel)

processText ();

}

di al og. di spose();
this is where the work gets done to insert

/
[/ the prefix and suffix (see the section called “Get the User's Input”)
oi d processText ()

~l T~

prefix = prefixField.getText();

suffix = suffixField. getText();

if(prefix.length() == 0 & suffix.length() == 0)
return;

prefi xFi el d. addCurrent ToH story();

suf fi xFi el d. addCur rent ToHi story();

/1 text manipul ati on begins here using calls

/1l to jEdit methods (see the section called “Call jEdit Methods to Man
buf f er. begi nConmpoundEdi t () ;

sel ect edLi nes = textArea. get Sel ect edLi nes();

for(i = 0; i < selectedLines.length; ++i)

of fsetBOL = text Area.getlLineStart O fset(
sel ectedLines[i]);
t ext Area. set Car et Posi ti on(of fset BOL);
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t ext Area. goToSt art Of Wi t eSpace(fal se);

t ext Ar ea. goTOEndOF Whi t eSpace(true);

text = textArea. get Sel ectedText ();

if(text == null) text ="";

t ext Area. set Sel ect edText (prefix + text + suffix);

}
buf f er. endConpoundEdi t () ;
}

this single line of code is the script's main routine
(see the section called “The Main Routine”)
f

}
/1
/1
prefixSuffixDi al og();

/1 end of Add_Prefix _and Suffix.bsh

Analysis of the Macro

Import Statements

/1 inmport statenent
i mport javax.sw ng. border. *;

This macro makes use of classesinthej avax. swi ng. bor der package, whichis not
automatically imported. As we mentioned previously (see the section called “The Mandatory First
Example”), jEdit's implementation of BeanShell causes a number of classes to be automatically
imported. Classes that are not automatically imported must be identified by a full qualified name or
be the subject of ani nport statement.

Create the Dialog

/1 create dial og object

title = “Add prefix and suffix to selected Iines”;
di al og = new JDi al og(view, title, false);

content = new JPanel (new BorderLayout());

content . set Border (new EnptyBorder (12, 12, 12, 12));
di al og. set Cont ent Pane(content);

To get input for the macro, we need a dialog that provides for input of the prefix and suffix strings,
an OK button to perform text insertion, and a Cancel button in case we change our mind. We have
decided to make the dialog window non-modal. Thiswill allow us to move around in the text buffer
to find things we may need (including text to cut and paste) while the macro is running and the
didogisvisble.

The Javaobject weneedisaJDi al og object from the Swing package. To construct one, we use
the new keyword and call a constructor function. The constructor we use takes three parameters: the
owner of the new dialog, the title to be displayed in the dialog frame, and abool ean parameter
(true orf al se) that specifies whether the dialog will be modal or non-modal. We define the
variablet i t | e using astring literal, then use it immediately in the JDi al og constructor.

A JDi al og object isawindow containing a single object called a content pane. The content pane
in turn contains the various visible components of the dialog. A JDi al og creates an empty content
pane for itself as during its construction. However, to control the dialog's appearance as much as
possible, we will separately create our own content pane and attach it to the JDi al og. We do this
by creating aJPanel object. A JPanel isalightweight container for other components that can
be set to a given size and color. It also contains alayout scheme for arranging the size and position
of its components. Here we are constructing aJPanel as acontent pane with aBor der Layout .
We put a Enpt yBor der insideit to serve as a margin between the edge of the window and the
components inside. We then attach the JPanel asthe dialog's content pane, replacing the dialog's
home-grown version.
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A Bor der Layout isone of the simpler layout schemes available for container objects like
JPanel . A Bor der Layout dividesthe container into five sections: “North”, “ South”, “East”,
“West” and “Center”. Components are added to the layout using the container's add method,
specifying the component to be added and the section to which it is assigned. Building a component
like our dialog window involves building a set of nested containers and specifying the location of
each of their member components. We have taken the first step by creating aJPanel asthe
dialog's content pane.

Create the Text Fields

// add the text fields

fi el dPanel = new JPanel (new GridLayout(4, 1, 0, 6));
prefixField = new Hi storyTextFi el d("nacro. add-prefix");
prefixLabel = new JLabel (“Prefix to add”:);

suffixField = new Hi storyTextFi el d(“macro. add-suffix”);
suf fi xLabel = new JLabel (“Suffix to add:”);

fi el dPanel . add( prefi xLabel);

fi el dPanel . add( prefi xFi el d);

fi el dPanel . add(suffi xLabel);

fiel dPanel . add(suffi xField);

content.add(fi el dPanel, “Center”);

Next we shall create a smaller panel containing two fields for entering the prefix and suffix text and
two labels identifying the input fields.

For the text fields, we will use jEdit's HistoryTextField class. It is derived from the Java Swing class
JText Fi el d. This class offers the enhancement of a stored list of prior values used as text input.
When the component has input focus, the up and down keys scroll through the prior values for the
variable.

To create the History TextField objects we use a constructor method that takes a single parameter:
the name of the tag under which history values will be stored. Here we choose names that are not
likely to conflict with existing jEdit history items.

The labels that accompany the text fields are JLabel objects from the Java Swing package. The
constructor we use for both labels takes the label text asasingle St r i ng parameter.

We wish to arrange these four components from top to bottom, one after the other. To achieve that,
we use aJPanel container object named f i el dPanel that will be nested inside the dialog's
content pane that we have already created. In the constructor for f i el dPanel , we assign anew
Gri dLayout with the indicated parameters: four rows, one column, zero spacing between
columns (a meaningless element of a grid with only one column, but nevertheless a required
parameter) and spacing of six pixels between rows. The spacing between rows spreads out the four
“grid” elements. After the components, the panel and the layout are specified, the components are
addedtofi el dPanel top to bottom, one “grid cell” at atime. Finaly, the complete

fi el dPanel isadded to the dialog's content pane to occupy the “Center” section of the content
pane.

Create the Buttons

/1 add the buttons

but t onPanel = new JPanel ();

but t onPanel . set Layout (new BoxLayout ( butt onPanel ,
BoxLayout. X AXI S));

but t onPanel . set Bor der (new Enpt yBorder (12, 50, 0, 50));

but t onPanel . add( Box. creat ed ue());

ok = new JButton(“OK");

cancel = new JButton("Cancel”);

ok. set Pref erredSi ze(cancel . get PreferredSi ze());

di al og. get Root Pane() . set Def aul t But t on( ok) ;

but t onPanel . add( ok) ;

but t onPanel . add( Box. cr eat eHori zontal Strut (6));

but t onPanel . add( cancel ) ;
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but t onPanel . add( Box. cr eat ed ue(
content. add( buttonPanel, “South

)

)
)

To create the dialog's buttons, we follow repeat the “ nested container” pattern we used in creating
the text fields. First, we create a new, nested panel. Thistime we use aBoxLayout that places
components either in a single row or column, depending on the parameter passed to its constructor.
Thislayout object ismore flexiblethan aGr i dLayout in that variable spacing between elements
can be specified easily. We put an Enpt yBor der inthe new panel to set margins for placing the
buttons. Then we create the buttons, using a JBut t on constructor that specifies the button text.
After setting the size of the OK button to equal the size of the Cancel button, we designate the OK
button as the default button in the dialog. This causes the OK button to be outlined when the dialog
if first displayed. Finally, we place the buttons side by side with a 6 pixel gap between them (for
aesthetic reasons), and place the completed but t onPanel inthe“South” section of the dialog's
content pane.

Register the Action Listeners

/1 register this nethod as an ActionListener for
/1 the buttons and text fields
ok. addActi onLi st ener (this);
cancel . addActi onLi stener(this);
prefi xFi el d. addActi onLi st ener (this);

suf fi xFi el d. addAct i onLi st ener(this);

In order to specify the action to be taken upon clicking a button or pressing the Ent er key, we
must register an Act i onLi st ener for each of the four active components of the dialog - the two
HistoryTextField components and the two buttons. In Java, an Act i onLi st ener isaninterface -
an abstract specification for a derived classto implement. The Act i onLi st ener interface
contains a single method to be implemented:

public void actionPerfornmed(ActionEvent e);

BeanShell does not permit a script to create derived classes. However, BeanShell offers a useful
substitute: amethod can be used as a scripted object that can include nested methods implementing
anumber of Javainterfaces. The method pr ef i xSuf f i xDi al og() that we arewriting can thus
betreated asan Act i onLi st ener object. To accomplish this, we call

addAct i onLi st ener () on each of the four components specifying t hi s asthe

Act i onLi st ener . We still need to implement the interface. We will do that shortly.

Make the Dialog Visible

/1 locate the dialog in the center of the

/1 editing pane and nmake it visible

di al og. pack();

di al og. set Locati onRel ati veTo(vi ew);

di al og. set Def aul t O oseQper ati on(JDi al og. DI SPOSE_ON_CLOSE)
di al og. set Vi si bl e(true);

Here we do three things. First, we activate all the layout routines we have established by calling the
pack() method for the dialog as the top-level window. Next we center the dialog's position in the
activejEdit vi ewby calling set Locat i onRel ati veTo() onthediadog. We also call the
set Def aul t O oseQper ati on() function to specify that the dialog box should be
immediately disposed if the user clicks the close box. Finally, we activate the dialog by calling

set Vi si bl e() with the state parameter settot r ue.

At this point we have a decent looking dialog window that doesn't do anything. Without more code,

it will not respond to user input and will not accomplish any text manipulation. The remainder of the
script deal s with these two reguirements.

The Action Listener
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/1 this nethod will be called when a button is clicked
/1 or when ENTER i s pressed
voi d actionPerforned(e)

i f(e.getSource() != cancel)
processText ();

}
di al og. di spose();

Themethod act i onPer f or ned() nestedinside pr ef i xSuf fi xDi al og() implementsthe
implicit Act i onLi st ener interface. It looks at the source of the Act i onEvent , determined by
acall toget Sour ce() . What we do with this return value is straightforward: if the sourceis not
the Cancel button, we call the pr ocessText () method to insert the prefix and suffix text. Then
thedialog is closed by calling itsdi spose() method.

The ability to implement interfaces like Act i onLi st ener inside aBeanShell script is one of the
more powerful features of the BeanShell package. this techniqueis discussed in the next chapter; see
the section called “Implementing Classes and Interfaces’.

Get the User's Input

/1 this is where the work gets done to insert
/1 the prefix and suffix
}/oid processText ()

prefix = prefixField.getText();

suffix = suffixField. getText();

if(prefix.length() == 0 & suffix.length() == 0)

return;
prefi xFi el d. addCurrent ToH story();
suf fi xFi el d. addCurrent ToH story();

The method pr ocessText () doesthe work of our macro. First we obtain the input from the two
text fields with acall to their get Text () methods. If they are both empty, there is nothing to do,
so the method returns. If there isinput, any text in the field is added to that field's stored history list
by calling addCur r ent ToHi st or y() . Wedo not need to test the pr ef i xFi el d or

suf fi xFi el d controlsfor nul | or empty values because addCur r ent ToHi st or y() does
that internally.

Call jEdit Methods to Manipulate Text

/1 text manipul ati on begins here using calls
/1 to jEdit methods
buf f er. begi nConpoundEdi t () ;
sel ect edLi nes = textArea. get Sel ect edLi nes();
Eor(i = 0; i < selectedLines.length; ++i)
of fsetBOL = text Area.getLineStart O fset(
sel ect edLi nes[i]);
t ext Area. set Car et Posi ti on(of fset BOL);
t ext Area. goToSt art Of Whi t eSpace(fal se);
t ext Area. goToEndCOF Whi t eSpace(true);
text = textArea.getSel ectedText ();
if(text == null) text ="";
t ext Area. set Sel ect edText (prefix + text + suffix);

}
buf f er. endConpoundEdi t () ;

The text manipulation routine loops through each selected line in the text buffer. We get the loop
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parameters by callingt ext Ar ea. get Sel ect edLi nes() , which returns an array consisting of
the line numbers of every selected line. The array includes the number of the current line, whether
or not it is selected, and the line numbers are sorted in increasing order. We iterate through each
member of the sel ect edLi nes array, which represents the number of a selected line, and apply
the following routine:

» Get the buffer position of the start of the line (expressed as a zero-based index from the start of
the buffer) by callingt ext Ar ea. get Li neStart Of f set (sel ect edLi nes[i]);

* Movethe caret to that position by calling t ext Ar ea. set Car et Position();

* Find thefirst and last non-whitespace characters on the line by calling
t ext Area. goToSt art OF Whi t eSpace() and
t ext Area. goToEndCOf Whi t eSpace() ;

ThegoTo. . . methodsin JEditTextAreatake asingle parameter which tellsjEdit whether the
text between the current caret position and the desired position should be selected. Here, we call
t ext Area. goToSt art Of Wi t eSpace(f al se) sothat no text is selected, then call

t ext Area. goToEndOf Whi t eSpace(true) sothat al of the text between the beginning
and ending whitespace is selected.

* Retrieve the selected text by storing the return value of t ext Ar ea. get Sel ect edText ()
inanew variablet ext .

If thelineisempty, get Sel ect edText () will return nul | . In that case, we assign an empty
string tot ext to avoid calling methods on a null object.

e Changetheselectedtexttoprefi x + text + suffix bycaling
t ext Area. set Sel ect edText () . If thereis no selected text (for example, if thelineis
empty), the prefix and suffix will be inserted without any intervening characters.

Compound edits

Note thebegi nConpoundEdi t () and endConpoundEdi t () calls. These ensure that al edits
performed between the two calls can be undone in one step. Normally, jEdit automatically wraps a
macro call in these methods; however if the macro shows a non-modal dialog box, as far asjEdit is
concerned the macro has finished executing by the time the dialog is shown, since control returns to
the event dispatch thread.

If you do not understand this, don't worry; just keep it in mind if your macro needs to show a
non-modal dialog box for some reason; Most macros won't.

The Main Routine

/1 this single line of code is the script's main routine
prefixSuffixDial og();

Thecal toprefi xSuf fi xDi al og() isthe only linein the macro that is not inside an enclosing
block. BeanShell treats such code as atop-level mai n method and begins execution with it.

Our analysisof Add_Pr ef i x_and_Suf f i x. bsh isnow complete. In the next section, we look
at other ways in which amacro can obtain user input, as well as other macro writing techniques.
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Getting Input for a Macro

The dial og-based macro discussed in Chapter 14, A Dialog-Based Macro reflects a conventional
approach to obtaining input in a Java program. Nevertheless, it can be too lengthy or tedious for
someone trying to write a macro quickly. Not every macro needs a user interface specified in such
detail; some macros require only a single keystroke or no input at all. In this section we outline
some other techniques for obtaining input that will help you write macros quickly.

Getting a Single Line of Text

As mentioned earlier in the section called “Helpful Methods in the Macros Class’, the method
Macr os. i nput () offersaconvenient way to obtain asingle line of text input. Hereisan
example that inserts a pair of HTML markup tags specified by the user.

/1 1Insert_Tag. bsh

voi d insertTag()

{

caret = textArea.getCaretPosition();
tag = Macros.input(view, “Enter name of tag:”);
if( tag == null || tag.length() == 0) return;
text = textArea.getSel ectedText();
if(text == null) text = “";
sb = new StringBuffer();
sb. append(“<”). append(tag). append(“>");
sb. append(text);
sb. append(“</"). append(tag).append(“>");
t ext Area. set Sel ect edText (sb.toString());
if(text.length() == 0)
} t ext Area. set Caret Posi tion(caret + tag.length() + 2);

i nsert Tag();
/1 end Insert_Tag. bsh

Herethecall to Macr os. i nput () seeksthe name of the markup tag. This method setsthe
message box title to afixed string, “Macro input”, but the specific message Enter name of tag
provides all the information necessary. Thereturn valuet ag must be tested to see if it isnull. This
would occur if the user presses the Cancel button or closes the dialog window displayed by

Macr os. i nput ().

Getting Multiple Data Items

If more than one item of input is needed, a succession of callsto Macr os. i nput () isapossible,
but awkward approach, because it would not be possible to correct early input after the
corresponding message box is dismissed. Where moreis required, but afull dialog layout is either
unnecessary or too much work, the Java method JOpt i onPane. showConf i rnDi al og() is
available. The version to use has the following prototype:

e public static int showConfirnDi al og( Conponent parent Conponent,
bj ect nmessage, String title, int optionType, int messageType);

The usefulness of this method arises from the fact that the message parameter can be an object of
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any Javaclass (since all classes are derived from Qbj ect ), or any array of objects. The following
exampl e shows how this feature can be used.

/1 excerpt fromWite_Fil e_Header. bsh
title = “Wite file header”;

current Nane = buffer. get Nanme();

nanmeFi el d = new JText Fi el d(current Nane) ;

aut horField = new JText Fi el d(“Your name here”);

descField = new JTextField("", 25);

nanePanel = new JPanel (new GidLayout (1, 2));

naneLabel = new JLabel (“Nanme of file:”, Sw ngConstants.LEFT);
saveFi el d = new JCheckBox(“Save file when done”,

Ibuffer.isNewFile());
nanePanel . add( naneLabel ) ;
nanePanel . add(saveFi el d);

nessage = new bject[9];

nessage[ 0] = nanePanel ;

nmessage[ 1] = naneFi el d;

nmessage[ 2] = Box.createVertical Strut(10);
nmessage[ 3] = “Author's name:”;

nessage[ 4] = aut horFi el d;

nessage[ 5] = Box.createVertical Strut(10);
nessage[ 6] = “Enter description:”;
nessage[ 7] = descFi el d;

nmessage[ 8] = Box.createVertical Strut(5);

i f( JOptionPane. OK OPTION ! =
JOpt i onPane. showConf i rnDi al og(vi ew, nessage, title,
JOpt i onPane. OK_CANCEL_OPTI ON,
JOpt i onPane. QUESTI ON_MESSAGE) )
return null;

{1 *****remai nder of macro script omitted*****

/1 end excerpt fromWite_Fil e_Header. bsh

This macro takes several items of user input and produces aformatted file header at the beginning of
the buffer. The full macro isincluded in the set of macros installed by jEdit. There are a number of
input features of this excerpt worth noting.

e The macro uses atotal of seven visible components. Two of them are created behind the scenes
by showConf i r nDi al og() , therest are made by the macro. To arrange them, the script
creates an array of Qbj ect objects and assigns components to each location in the array. This
translates to a fixed, top-to-bottom arrangement in the message box created by
showConf i rnDi al og() .

e ThemacrousesJText Fi el d objectsto obtain most of theinput data. The fields naneFi el d
and aut hor Fi el d are created with constructors that take the initial, default text to be
displayed in the field as a parameter. When the message box is displayed, the default text will
appear and can be altered or deleted by the user.

e Thetext fielddescFi el d usesan empty string for itsinitial value. The second parameter in its
constructor sets the width of the text field component, expressed as the number of characters of
“average” width. When showConf i r mDi al og() preparesthe layout of the message box, it
sets the width wide enough to accommodate the designated with of descFi el d. This
technique produces a message box and input text fields that are wide enough for your data with
one line of code.

» The displayed message box includes a JCheckBox component that determines whether the
buffer will be saved to disk immediately after the file header iswritten. To conserve spacein the
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message box, we want to display the check box to the right of the label Name of file:. To do
that, we create aJPanel object and populate it with the label and the checkbox in aleft-to-right
Gri dLayout . TheJPanel containing the two components is then added to the beginning of
nessage array.

e Thetwo visible components created by showConf i r nDi al og() appear at positions 3 and 6
of the message array. Only the text isrequired; they are rendered as text |abels.

» There are three invisible components created by showConf i r nDi al og() . Each of them
involvesacall to Box. creat eVerti cal Strut (). TheBox classisasophisticated layout
classthat gives the user great flexibility in sizing and positioning components. Here we use a
st at i ¢ method of the Box class that produces avertical strut. Thisis atransparent component
whose width expands to fill its parent component (in this case, the message box). The single
parameter indicates the height of the strut in pixels. The last call to
createVertical Strut () separatesthe description text field from the OK and Cancel
buttons that are automatically added by showConf i r nDi al og() .

» Finaly, the call to showConf i r nDi al og() usesdefined constants for the option type and
the message type. The constants are the same as those used with the Macr os. conf i rn()
method; see the section called “Helpful Methodsin the Macros Class’. The option type signifies
the use of OK and Cancel buttons. The QUERY_MESSAGE message type causes the message
box to display a question mark icon.

The return value of the method is tested against the value OK_OPTI ON. If the return valueis
something el se (because the Cancel button was pressed or because the message box window
was closed without a button press), anul | valueisreturned to a calling function, signaling that
the user canceled macro execution. If the return valueis OK_OPTI QN, each of the input
components can yield their contents for further processing by callsto

JText Fi el d. get Text () (or, inthe case of the check box,

JCheckBox. i sSel ect ed()).

Selecting Input From a List

Another useful way to get user input for amacro is to use a combo box containing a number of
pre-set options. If thisisthe only input required, one of the versions of showl nput Di al og() in
the JOpt i onPane class provides a shortcut. Here isits prototype:

e public static Object show nput Di al og( Conponent par ent Conponent,
bj ect nmessage, String title, int nessageType, lcon icon,
Ohj ect[] sel ectionValues, (bject initial SelectionVal ue);

This method creates a message box containing a drop-down list of the options specified in the
method's parameters, along with OK and Cancel buttons. Compared to

showConfi r mDi al og() , thismethod lacks an opt i onType parameter and has three
additional parameters: ani con to display in the dialog (which can be set to nul | ), an array of
sel ecti onVal ues objects, and areference to one of the options as the

i nitial Sel ectionVal ue tobedisplayed. Inaddition, instead of returning ani nt
representing the user's action, showl nput Di al og() returnsthe Obj ect corresponding to the
user's selection, or nul | if the selection is canceled.

The following macro fragment illustrates the use of this method.

/1 fragment illustrating use of show nputDi al og()
options = new Cbject[5];

options[0] = "JLabel ";

options[1] = "JTextField";

options[2] = "JCheckBox";

options[3] = "HistoryTextField";

options[4} = "-- other --";
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result = JOptionPane. show nput Di al og(vi ew,
"Choose conponent cl ass”,
"Sel ect class for input conponent",
JOpt i onPane. QUESTI ON_MESSAGE,
nul |, options, options[0]);

Thereturnvaluer esul t will contain either the St r i ng object representing the selected text item
or nul | representing no selection. Any further use of this fragment would have to test the value of
resul t and likely exit from the macro if the value equaled nul | .

A set of options can be similarly placed in aJConboBox component created as part of alarger
dialog or showvessageDi al og() layout. Here are some code fragments showing this approach:

/1 fragments from Di spl ay_Abbrevi ations. bsh
/1 inmport statenments and other code onmitted

/1l frommain routine, this nmethod call returns an array
/1 of Strings representing the nanmes of abbreviation sets

abbrevSets = getActiveSets();

/1 from showAbbrevs() nethod

conbo = new JConboBox(abbrevSets);

/1 set width to uniformsize regardl ess of conbobox contents
Di nensi on di m = conbo. get PreferredSi ze();

dimw dth = Mat h. max(di mwi dt h, 120);

conbo. set PreferredSi ze(di m;

conbo. set Sel ect edl t en( STARTI NG 5 SET); // defined as "gl obal "

/1 end fragments

Using a Single Keypress as Input

Some macros may choose to emulate the style of character-based text editors such as emacs or vi.
They will require only asingle keypress as input that would be handled by the macro but not
displayed on the screen. If the keypress corresponds to a character value, jEdit can pass that value as
a parameter to a BeanShell script.

ThejEdit class InputHandler is an abstract class that that manages associations between keyboard
input and editing actions, along with the recording of macros. Keyboard input in jEdit is normally
managed by the derived class DefaultlnputHandler. One of the methods in the InputHandler class
handles input from a single keypress:

e public void readNext Char(String pronpt, String code);

When this method is called, the contents of the pr onpt parameter is shown in the view's status bar.
The method then waits for a key press, after which the contents of the code parameter will be run
as a BeanShell script, with one important modification. Each timethestring ___char __ appearsin
the parameter script, it will be substituted by the character pressed. The key pressis“consumed” by
r eadNext Char () . It will not be displayed on the screen or otherwise processed by jEdit.

Using r eadNext Char () requiresamacro within the macro, formatted as a single, potentially
lengthy string literal. The following macro illustrates this technique. It selects aline of text from the
current caret position to the first occurrence of the character next typed by the user. If the character
does not appear on the line, no new selection occurs and the display remains unchanged.

/1 Next Char. bsh
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script = new StringBuffer(512);

script.append( "start = textArea.getCaretPosition();" )
script.append( "line = textArea.getCaretLine();" )
script.append( "end = textArea.getLineEndOfset(line) + 1;" )
script.append( "text = buffer.getText(start, end - start);" )
script.append( "match = text.indexOr(__char__, 1);" )
script.append( "if(match !'= -1) {" )
scri pt. append( "if(__char__ I'="\\n") ++match;" )
scri pt. append( "text Area. sel ect(start, start + match - 1);" g;

script.append( "}

vi ew. get | nput Handl er (). readNext Char ("Enter a character",
script.toString());

/1 end Next Char. bsh
Once again, here are afew comments on the macro's design.

« A StringBuffer objectisusedfor efficiency; it obviates multiple creation of fixed-length
St ri ng objects. The parameter to the constructor of scri pt specifiesthe initial size of the
buffer that will receive the contents of the child script.

» Besidesthe quoting of the script code, the formatting of the macro is entirely optional but
(hopefully) makes it easier to read.

» Itisimportant that the child script be self-contained. It does not run in the same namespace as
the “parent” macro Next _Char . bsh and therefore does not share variables, methods, or
scripted objects defined in the parent macro.

» Finaly, access to the InputHandler object used by jEdit is available by caling
get | nput Handl er () onthe current view.

Startup Scripts

On startup, jEdit runs any BeanShell scripts located in the st ar t up subdirectory of the jEdit
installation and user settings directories (see the section called “The jEdit Settings Directory”). As
with macros, the scripts must have a. bsh file name extension. Startup scripts are run near the end
of the startup sequence, after plugins, properties and such have been initialized, but before the first
view is opened.

Startup scripts can perform initialization tasks that cannot be handled by command line options or
ordinary configuration options, such as customizing jEdit's user interface by changing entriesin the
Javaplatform's Ul Manager class.

Startup scripts have an additional feature lacking in ordinary macros that can help you further
customize jEdit. Variables and methods defined in a startup script are availablein al instances of
the BeanShell interpreter created in jEdit. This allows you to create a personal library of methods
and objects that can be accessed at any time during the editing session in another macro, the
BeanShell shell of the Console plugin, or menu items such as Utilities>BeanShell>Evaluate
BeanShell Expression.

The startup script routine will run script filesin the installation directory first, followed by scriptsin
the user settings directory. In each case, scripts will be executed in alphabetical order, applied
without regard to whether the file name contains upper or lower case characters.

If astartup script throws an exception (because, for example, it attempts to call amethod on anul |
object). jEdit will show an error dialog box and move on to the next startup script. If script bugs are
causing jEdit to crash or hang on startup, you can usethe - nost ar t upscri pt s command line
option to disable them for that editing session.

Another important difference between startup scripts and ordinary macros is that startup scripts
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cannot use the pre-defined variablesvi ew, t ext Ar ea, edi t Pane and buf f er . Thisis because
they are executed before the initial view is created.

If you are writing a method in a startup script and wish to use one of the above variables, pass
parameters of the appropriate type to the method, so that a macro calling them after startup can
supply the appropriate values. For example, a startup script could include a method

voi d doSomet hi ngWthViewView v, String s) {

}

so that during the editing session another macro can call the method using

doSomet hi ngW t hVi ew(vi ew, "sonet hi ng");

Reloading startup scripts without restarting

It is actually possible to reload startup scripts or load other scripts without restarting jEdit, using a
BeanShell statement like the following:

BeanShel | . runScri pt (vi ew, pat h, nul | , fal se);

For pat h, you can substitute any string, or a method call such asbuf f er . get Pat h() .

Running Scripts from the Command Line

The - r un command line switch specifies a BeanShell script to run on startup:

$ jedit -run=test.bsh

Note that just like with startup scripts, thevi ew, t ext Ar ea, edi t Pane and buf f er variables
are not defined.

If another instance is already running, the script will be run in that instance, and you will be ableto
usethej Edi t . get Last Vi ew() method to obtain aview. However, if anew instance of jEdit is
being started, the script will be run at the same time as all other startup scripts; that is, before the
first view is opened.

If your script needs a view instance to operate on, you can use the following code pattern to obtain
one, no matter how or when the script is being run:

voi d doSonmet hi ngUsef ul ()
{ voi d run()
view = jEdit. getLastView);
/1 put actual script body here
if(jEdit.getLastViewm) == null)
VFSManager . r unl nAWIThr ead(t hi s);

el se
run();

}
doSonet hi ngUsef ul () ;
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If the script isbeing run in aloaded instance, it can be invoked to perform its work immediately.
However, if the script is running at startup, before an initial view exists, its operation must be
delayed to allow the view object first to be created and displayed. In order to queue the macro's
operation, the scripted “ closure” named doSonet hi ngUsef ul () implementsthe Runnabl e
interface of the Java platform. That interface contains only asingler un() method that takes no
parameters and has no return value. The macro's implementation of ther un() method contains the
“working” portion of the macro. Then the scripted object, represented by areferencetot hi s, is
passed to ther unl nAWI Thr ead() method. This schedules the macro's operations for execution
after the startup routine is complete.

Asthisexampleillustrates, ther unl NAWI Thr ead() method can be used to ensure that a macro
will perform operations after other operations have completed. If it isinvoked during startup, it
schedules the specified Runnabl e object to run after startup is complete. If invoked when jEdit is
fully loaded, the Runnabl e object will execute after all pending input/output is complete, or
immediately if there are no pending I/O operations. Thiswill delay operations on a new buffer, for
example, until after the buffer isloaded and displayed.

Advanced BeanShell Techniques

BeanShell has afew advanced features that we haven't mentioned yet. They will be discussed in this
section.

BeanShell's Convenience Syntax

We noted earlier that BeanShell syntax does not require that variables be declared or defined with
their type, and that variables that are not typed when first used can have values of differing types
assigned to them. In addition to this “loose” syntax, BeanShell allows a“convenience” syntax for
dealing with the properties of JavaBeans. They may be accessed or set asif they were data
members. They may also be accessed using the name of the property enclosed in quotation marks
and curly brackets. For example, the following statement are all equivalent, assuming bt nisa
JBut t on instance:

b. set Text (" Choose");
b.text = "Choose";
b{"text"} = "Choose";

Thelast form can also be used to access a key-value pair of aHasht abl e object.

Special BeanShell Keywords

BeanShell uses special keywords to refer to variables or methods defined in the current or an
enclosing block's scope:

» Thekeywordt hi s refersto the current scope.
» Thekeyword super refersto the immediately enclosing scope.

e Thekeyword gl obal refersto the top-level scope of the macro script.

The following script illustrates the use of these keywords:

a = "top\n";

foo() {
a = "mddle\n";
bar () {

= "bottom n";
t ext Ar ea. set Sel ect edText (gl obal . )
t ext Ar ea. set Sel ect edText (super. a
/1 equival ent to textArea. set Sel ect edText (this.a):
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t ext Area. set Sel ect edText (a);

bar () ;
%oo();

When the script is run, the following text isinserted in the current buffer:

top
m ddl e
bottom

Implementing Classes and Interfaces

As discussed in the macro example in Chapter 14, A Dialog-Based Macro, scripted objects can
implicitly implement Javainterfaces such as Act i onLi st ener . For example:

nmyRunnabl e() {

run() {
Systemout.printin("Hello world!'");

return this;

Runnabl e r = myRunnabl e();
new Thread(r).start();

Frequently it will not be necessary to implement all of the methods of a particular interface in order
to specify the behavior of a scripted object. To prevent BeanShell from throwing exceptions for
missing interface methods, implement thei nvoke() method, which is called when an undefined
method is invoked on a scripted object. Typically, the implementation of this method will do
nothing, as in the following example:

i nvoke(nethod, args) {}
In addition to the implicit interface definitions described above, BeanShell permits full-blown
classes to be defined. Indeed, almost any Java class definition should work in BeanShell:
class Cons {

/1 Long-live LISP!

oj ect car;

oj ect cdr;

rplaca(Object car) {

this.car = car;
}

rpl acd(Obj ect cdr) {
this.cdr = cdr;
}

Debugging Macros

Here are afew techniques that can prove helpful in debugging macros.

ldentifying Exceptions
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An exception is a condition reflecting an error or other unusual result of program execution that
requires interruption of normal program flow and some kind of special handling. Java has arich
(and extensible) collection of exception classes which represent such conditions.

jEdit catches exceptions thrown by BeanShell scripts and displays them in adialog box. In addition,
the full traceback is written to the activity log (see Appendix B, The Activity Log for more
information about the activity log).

There are two broad categories of errors that will result in exceptions:
» Interpreter errors, which may arise from typing mistakes like mismatched brackets or missing
semicolons, or from BeanShell's failure to find a class corresponding to a particular variable.

Interpreter errors are usually accompanied by the line number in the script, along with the cause
of the error.

» Execution errors, which result from runtime exceptions thrown by the Java platform when
macro code is executed.

Some exceptions thrown by the Java platform can often seem cryptic. Nevertheless, examining
the contents of the activity log may reveals clues as to the cause of the error.

Using the Activity Log as a Tracing Tool

Sometimes exception tracebacks will say what kind of error occurred but not where it arose in the
script. In those cases, you can insert calls that log messages to the activity log in your macro. If the
logged messages appear when the macro is run, it means that up to that point the macro is fine; but
if an exception islogged first, it means the logging call islocated after the cause of the error.

To write a message to the activity log, use the following method of the Log class:

e public static void log(int urgency, Object source, Object
message) ;

See the documentation for the Log class for information about the method's parameters.

The following code sends atypical debugging message to the activity log:

Log. | og(Log. DEBUG, BeanShell . cl ass,

"counter = + counter);

The corresponding activity log entry might read as follows:

[ debug] BeanShell: counter = 15

Using message dialog boxes as a tracing tool

If you would prefer not having to deal with the activity log, you can use the Macr os. message()
method as a tracing tool. Just insert calls like the following in the macro code:

Macr os. nessage(vi ew, "traci ng");
Execution of the macro is halted until the message dialog box is closed. When you have finished

debugging the macro, you should delete or comment out the debugging calls to
Macr os. nessage() inyour final source code.
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Chapter 16. BeanShell Commands

BeanShell includes a set of commands; subroutines that can be called from any script or macro. The
following is a summary of those commands which may be useful within jEdit.

Note

Java classes in plugins cannot make use of BeanShell commands directly. However, these
commands can be called from BeanShell code that is part of aplugin, for example the
snippetsinacti ons. xm , or any BeanShell scripts shipped with the plugin and loaded
on startup.

Output Commands

void cat(String fil enane);
Writesthe contents of f i | enane to the activity log.
void javap(String | Object | dass target);

Writes the public fields and methods of the specified class to the output stream of the current
process. Requires Java 2 version 1.3 or greater.

void print(arg);

Writes the string value of the argument to the activity log, or if run from the Console plugin, to
the current output window. If ar g isan array, pr i nt runsitself recursively on the array's
elements.

File Management Commands

void cd(String dirnane);

Changes the working directory of the BeanShell interpreter to di r narre.
void cp(String fronFile, String toFile);
CopyfronFil etotoFil e.

void dir(String dirnane);

Displays the contents of directory di r nane. The format of the display issimilar to the Unix | s
-1 command.

void nmv(String fronFile, String toFile);
Movesthefilenamed by fronFil etot oFi | e.
File pathToFile(String fil enane);

Create aFi | e object corresponding tof i | enamnre. Relative paths are resolved with reference
to the BeanShell interpreter's working directory.

voi d pwd(void);

Writes the current working directory of the BeanShell interpreter to the output stream of the
current process.
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e void rm(String pathnane);

Deletes the file name by pat hnane.

Component Commands

o« JFrane frame(Conponent frane);

Displays the component in atop-level JFr ane, centered and packed. Returnsthe JFr ane
object.

e nject load(String fil enane);
Loads and returns a serialized Java object fromf i | enarne.

« void save(Conponent conponent, String fil enane);
Saves conponent inseridized formtofi | enane.

« Font set Font (Conponent conp, int ptsize);

Set the font size of conponent to pt si ze and returns the new font.

Resource Management Commands

« URL getResource(String path);

Returns the resource specified by pat h. An absolute path must be used to return any resource
available in the current classpath.

Script Execution Commands

« Thread bg(String fil enane);

Run the BeanShell script named by f i | enamne in acopy of the existing namespace and in a
separate thread. Returnsthe Thr ead object so created.

« void exec(String cndline);

Start the external process by calling Runt i ne. exec() oncndl i ne. Any output is directed
to the output stream of the calling process.

« (bject eval (String expression);

Evaluatesthe string expr essi on as aBeanShell script in the interpreter's current namespace.
Returns the result of the evaluation of nul | .

e bsh. This run(String fil enane);

Run the BeanShell script named by f i | enane in acopy of the existing namespace. The return
value represent the object context of the script, allowing you to access its variables and methods.

« void setAccessibility(boolean flag);

Ifflagistrue, BeanShell scripts are alowed to change and modify private variables, and call
private methods. The default isf al se.
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« void setStrictJava(bool ean fl ag);

Ifflagistrue, BeanShell scripts must follow a much more strict, Java-like syntax, and are
not able to use the convenience features described in the section called “BeanShell's
Convenience Syntax”.

« void source(String fil enane);

Evaluates the contents of f i | enane as aBeanShell script in the interpreter's current
namespace.

BeanShell Object Management Commands

« bind(bsh. This ths, bsh. Nanespace nanespace);
Binds the scripted object t hs to nanespace.
« void clear(void);

Clear al variables, methods, and imports from this namespace. If this namespace is the root, it
will be reset to the default imports.

e« bsh. This extend(bsh. This object);
Creates anew BeanShell Thi s scripted object that is a child of the parameter obj ect .
e« void inportQbject(Object object);

Import an object into this namespace. Thisis somewhat similar to Java 1.5 static classimports,
except you can import the methods and fields of a Java object instance into a BeanShell
namespace, for example:

Map map = new HashMap();
i nport Obj ect( map );
put ("foo", "bar");
print( get("foo") ); // "bar"
e bsh. This object(void);

Creates anew BeanShell Thi s scripted object which can hold data members. Y ou can use this
to create an object for storing miscellaneous crufties, like so:

crufties = object();

crufties.foo = "hello worl d";
crufties.counter = 5;

« set NameSpace(bsh. Nanespace nanespace);
Set the namespace of the current scope to nanespace.
e bsh. This super(String scopenane);

Returns areference to the BeanShell Thi s object representing the enclosing method scope
specified by scopenane. This method work similar to the super keyword but can refer to
enclosing scope at higher levelsin a hierarchy of scopes.

e void unset(String nane);

Removes the variable named by name from the current interpreter namespace. This has the
effect of “undefining” the variable.

104



BeanShell Commands

Other Commands

« void debug(void);
Toggles BeansShell's internal debug reporting to the output stream of the current process.
» get SourceFil el nfo(void);

Returns the name of the file or other source from which the BeanShell interpreter is reading.
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Part IV. Writing Plugins

This part of the user's guide covers writing plugins for jEdit.

Like jEdit itself, plugins are written primarily in Java. While this guide assumes some working
knowledge of the language, you are not required to be a Javawizard. If you can write a useful
application of any sizein Java, you can write a plugin.

This part of the user's guide was written by John Gellene <j gel | ene@yc. rr. conp.




Chapter 17. Introducing the Plugin
API

ThejEdit Plugin API provides aframework for hosting plugin applications without imposing any
requirements on the design or function of the plugin itself. Y ou could write an application that
performs spell checking, displays aclock or plays chess and turn it into ajEdit plugin. There are
currently over 50 released plugins for jEdit. While none of them play chess, they perform awide
variety of editing and file management tasks.

A detailed listing of available pluginsis available at plugins.jedit.org. You can aso find beta
versions of new pluginsin the “Downloads’ area of community.jedit.org.

Using the “Plugin Manager” feature of jEdit, users with an Internet connection can check for new or
updated plugins and install and remove them without leaving jEdit. See Chapter 9, Installing and
Using Plugins for details.

Requirements for “plugging in” to jEdit are as follows:

* Thisplugin must supply information about itself, such asits name, version, author, and
compatibility with versions of jEdit.

e The plugin must provide for activating, displaying and deactivating itself upon direction from
jEdit, typically in response to user input.

» The plugin may define actions, both explicitly with an action definition file, or implicitly by
providing dockable windows. Actions are small blocks of BeanShell code that jEdit will perform
on behalf of the plugin upon user request. They provide the “glue” between user input and
specific plugin routines.

By convention, plugins display their available actions in submenus of jEdit's Plugins menu;
each menu item corresponds to an action. The user can also assign actions to keyboard shortcuts,
toolbar buttons or entriesin the text area's right-click menu.

» The plugin may, but need not, provide a user interface.

If the plugin has avisible interface, it can be shown in any object derived from one of Java
top-level container classes: JW ndow, JDi al og, or JFr ame. jEdit aso provides a dockable
window API, which allows plugin windows derived from the JConponent classto be docked
into views or shown in top-level frames, at the user's request.

Plugins can aso act directly upon jEdit's text area. They can add graphical elementsto the text
display (like error highlighting in the case of the ErrorList plugin) or decorations surrounding
the text area (like the JDiff plugin's summary views).

e Plugins may provide arange of options that the user can modify to alter their configuration.

If aplugin provides configuration options in accordance with the plugin API, jEdit will make
them available in the Global Options dialog box.

« Whileit isnot required, plugins are encouraged to provide documentation.
As noted, many of these features are optional; it is possible to write a plugin that does not provide

actions, configuration options, or dockable windows. The majority of plugins, however, provide
most of these services.

Plugins and different jEdit versions
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Introducing the Plugin AP

As|jEdit continuesto evolve and improve, elements of the plugin APl may change with a new jEdit
release.

On occasion an API change will break code used by plugins, although efforts are made to maintain
or deprecate plugin-related code on atransitional basis. While the majority of plugins are unaffected
by most changes and will continue working, it is a good ideato monitor the jEdit change log, the
mailing lists and community.jedit.org for API changes so that you can update your plugin if
necessary.
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Chapter 18. Implementing a Simple
Plugin

There are many applications for the leading operating systems that provide a “ scratch-pad” or
“sticky note” facility for the desktop display. A similar type of facility operating within the jEdit
display would be a convenience. The use of dockable windows would allow the notepad to be
displayed or hidden with a single mouse click or keypress (if a keyboard shortcut were defined). The
contents of the notepad could be saved at program exit (or, if earlier, deactivation of the plugin) and
retrieved at program startup or plugin activation.

We will keep the capabilities of this plugin modest, but afew other features would be worthwhile.
The user should be able to write the contents of the notepad to storage on demand. It should aso be
possible to choose the name and location of the file that will be used to hold the notepad text. This
would allow the user to load other filesinto the notepad display. The path of the notepad file should
be displayed in the plugin window, but will give the user the option to hide the file name. Finally,
there should be an action by which asingle click or keypress would cause the contents of the
notepad to be written to the new text buffer for further processing.

The full source code for QuickNotepad is contained in jEdit's source code distribution. We will
provide excerpts in this discussion where it is helpful to illustrate specific points. Y ou are invited to
obtain the source code for further study or to use as a starting point for your own plugin.

How Plugins are Loaded

We will discuss the implementation of the QuickNotepad plugin, along with the jEdit APIs it makes
use of. But first, we describe how plugins are loaded.

As part of its startup routine, jEdit's mai n method calls various methods to load and initialize
plugins.

Additionally, plugins using the new jEdit 4.2 plugin API can be loaded and unloaded at any time.
Thisisagreat help when developing your own plugins -- there is no need to restart the editor after
making changes (see the section called “Reloading the Plugin” ).

Note that plugins using the older jEdit 4.1 API are still only loaded on editor startup, and unloaded
on editor exit. The jEdit 4.1 APl is deprecated and will not be described in this guide.

Plugins are loaded from fileswith the . j ar filename extension located inthej ar s subdirectories
of the jEdit installation and user settings directories (see the section called “ The jEdit Settings
Directory”).

For each JAR archive fileit finds, jEdit scansits entries and performs the following tasks:

» Addsto acollection maintained by jEdit anew object of type Pl ugi nJAR. Thisisadata
structure holding the name of the JAR archivefile, areferenceto the JARCl assLoader,and a
collection of plugins found in the archivefile.

» Loadsany properties defined in files ending with the extension . pr ops that are contained in
the archive. See the section called “The Property File’.

» Reads action definitions from any filenamed act i ons. xmi in the archive (the file need not
be at the top level). See the section called “The Action Catalog”.

* Parsesand loads the contents of any file named dockabl es. xml in the archive (the file need
not be at the top level). Thisfile contains BeanShell code for creating docking or floating
windows that will contain the visible components of the plugin. Not all plugins define dockable
windows, but those that do need adockabl es. xm file. See the section called “The Dockable
Window Catalog”.
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e Checksfor aclass name with a name ending with Pl ugi n. cl ass.

Such aclassisknown as a plugin core class and must extend jEdit's abstract Edi t Pl ugi n
class. Theinitialization routine checks the plugin's properties to see if it is subject to any
dependencies. For example, a plugin may require that the version of the Java runtime
environment or of jEdit itself be equal to or above some threshold version. A plugin can also
require the presence of another plugin.

If any dependency is not satisfied, the loader marks the plugin as “broken” and logs an error
message.

After scanning the plugin JAR file and loading any resources, anew instance of the plugin core
classis created and added to the collection maintained by the appropriate Pl ugi nJAR. jEdit then
calsthest art () method of the plugin coreclass. Thest ar t () method can perform
initialization of the object's data members. Because this method is defined as an empty “no-op” in
the Edi t Pl ugi n abstract class, a plugin need not provide an implementation if no unique
initialization is required.

Updating 4.1 plugins

Note that while jEdit 4.1 plugins were only loaded on startup, jEdit 4.2 plugins can be loaded at any
time. Asaresult, thest ar t () method needs to cope with being called at any time, and st op()
needsto fully clean up after the plugin. See the APl documentation for the Edi t Pl ugi n classfor
details.

The QuickNotepadPlugin Class

The major issues encountered when writing a plugin core class arise from the devel oper's decisions
on what features the plugin will make available. These issues have implications for other plugin
elements aswell.

»  Will the plugin provide for actions that the user can trigger using jEdit's menu items, toolbar
buttons and keyboard shortcuts?

»  Will the plugin have its own visible interface?
»  Will the plugin have settings that the user can configure?

»  Will the plugin respond to any messages reflecting changesin the host application's state?

Recall that the plugin core class must extend Edi t Pl ugi n. In QuickNotepad's plugin core class,
there are no special initialization or shutdown choresto perform, so we will not needast art () or
st op() method.

The resulting plugin core classis lightweight and straightforward to implement:

public class Qui ckNot epadPl ugi n extends EditPlugin {
public static final String NAME = "qui cknot epad”;
public static final String MENU = "qui cknot epad. nenu”;
public static final String PROPERTY_PREFI X
= "pl ugi n. Qui ckNot epadPl ugi n.";
public static final String OPTI ON_PREFI X
= "options. qui cknotepad.";

First we define afew static St r i ng data members to enforce consistent syntax for the name of
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properties we will use throughout the plugin.

public void createMenultens(Vector nenultens) {
menul t ens. addEl ement (GUI Utilities. | oadMenu( MENU)) ;
}

Thisimplementation of the Edi t Pl ugi n. cr eat eMenul t ens() method isvery typical. It
uses a jEdit utility function to create the menu, taking the list of actions from the
qui cknot epad property, and the label from quot enot epad. | abel .

If the plugin only had a single menu item (for example, an item activating a dockable window),
wewouldcal GUI Utilities. | oadMenul tem() instead of
GUIUtilities.loadMenu().

public void createOpti onPanes(Opti onshi al og od) {
od. addOpt i onPane( new Qui ckNot epadQpt i onPane());

Thisimplementation of the Edi t Pl ugi n. cr eat eQpt i onPanes() method adds anew
instance of Qui ckNot epadOpt i onPane to the given instance of the Global Optionsdialog
box.

The EditBus

Plugins register EBConponent instances with the Edi t Bus to receive messages reflecting
changesin jEdit's state.

The message classes derived from EBMessage cover the opening and closing of the application,
changes in the status of buffers and views, changes in user settings, as well as changes in the state of
other program features. A full list of messages can be found in the org.gjt.sp.jedit.msg package.

EBConponent sare added and removed with the Edi t Bus. addToBus() and
Edi t Bus. r enoveFr omBus() methods.

Typically, the EBConponent . handl eMessage() method isimplemented with one or morei f
blocks that test whether the message is an instance of a derived message class in which the
component has an interest.

i f(msg instanceof BufferUpdate) {
/1 a buffer's state has changed!

el se i f(msg instanceof Viewlpdate) {
/] a view s state has changed!

// ... and so on

If aplugin core class will respond to EditBus messages, it can be derived from EBPI ugi n, in
which case no explicitaddToBus( ) call isnecessary. Otherwise, Edi t Pl ugi n will sufficeasa
plugin base class. Note that QuickNotepad uses the latter.

The Property File

jEdit maintains alist of “properties’, which are name/value pairs used to store human-readable
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strings, user settings, and various other forms of meta-data. During startup, jEdit |oads the default
set of properties, followed by plugin properties stored in plugin JAR files, finally followed by user
properties.

Some properties are used by the plugin API itself. Others are accessed by the plugin using methods
inthej Edi t class.

Property files contained in plugin JARs must end with the filename extension . pr ops, and have a
very simple syntax, which the following exampleillustrates:

# Lines starting with '# are ignored.
name=val ue
anot her . nane=anot her val ue
| ong. property=Long property value, split over \
several lines
escape. property=New i nes and tabs can be inserted \
using the \'t and \n escapes
backsl ash. property=A backsl ash can be inserted by witing \\.

Now we look at the Qui ckNot epad. pr ops file which contains properties for the QuickNotepad
plugin. Thefirst type of property datais information about the plugin itself; these are the only
properties that must be specified in order for the plugin to load:

# general plugin information

pl ugi n. Qui ckNot epadPl ugi n. act i vat e=def er

pl ugi n. Qui ckNot epadPl ugi n. nane=Qui ckNot epad

pl ugi n. Qui ckNot epadPl ugi n. aut hor =John CGel | ene

pl ugi n. Qui ckNot epadPl ugi n. versi on=4. 1

pl ugi n. Qui ckNot epadPl ugi n. docs=Qui ckNot epad. ht m

pl ugi n. Qui ckNot epadPl ugi n. depend. O=j edit 04. 02. 10. 00

These properties are described in detail in the documentation for the Edi t Pl ugi n class and do not
require further discussion here.

Next in the file comes a property that sets the title of the plugin's dockable window. Dockable
windows are discussed in detail in the section called “ The Dockable Window Catalog”.

# dockabl e wi ndow nane
qui cknot epad. tit| e=Qui ckNot epad

Next, we see menu item labels for the plugin's actions. Actions are discussed in detail in the section
called “The Action Catalog”.

# action | abels

gui cknot epad. | abel =Qui ckNot epad

qui cknot epad. choose-fil e. | abel =Choose notepad file

qui cknot epad. save-fil e.l abel =Save notepad file

gui cknot epad. copy-to-buffer. | abel =Copy notepad to buffer

Next, the plugin's menu is defined. See the section called “ The QuickNotepadPlugin Class’.

# application menu itens

qui cknot epad. menu. | abel =Qui ckNot epad

qgui cknot epad. nenu=qui cknot epad - qui cknot epad. choose-file \
qui cknot epad. save-fil e qui cknot epad. copy-t o-buffer

We have created a small toolbar as a component of QuickNotepad, so file names for the button icons
follow:

# plugin tool bar buttons
qui cknot epad. choose-fil e.i con=Cpen. png
qui cknot epad. save-fil e.icon=Save. png
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qui cknot epad. copy-to-hbuffer.icon=Edit. png

The menu item labels corresponding to these icons will also serve as tooltip text.
Finally, the properties file set forth the labels and settings used by the option pane:

# Option pane | abels

opt 1 ons. qui cknot epad. | abel =Qui ckNot epad

options. qui cknot epad. file=File:

options. qui cknot epad. choose-fi | e=Choose

options. qui cknot epad. choose-file.title=Choose a notepad file
options. qui cknot epad. choose- f ont =Font :

options. qui cknot epad. showfilepath.title=Di splay notepad file path

# Initial default font settings
options. qui cknot epad. showfi | epat h=true
opti ons. qui cknot epad. f ont =Monospaced
options. qui cknot epad. f ont styl e=0
options. qui cknot epad. f ont si ze=14

# Setting not defined but supplied for conpl eteness
options. qui cknot epad. fil epat h=

Updating 4.1 plugins

jEdit 4.2 plugins are distinguished from jEdit 4.1 plugins by the presence of the

pl ugi n. name. act i vat e property. If this property is set, the plugin is treated like a jEdit 4.2
plugin. Usualy, this property should be set to def er . See the API documentation for the

Edi t Pl ugi n classfor details.

The Action Catalog

Actions define procedures that can be bound to a menu item, atoolbar button or a keyboard

shortcut. Actions are short scripts written in BeanShell, jEdit's macro scripting language. These
scripts either direct the action themselves, delegate to a method in one of the plugin's classes that
encapsulates the action, or do alittle of both. The scripts are usually short; elaborate action protocols
are usually contained in compiled code, rather than an interpreted macro script, to speed execution.

Actions are defined by creating an XML fileentitled act i ons. xm and placing it in the plugin
JARfile.

Theact i ons. xmi file from the QuickNotepad plugin looks as follows:
<?xm version="1.0"7?>
<! DOCTYPE ACTI ONS SYSTEM "acti ons. dtd">

<ACTI ONS>
<ACTI ON NAME="qui cknot epad. choose-fil e">
<CODE>
wm get Dockabl e( Qui ckNot epadPl ugi n. NAME) . chooseFi |l e();
</ CCDE>
</ ACTI ON>

<ACTI ON NAME=" qui cknot epad. save-file">
<CODE>
wm get Dockabl e( Qui ckNot epadPl ugi n. NAME) . saveFil e();
</ CODE>
</ ACTI ON>

<ACTI ON NAME=" qui cknot epad. copy-to-buffer">
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<CODE>
wm get Dockabl e( Qui ckNot epadPl ugi n. NAME) . copyToBuffer();
</ CODE>
</ ACTI ON>
</ ACTI ONS>

Thisfile defines three actions. They use the current view's Dockabl eW ndowivanager object
and the method get Dockabl e() to find the QuickNotepad plugin window and call the desired
method.

When an action is invoked, the BeanShell scripts address the plugin through static methods, or if
instance datais needed, the current Vi ew, its Dockabl eW ndowvanager , and the plugin object
return by the get Dockabl e() method.

If you are unfamiliar with BeanShell code, you may nevertheless notice that the code statements
bear a strong resemblance to Java code, with one exception: the variable vi ewis never assigned
any value.

For complete answersto this and other BeanShell mysteries, see Part 111, “Writing Macros’; two
observations will suffice here. First, the variable vi ewis predefined by jEdit's implementation of
BeanShell to refer to the current Vi ew object. Second, the BeanShell scripting language is based
upon Java syntax, but allows variables to be typed at run time, so explicit types for variables need
not be declared.

A formal description of each element of theact i ons. xm file can be found in the documentation
of the Act i onSet class.

The Dockable Window Catalog

ThejEdit plugin API uses BeanShell to create the top-level visible container of a plugin's interface.
The BeanShell codeis contained in afile named dockabl es. xnml . It usualy is quite short,
providing only a single BeanShell expression used to create a visible plugin window.

The following example from the QuickNotepad plugin illustrates the requirements of the datafile:
<?xm version="1.0"?>
<! DOCTYPE DCOCKABLES SYSTEM "dockabl es. dtd">

<DOCKABLES>
<DOCKABLE NAME="(qui cknot epad" >
new Qui ckNot epad(vi ew, position);
</ DOCKABLE>
</ DOCKABLES>

In this example, the <DOCKABLE> element has a single attribute, the dockable window's identifier.
This attribute is used to key a property where the window title is stored; see the section called “ The
Property File".

The contents of the <DOCKABLE> element itself is a BeanShell expression that constructs a new
Qui ckNot epad object. Thevi ewand posi ti on are predefined by the plugin API asthe view
in which the plugin window will reside, and the docking position of the plugin.

A formal description of each element of thedockabl es. xm file can be found in the
documentation of the Dockabl eW ndowianager class.

The QuickNotepad Class

Here is where most of the features of the plugin will be implemented. To work with the dockable
window AP, the top level window will be aJPanel . The visible components reflect asimple
layout. Inside the top-level panel we will place ascroll pane with atext area. Above the scroll pane
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we will place a panel containing asmall tool bar and alabel displaying the path of the current
notepad file.

We have identified three user actions that need implementation here: chooseFi | e(),

saveFi |l e(),andcopyToBuf f er () . Asnoted earlier, we also want the text areato changeiits
appearance in immediate response to a change in user options settings. In order to do that, the
window class must respond to aPr oper t i esChanged message from the EditBus.

Unlike the EBPI ugi n class, the EBConponent interface does not deal with the component's
actual subscribing and unsubscribing to the EditBus. To accomplish this, we use apair of methods
inherited from the Java platform's JConponent class that are called when the window is made
visible, and when it is hidden. These two methods, addNot i f y() andr enoveNoti fy(), are
overridden to add and remove the visible window from the list of EditBus subscribers.

We will provide for two minor features when the notepad is displayed in the floating window. First,
when afloating plugin window is created, we will give the notepad text areainput focus. Second,
when the notepad if floating and has input focus, we will have the Escape key dismiss the notepad
window. An Ancest or Li st ener and aKeyLi st ener will implement these details.

Hereisthelisting for the data members, the constructor, and the implementation of the
EBConponent interface:

public class Qui ckNotepad extends JPanel
i mpl ement s EBConponent
{

private String fil enaneg;
private String defaultFilenang;
private View view,

private bool ean fl oating;

private Qui ckNot epadText Area text Area,;
private Qui ckNot epadTool Panel t ool Panel ;

/1
/1 Constructor
/1

public Qui ckNotepad(View view, String position)
{
super (new Bor der Layout () ) ;

this.view = view,
this.floating = position.equal s(
Dockabl eW ndowivanager . FLOATI NG) ;

this.filename = jEdit.getProperty(
Qui ckNot epadPI ugi n. OPTI ON_PREFI X
+ "filepath");
if(this.filename == null || this.filenane.length() == 0)

this.filenanme = new String(jEdit.getSettingsDirectory()
+ File.separator + "gn.txt");

j Edit.set Property(Qui ckNot epadPl ugi n. OPTI ON_PREFI X
+ "filepath",this.filenane);

this.defaul tFilename = new String(this.filenane);

t hi s. t ool Panel = new Qui ckNot epadTool Panel (this);
add( Bor der Layout . NORTH, this.tool Panel);

i f(floating)
this.setPreferredSi ze(new D nmensi on(500, 250));

t ext Area = new Qui ckNot epadText Area();

t ext Ar ea. set Font ( Qui ckNot epadOpt i onPane. nakeFont () ) ;
t ext Ar ea. addKeyLi st ener (new KeyHandl er ());

t ext Ar ea. addAncest or Li st ener (new Ancest or Handl er () ) ;
JScrol | Pane pane = new JScrol | Pane(text Area);
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add( Bor der Layout . CENTER, pane);
readFil e();

~~ —

/

/ Attribute methods

/

/1 for tool Bar display
public String getFilenane()

return fil enane;

EBComnponent i npl ement ati on

~ I~ — ~—
~ I~

public void handl eMessage( EBMessage nessage)
{

i f (message instanceof PropertiesChanged)

propertiesChanged();

private void propertiesChanged()
{
String propertyFilename = jEdit. getProperty(
Qui ckNot epadPI ugi n. OPTI ON_PREFI X + "filepath");
i f(!defaultFilename. equal s(propertyFil enane))
{
saveFil e();
t ool Panel . properti esChanged();
defaul t Fi |l enanme = propertyFil enane. cl one();
filenane = defaul tFil enane.clone();
readFil e();

}
Font newFont = Qui ckNot epadOpti onPane. makeFont () ;
i f(!newFont. equal s(textArea. getFont()))

t ext Ar ea. set Font ( newFont) ;
text Area.invalidate();

}
/1 These JConponent nethods provide the appropriate points
/1 to subscribe and unsubscribe this object to the EditBus

public void addNotify()
{

super. addNoti fy();
Edi t Bus. addToBus(t hi s);

public void renmoveNotify()

saveFil e();
super.remveNotify();
Edi t Bus. r enoveFr onBus(t hi s);
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Thislisting refersto a Qui ckNot ebook Text Ar ea object. It is currently implemented as a
JText Ar ea with word wrap and tab sizes hard-coded. Placing the object in a separate class will
simply future modifications.

The QuickNotepadToolBar Class

Thereis nothing remarkabl e about the toolbar panel that is placed inside the Qui ckNot epad
object. The constructor shows the continued use of items from the plugin's propertiesfile.

public class Qui ckNot epadTool Panel extends JPanel

{
private Qui ckNot epad pad;
private JLabel | abel;
?ubl i ¢ Qui ckNot epadTool Panel (Qui ckNot epad gnpad)
pad = gnpad;
JTool Bar tool Bar = new JTool Bar () ;
t ool Bar . set Fl oat abl e(fal se);
t ool Bar. add( nakeCust onBut t on( " qui cknot epad. choose-fil e",
new Acti onLi stener () {
public void actionPerformed(Acti onEvent evt) ({
Qui ckNot epadTool Panel . t hi s. pad. chooseFi |l e();
}
t ool Bar . add( makeCust onmBut t on( " qui cknot epad. save-file",
new Acti onLi stener() {
public void actionPerformed(ActionEvent evt) {
| Qui ckNot epadTool Panel . thi s. pad. saveFil e();
t ool Bar. add( nakeCust onBut t on( " qui cknot epad. copy-to-buffer",
new Acti onLi stener () {
public void actionPerformed(Acti onEvent evt) ({
Qui ckNot epadTool Panel . t hi s. pad. copyToBuffer();
1) ,
| abel = new JLabel (pad. get Fi |l ename(),
Swi ngConst ant s. Rl GHT) ;
| abel . set For egr ound( Col or. bl ack) ;
| abel . set Vi si bl e(j Edit. getProperty(
Qui ckNot epadPIl ugi n. OPTI ON_PREFI X
+ "showfilepath").equal s("true"));
thi s. set Layout (new Border Layout (10, 0));
t hi s. add( Bor der Layout . WEST, t ool Bar);
t hi s. add( Bor der Layout . CENTER, | abel);
t hi s. set Bor der ( Bor der Fact ory. cr eat eEnpt yBorder (0, 0, 3, 10));
}
}

The method makeCust onBut t on() provides uniform attributes for the three toolbar buttons
corresponding to three of the plugin's use actions. The menu titles for the user actions serve double
duty astooltip text for the buttons. Thereisalso apr operti esChanged() method for the
toolbar that sets the text and visibility of the label containing the notepad file path.

The QuickNotepadOptionPane Class

Using the default implementation provided by Abst r act Opt i onPane reduces the preparation of
an option pane to two principal tasks: writinga_i ni t () method to layout and initialize the pane,
and writinga_save() method to commit any settings changed by user input. If a button on the
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option pane should trigger another dialog, such asaJFi | eChooser or jEdit's own enhanced
VFSFi | eChooser Di al og, the option pane will also have to implement the Act i onLi st ener
interface to display additional components.

The QuickNotepad plugin has only three options to set: the path name of the file that will store the
notepad text, the visibility of the path name on the tool bar, and the notepad's display font. Using the
shortcut methods of the plugin API, the implementation of _i ni t () lookslikethis:

public class Qui ckNot epadOpti onPane extends Abstract Opti onPane
i mpl enents Acti onLi st ener

private JText Fi el d pat hNamne;
private JButton pickPat h;
private FontSel ector font;

public void _init()

showPat h = new JCheckBox(j Edit. get Property(
Qui ckNot epadPI ugi n. OPTI ON_PREFI X
+ "showfilepath.title"),
j Edit. get Property(
Qui ckNot epadPl ugi n. OPTI ON_PREFI X + "show-fil epath")
.equal s("true"));
addConponent ( showPat h) ;

pat hNane = new JText Fi el d(j Edit. get Property(
Qui ckNot epadP! ugi n. OPTI ON_PREFI X
+ "filepath"));
JButton pickPath = new JButton(j Edit. getProperty(
Qui ckNot epadPI ugi n. OPTI ON_PREFI X
+ "choose-file"));
pi ckPat h. addAct i onLi st ener (thi s);

JPanel pat hPanel = new JPanel (new Border Layout (0, 0));
pat hPanel . add( pat hNane, Bor der Layout. CENTER);
pat hPanel . add( pi ckPat h, Bor der Layout . EAST) ;

addConponent (j Edi t. get Property(
Qui ckNot epadP! ugi n. OPTI ON_PREFI X + "file"),
pat hPanel ) ;

font = new Font Sel ect or (makeFont ());

addConponent (j Edi t . get Propert y(
Qui ckNot epadPI ugi n. OPTI ON_PREFI X + "choose-font"),
font);

Here we adopt the vertical arrangement offered by use of the addConponent () method with one
embellishment. We want the first “row” of the option pane to contain atext field with the current
notepad file path and a button that will trigger afile chooser dialog when pressed. To place both of
them on the same line (along with an identifying label for the file option), we create aJPanel to
contain both components and pass the configured panel to addConponent () .

The _i ni t () method uses properties from the plugin's property file to provide the names of 1abel
for the components placed in the option pane. It also uses a property whose name begins with
PROPERTY_PREFI X as a persistent dataitem - the path of the current notepad file. The elements
of the notepad's font are also extracted from properties using a static method of the option pane
class.

The _save() method extracts data from the user input components and assigns them to the
plugin's properties. The implementation is straightforward:
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public void _save()

j Edit.set Property(Qui ckNot epadPl ugi n. OPTI ON_PREFI X
+ "filepath", pathNane.getText());
Font _font = font.getFont();

j Edi t set Property(QM ckNot epadPl ugi n. OPTI ON_PREFI X
"font" font.getFam ly());
j Edi t set Property(QJl ckNot epadPl ugi n. OPTI ON_PREFI X
"fontsize", String.valueCO(_font.getSize()));
j Edi t set Property(Qn ckNot epadPl ugi n. OPTI ON_PREFI X
"fontstyle", String.valueO(_font.getStyle()));
j Edi t set Property(Qﬂ ckNot epadPl ugi n. OPTI ON_PREFI X
+ "showfilepath", String.val ued (showPath.isSelected()));

The class has only two other methods, one to display afile chooser dialog in response to user action,
and the other to construct a Font object from the plugin's font properties. They do not require
discussion here.

Plugin Documentation

While not required by the plugin API, ahelp fileis an essential element of any plugin written for
public release. A single web pageis often all that is required. There are no specific requirements on
layout, but because of the design of jEdit's help viewer, the use of frames should be avoided. Topics
that would be useful include the following:

» adescription of the purpose of the plugin;

» an explanation of the type of input the user can supply through its visible interface (such as
mouse action or text entry in controls);

» aligting of available user actions that can be taken when the plugin does not have input focus,
e asummary of configuration options;

» information on development of the plugin (such as a change log, alist of “to do” items, and
contact information for the plugin's author); and

 licensing information, including acknowledgments for any library software used by the plugin.

Thelocation of the plugin's help fileis stored inthe pl ugi n. Qui ckNot epad. docs property;
see the section called “The Property File”

Compiling the Plugin

We have aready outlined the contents of the user action catal og, the properties file and the
documentation file in our earlier discussion. The final step isto compile the source file and build the
archive file that will hold the class files and the plugin's other resources.

Publicly released plugins include with their source amakefilein XML format for the Ant utility.
The format for this file requires few changes from plugin to plugin. Here is the version of
bui | d. xm used by QuickNotepad and many other plugins:

<proj ect name="Qui ckNot epad" defaul t="dist" basedir=".">

<property nane="jedit.install.dir" value="../.."/>
<property nane="jar.nane" val ue="Qui ckNotepad.jar"/>

<property nane="install.dir" value=".."/>
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<path id="project.class.path">
<pat hel enment location="${jedit.install.dir}/jedit.jar"/>
<pat hel ement | ocation="."/>

</ pat h>

<target nane="conpile">
<j avac
srcdir="."
deprecati on="on"
i ncl udeJavaRunti me="yes"
>

<cl asspath refid="project.class.path"/>
</javac>
</target>

<target name="dist" depends="conpile">
<nkdir dir="${install.dir}"/>
<jar jarfile="${install.dir}/${jar.nane}">
<fileset dir=".">
<i ncl ude nanme="**/*_ cl ass"/>
<i ncl ude name="**/*_ props"/>
<i nclude name="**/*_htm"/>
<i ncl ude name="actions.xm"/>
<i ncl ude name="dockabl es. xm "/ >
</fileset>
</jar>
</target>
</ proj ect >

For afull discussion of the Ant file format and command syntax, you should consult the Ant
documentation site. Modifying this makefile for a different plugin will likely only require three
changes:

e the name of the plugin;

» the choice of compiler (made by inserting and deleting the comment character * #' ); and

» theclasspath variablesfor j edi t . j ar any pluginsthis one depends on.

Reloading the Plugin

Once you have compiled your plugin using the 4.2 API you will need to reload it to test it. Follow
these stepsto reload your plugin without restarting jEdit:
e From the Plugins menu open the Plugin Manager.

» Onthe Manage tab uncheck Hide libraries. Thiswill allow you to see plugins that are not
loaded.

» Find the plugin on the Manage tab and uncheck it. Thiswill unload the plugin. You will get a
warning if this plugin does not support dynamic reloading. If you get that warning you will need
to restart jEdit to reload the plugin until the plugin is converted over to the 4.2 API.

e Recheck the plugin to reload it.

The jEdit web site contains a macro and an Ant task that can be used as an aternative method for
dynamically reloading plugins.
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If you have reached this point in the text, you are probably serious about writing a plugin for jEdit.
Good luck with your efforts, and thank you for contributing to the jEdit project.
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Chapter 19. Plugin Tips and
Techniques

Bundling Additional Class Libraries

Recall that any class whose hame ends with Pl ugi n. cl ass iscalled aplugin core class. JAR
fileswith no plugin core classes are also loaded by jEdit; the classes they contain are made available
to other plugins. Many plugins that rely on third-party class libraries ship them as separate JAR
files. The libraries will be available inside the jEdit environment but are not part of a general
classpath or library collection when running other Java applications.

A plugin that bundles extra JAR files must list theminthe pl ugi n. cl ass nane.jars
property. See the documentation for the Edi t Pl ugi n classfor details.
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